
Izabela Major

Examples of applying 

the finite element method 

in building engineering 

by means 

of the ADINA software

Maciej Major

Krzysztof Kuliński

Examples of applying 

the finite element method 

in building engineering 

by means 

of the ADINA software

Częstochowa 2024

CZESTOCHOWA UNIVERSITY OF TECHNOLOGY



Czestochowa University of Technology 

Izabela Major 
Maciej Major 
Krzysztof Kuliński 

Examples of applying the finite element method  

in building engineering by means of  

the ADINA software 

Part  one 

 

The Publishing Office of Czestochowa University of Technology 

Częstochowa 2024 



 

Reviewers 

Krzysztof Cichocki, PhD. Eng. Prof. ANS 
Jacek Selejdak, PhD. Eng. Assoc. Prof. PCz 

Proofreading 

Zdzisława Tasarz 

Technical editor 

Robert Świerczewski 

Cover design 

Dorota Boratyńska 

The work cannot be copied or distributed in its entirety or in fragments by means of 
electronic, mechanical, copying, recording and other devices, including its uploading 
and distribution in digital form both on the Internet and local networks without written 
consent of the copyright holder. 

e-ISBN 978-83-7193-997-6 

DOI: 10.17512/CUT/9788371939976 

 Copyright by the Publishing Office of Czestochowa University of Technology  
Częstochowa 2024 

 Copyright by Izabela Major, Maciej Major, Krzysztof Kuliński, Częstochowa 2024 

 
Creative Commons Attribution Non Commercial 4.0 International (CC BY-NC 4.0) 
https://creativecommons.org/licenses/by-nc/4.0/legalcode 
Częstochowa 2023 

 

The Publishing Office of Czestochowa University of Technology 
Poland, 42-200 Częstochowa, al. Armii Krajowej 36 B 
Editorial Team – wydawnictwo.pcz.pl, phone 34 325 04 80, e-mail: wydawnictwo@pcz.pl 
Distribution – sklep.pcz.pl, phone 34 325 03 93, e-mail: sklep@pcz.pl 



Examples of applying the finite element method in building engineering by means of the ADINA software 

 

TABLE OF CONTENTS 

Foreword  .............................................................................................................  4 

The basics of modeling using the finite element method  ....................................  6 

An introduction to using the software  .................................................................  17 

Characteristics of main menu tabs in the ADINA-Structures software  ..............  21 

Characteristics of main menu toolbar buttons used across examples  .................  44 

Examples regarding building statics and dynamics 

● Statics 

○ Two-dimensional problems 

Example 1 

A simply supported beam. Determining the maximum bending moment  

and displacement  .................................................................................................  51 

Example 2 

A truss system. Displacement of a node due to the action of a concentrated  

force. Determining zero force members  .............................................................  79 

Example 3 

Deformations of a planar frame with rigid connections at nodes subjected  

to the variable external force  ...............................................................................  99 

○ Three-dimensional problems 

Example 4 

The spatial model of a single-clamped round bar subjected to stretching  ..........  152 

Example 5 

The spatial shell construction. Calculations including the irregular shape of  

surface load  .........................................................................................................  195 

● Dynamics 

Example 6 

Vibration frequency and vibration modes of a T-shape cantilever beam  ...........  238 

Example 7 

A clamped-clamped beam with a stepped cross-section. Definition of objects  

with a specific life cycle in the computational model  .........................................  268 

Summary  .............................................................................................................  329 

References  ...........................................................................................................  330 



Examples of applying the finite element method in building engineering by means of the ADINA software 

4 

FOREWORD 

The present book has been written for students of building engineering and mechan-

ics, who during their studies have contact with computer simulations which for their 

calculations use the finite element method in the ADINA software. The included 

examples provide simultaneous step-by-step presentation of both the operation of 

the software and the options related to the modeling of a given physical phenomenon. 

The examples address the application of both static and dynamic analysis for the 

calculation of flat rods and surface elements, as well as the calculation of spatial 

volumetric elements. The book intends to present selected techniques for modeling 

physical phenomena, and to facilitate work in the environment of the ADINA  

software. 

The finite element method, abbreviated as FEM, is a basic element of computer- 

-supported design. This method is eagerly used by engineers from all over the world 

who handle computer simulations, and the popularity of the method results from the 

fact that calculations may involve any model shape for a given type of analysis. We 

tend to be unaware that some items which are in everyday use have been produced 

on the basis of earlier analyses using FEM-type software. Such items include, e.g., 

shoe insoles, hard helmets protecting the head against impact, motors, etc. Of course, 

besides computer simulations, before a product reaches its receiver, experimental 

tests are performed on a prototype of a given element, in order to check and confirm 

the correctness of the analysis which uses the simulations. Moreover, the projects 

may be way larger, in example: testing the stability of a suspended rope bridge during 

blowing wind. The design team decides how complex and detailed the prepared 

model should be, with models which are more representative of the actual object 

meaning higher quality of the performed calculations. It should be kept in mind that 

larger models which are more representative of the actual object result in a directly 

proportional increase in the amount of time necessary to perform the calculations.  

In a way, this is a drawback; however, in such a moment it should be contemplated 

how many simplifications should have been made, and how performed calculations 

should be time costly in reference to the standard method (a piece of paper and  

a pen). One should also realize how much the results are different from reality when 

simplifications are used. When performing advanced simulations, it is required that 

the machine on which the calculations are to be performed should have proper  

technical parameters; otherwise, the calculations will most likely end with an error. 

The use of computers for FEM analyses requires certain financial expenses;  

however, for design offices, the return is relatively fast, since both the pace and  

the scope of possibilities in the performed simulations increase rapidly. 
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There are numerous commercial computer programs which use the finite element 

method for calculations. The most popular programs used all over the world include: 

ANSYS, ABAQUS, and SOLIDWORKS. These are advanced and complex pro-

grams which allow calculations for almost any structures. ADINA is also a commer-

cial program with a similar level of advancement; however, it is mostly popular  

in the United States, albeit a certain part of European universities and industrial 

structures eagerly use it to perform their own simulations. 
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THE BASICS OF MODELING USING  

THE FINITE ELEMENT METHOD 

The finite element method is currently the basic tool of the computer-supported de-

sign process. It is a method which involves determining the approximated solutions 

of partial differential equations. Each time, the fundamental element of a performed 

numerical analysis is usually some kind of a physical phenomenon or process, since 

why mathematical formulation of the problem should be developed in the very  

beginning. Subsequently, the choice of a proper mathematical model for producing 

a specific solution decides about the usefulness of the yielded results and their match 

with the actual model. It should be pointed out from the get-go that results do not 

match the reality perfectly, as models with a high degree of complexity are affected 

by the adopted simplifications, the size and number of finite elements, the type of 

the selected elements, etc. 

In the ADINA software, before the design of a given object/phenomenon is initiated, 

it is necessary to choose a preprocessing module in which the alleged model will be 

created. The software is divided into 5 basic modules, i.e.: 

– ADINA Structures 

– ADINA Thermal 

– ADINA CFD 

– ADINA EM 

– Post-Processing 

The first four modules, i.e.: “ADINA Structures”, “ADINA Thermal”, “ADINA 

CFD” and “ADINA EM”, are the so-called preprocessing modules, in which con-

struction of the adopted model/phenomenon takes place. The individual modules 

correspond to the following types of the examined physical phenomena: 

“ADINA Structures” – enables a linear/nonlinear analysis of stresses/deformations 

in rod elements, surface elements (2D and 3D) and volumetric elements (3D), both 

in statics and dynamics. Moreover, it is possible to declare the nonlinearity of  

a material model, assume heavy strains, perform a contact analysis, etc. 

“ADINA Thermal” – enables an analysis of convection, heat flow, and thermal  

radiation in surface (2D and 3D) and volumetric (3D) elements. Moreover, it is  

possible to study the phenomena of freezing and thawing of materials. 

“ADINA CFD” – a module related to an analysis of sound wave propagation  

phenomena as well as the flow of compressible and incompressible liquids. The cal-

culations can be performed for any shape of the surface restraining – the flow of 

liquids/the propagation of waves. When studying the flow of liquids, both laminar 

and turbulent flow can be examined. 
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“ADINA EM” – a module related to the analysis of electromechanical phenomena. 

In this module, it is possible to define the phenomena of electrical conductivity,  

examine the propagation of an electromagnetic field, etc. 

Although these modules are accessible separately in the software, the internal options 

enable the combination of various types of analyses. It is possible to simultaneously 

analyze two modules, e.g., analyze stresses affected by the heat supplied to the model 

– a combination of the “ADINA Structures” and “ADINA Thermal” modules. 

The last module is “Post-Processor” – this is the module in which the results are 

analyzed in the form of maps, graphs, and tables. This module also enables the com-

bination of various types of analyses from various pre-processing modules when 

preparing an identical model in terms of geometric and material characteristics. 

Once a proper computational model of the preprocessor has been selected, declara-

tion of geometric parameters is initiated. Geometry of the model may be completed 

directly in the ADINA software, or by means of any CAD-type software, keeping in 

mind that the file extension of the model exported from the CAD software must cor-

respond to the importing software – ADINA. The supported file extensions include: 

*.brep, *.dat, *igs, *.nas, *.stl and *.stp. When declaring a geometric model, keep  

in mind that it should provide the best possible representation of the actual object; 

however, it should be kept in mind that the representation should not be overdone 

either, i.e., in a 10-meter concrete slab, there is no sense in declaration of an opening 

with a diameter of several millimeters. The same applies to roughness, which is not 

taken into account either. One should also consider dividing the model into parts, if 

it has axes of symmetry, and perform an analysis of only one part of this symmetric 

object. Sample divisions of models are presented in Figures 1 for a planar plate and 

in Figure 2 for a volumetric element. 

 

 
Fig. 1. Delimiting an area to be analyzed for a stretched flat plate. Dash-dotted lines  

define the symmetry of a given object; a) a model prior to division,  

b) a separated area which should have been taken to the analysis 

Models usually use axial symmetry for planar models, plane symmetry for spatial 

models, and cyclic symmetry mainly for rotor elements. The division into subareas 

by means of symmetry or other delimiting criteria enables a more precise analysis  

of a model, and enables reducing the requirements in the form of: free disk space, 

the amount of main computer memory necessary to perform the calculations, and  

the use of the processor. 

a) b) 
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Fig. 2. a) a model of a cube with cut out openings subjected to triaxial stretching.  

b) a separated fragment to be analyzed upon applying the abovementioned  

division of the model into symmetric elements 

Declaration of the model or models of materials creating the examined object is  

commenced after selection of a proper model analysis module and declaration of the 

geometric model. To this end, the ADINA software offers over 30 various types  

of material models. The software includes the following material models: elastic, 

plastic, thermal, with variable and constant creep characteristics, rubber and foam, 

geotechnical, and others. Each of the material models also has its subcategories,  

and when the user is not satisfied with any of the definitions prepared in advance, 

they can access a definition tool, in which they can define their own type of material 

on the basis of strain and stress curves. 

The next step is to declare boundary conditions. Boundary conditions can be assigned 

to a point, a line, a surface, a 3D figure, as well as a single node or finite element.  

It should be noted that boundary conditions are indispensable for the numerical  

analysis, otherwise the model becomes unstable or improperly defined and the  

calculations are terminated. This is especially significant for objects in which  

the applied external forces balance themselves out. In spite of the equilibrium of 

forces (e.g., Fig. 1), an object should be modeled so as to take away the necessary 

number of degrees of freedom from the body, to ensure blocking the motion of this 

body on all the considered axes of the coordinate system, but also retaining the free-

dom of body deformations due to the action of forces. In accordance with the above, 

for flat objects, it is necessary to take away 3 degrees of freedom, while for spatial 

objects this number increases to 6. 

During one’s work, it is also possible to encounter symmetric and antisymmetric 

boundary conditions. For elements such as those in Figure 1, it is necessary to assume 

symmetric boundary conditions in accordance with Figure 3. 

a) b) 
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A – linear fixity 

Ux = 0 

 

C – linear fixity 

Uy = 0 

Fig. 3. Symmetric boundary conditions 

In accordance with the contents of Figure 3 (compared to Figure 1), it is clear  

that the X direction should be blocked for the line marked with the letter “A”, while 

the Y direction should remain unblocked, since deformations occur in this place due 

to the applied load. A similar case applies to the line marked with the letter “C”; 

however, the blocked directions is Y, and the unblocked direction is X, since on the 

line of the axis of symmetry overlapping the X axis of the global coordinate system 

some deformations occur due to the load. Despite it results in taking away 2 degrees 

of freedom the analyzed object is unable to move. Discussed approach is the simplest 

for defining symmetric boundary conditions, which leaves the possibility of free  

rotations for finite elements along lines marked with “A” and “C”. Despite that,  

in other different cases it may have been required to block the rotation in regard  

to the Z axis pointing upwards/downwards at the crossing of X and Y axes.  

After the declaration of boundary conditions, the next step is usually to define and 

declare loads. Almost all types of loads have been implemented in the ADINA soft-

ware, including the possibility to create their combinations. Since all the definitions 

in the software are without physical units, one should take extra care to ensure unit 

compliance. The easiest way is to operate on simple metric unit system (SI) or on 

imperial system, respectively. In practice, the SI system is the one used the most 

frequently.  

Having a computational model created this way (virtual bar/shell/body defined,  

all boundary conditions, all loads, the number of time steps, the functions of the load 

factor over time, possible load combinations etc.) one progresses onto 3 final steps 

before the performance of calculations. The first among these steps is to define 

groups of elements – in the next step, this allows for assigning to a given geometric 

object a material model, a cross-section, the type of calculations (small/large dis-

placements), the moment of bringing an element to “life” or excluding it from the 

analysis in a given time unit, etc. 

The penultimate step is to divide geometry for the finite elements. The compliance 

of numerical calculations with the actual values of the examined characteris-

tics/properties of a phenomenon/process depends mainly on discretization of the area 

(mesh density). It should be kept in mind that adopting a mesh with the same dimen-

sions for the whole model may lead to errors in calculations. The mesh should have 

increased density in locations such as the corners, the connections of two different 

elements (made of two various material models), contact joints, places in direct  
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vicinity of a concentrated force, etc. According to that it is clear that in all places 

where a concentration of stresses occurs, the number of mesh elements should have 

been increased. 

As already previously mentioned, the finite element method involves the determina-

tion of approximated solutions of partial differential equations, therefore, using  

a coarse mesh (relatively large mesh size) for the whole model, it may end in under-

estimation of stresses in the place of their concentration. Figure 4 presents the  

essence of the problem.  

 

 
 

 
 

Fig. 4. a) an example of the application of a coarse mesh, b) results for a coarse mesh,  

c) an example of the application of a densified mesh. d) results for a densified  

mesh. The “jagging” of the map of stresses results from the fact of not using  

the smoothing function (an intentional action) 

In accordance with what can be seen in the figures, the numerical values of stresses 

for a coarse mesh are underestimated, in contrast to an increased mesh density.  

It should be noted that the absence of map smoothing function use was intentional, 

in order to show how much the final results, depend on the regularity of the shape  

of finite elements, as well as on their size. In the case of Figure 4b, it is apparent  

that the colors of the presented resultant map do not change smoothly, passing from 

one finite element onto the other in a visible steps. These visible steps are connected 

a) b) 

c) d) 
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with the adopted too large mesh size. For the mesh in Figure 4d, the change in map 

colors between one finite element and the other is rather smooth, while the effects  

of “jagging” are associated with the irregularity of the mesh elements. 

When the smoothing technique function is applied, the resultant map of stresses  

ultimately looks like in Figure 5. It should be kept in mind that the division into finite 

elements in the case of planar (2D) and spatial (3D) models proceeds in FEM soft-

ware semiautomatically – i.e., the user inputs the final parameters (the density of 

mesh division for finite elements) for the edges defining a given surface or 3D figure, 

then the software performs discretization of the inner area of the input body by means 

of complex algorithms. 

 

 

Fig. 5. A smoothened map of reduced stresses for a densified mesh of finite elements 

The dimensions of finite elements are closely related to the division for elements 

declared by the user, and to the automatic internal discretization adopted by the soft-

ware. The density of dividing the edges of the body adopted by the user usually 

causes the mesh created inside a given object to have a mesh size no larger than  

the largest assumed segment of discretization. 

Finite elements are implemented when proper discretization of the area has been 

adopted-depending on type of analysis and material, finite elements should have  

assigned required properties. In example in static analysis there should have been 

adopted at least: Young’s modulus and Poisson’s ratio. The precision of calculations 

depends to a certain extent on the adopted finite element type (Fig. 6). For example, 

when designing a displacements of a beam made of a circular tube, results may 

highly deviate from reality pyramidal (4-node) spatial finite elements (3D) are used. 

When the same mesh is used, but with the implementation of prismatic (8-node) 

objects, the results will correspond to the actual displacement values (errors will  

only be related to the approximation of the solution). Generally, the higher the  

number of nodes in a simple finite element the higher the precision of reproducing 

the actual behavior of the model resulting in a greater precision of calculations.  

On the other hand, simultaneously the time needed to complete the calculations  
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increases significantly as well as the demand for computer RAM size and processor 

unit speed. Moreover, some of the elements better describes one material, whereas 

the other ones describe better different material. Before choosing a given finite  

element type, it is necessary to get acquainted with guidelines regarding its usage. 

These guidelines can be found in technical documentation attached to the software. 

 

 

Fig. 6. Types of finite elements available in the ADINA software 

When implementing the finite elements, the user can choose among three types of 

division of the internal structure of an object: 

– “Rule-Based” – causes the elements to be evenly distributed. This option is  

usually applicable when the designed element has a simple shape. 

As can be seen in the Figure 7, the applied mesh is regular and symmetric in the case 

of quarter circles, while the sizes and shapes of some finite elements are incorrect. 

Calculation of the abovementioned model would cause erroneous results in certain 

points of the model. 
 

 

Fig. 7. Using the “Rule-Based” function with 4-node elements and forced  

triangular shapes of finite elements: “Preferred Cell Shape: Triangular” 

One-dimensional finite elements 

Flat finite elements (2D) 

Spatial finite elements (3D) 
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 “Free-Form” – any distribution of the elements (adopted automatically by the 

software on the basis of the input density of the division of edges describing  

an object).  

That option works for larger projects with highly irregular shapes. Using this option 

in the model prepared in Figure 7 results in a division like in Figure 8. 

 

 

Fig. 8. Using the “Free-Form” function with 4-node elements 

As seen in Figure 8, the applied division is irregular in the case of quarter circles. 

Moreover, similarly to the model of Figure 7, some of the finite elements have  

different shapes, which further down the line can lead to erroneous calculations in 

certain areas of the model. 

– “Degenerated” – the last option which enables considering a surface with 3 

vertices (triangular surfaces, quarter circles, etc.) as a surface in which one of 

the vertices is a main node, from which a mesh extends towards the remaining 

nodes specified by the user’s density of division. The use of this function is 

presented in Figure 9. 
 

 

Fig. 9. Using the “Triangular Surfaces Treated as Degenerate”  

function adopting 4-node finite elements 

It should be kept in mind that during the implementation of finite elements, a very 

important factor contributing to the correctness of future calculations is to fine-tune 
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the discretization of the area, so that the transition between the consecutive elements 

would be smooth, and moreover, the discretized area would not contain elements 

with strongly deformed shapes.  

Finally, it should be added that semiautomatic generation of a mesh by the software 

entails certain problems. One of them is the fact that the user inputs the density of 

division only for the envelope of a given body, having no impact on the distribution 

of finite elements within certain areas of this body. With the geometric model  

presented in Figure 10, the area should be densified near the application of the  

concentrated force. 
 

 
Fig. 10. A flat geometric model with an adopted concentrated force 

The preparation of a regular mesh with elements in the shape of rectangles for the 

input area, and the division of the entire envelope by rectangular finite elements  

with identical dimensions and a regular mesh, cause the resulting mesh to look like 

in Figure 11. 
 

 
Fig. 11. A regular mesh of rectangular elements 

For a very large object, the above schematic drawing causes the necessity to use  

a finer mesh. It is possible to increase the mesh density for the entire model, which 

automatically results in greater demand for the processing power of the computer, 

and in increasing the demand of the main memory. It is also possible to increase 

density on a single edge or several edges, allowing for resolution of the problem.  

A sample view of a finite element mesh with applied increased density of a single 

edge is presented in Figure 12. 

In accordance with the figure above, when the software is ordered to use rectangular 

elements, it becomes impossible to discretize an area by means of the selected  

elements, which results in the appearance of triangular elements. Figure 13 presents  

the density increase of a mesh when several edges have been selected, so that the 

mesh would only contain rectangular elements. 
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Fig. 12. Applying the densification of a single edge 

An analysis of the Figures 12 and 13a, 13b suggest that Figure 13b presents the most 

preferable form of meshing. However, in such a case it is necessary to consider 

whether the elements located in close vicinity to the central point of the object are 

not too large. 
 

        

Fig. 13. a) densification of the upper and lower edge of an object near a concentrated 

force, b) densification of 4 edges near the places of stress concentration 

When it is required for the zone near the concentrated force to be densified in  

a circular/elliptical manner, once again we obtain the presence of triangular ele-

ments. Moreover, in order to enable the preparation of such a model, it is necessary 

to create two separate geometric objects, i.e., a rectangle with a cut out circle/ellipse, 

and a part of an ellipse. The essence of the problem is presented in Figure 14. 

 

 

Fig. 14. Elliptical densification of a mesh 

In Figure 14, object 1 and object 2 are two subareas of the main object, which is  

a bar in the form of a rectangle. The preparation of the abovementioned model  

is quite complicated, especially when the object is drawn in the ADINA software.  

object 1 

object 2 

densified 

edge 

a) b) 
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In such a case, the fastest method is to use CAD-type software, and import the pre-

pared model into the ADINA software.  

It is less problematic to prepare a model consisting of two rectangles in the ADINA 

software (Fig. 15); however, this also entails the problem of the generation of trian-

gular elements along the contact of two areas – an area with an increased mesh  

density, and an area with standard mesh. 

 

 

Fig. 15. Increase of mesh density in one of the rectangles of an existing model 

In accordance with the abovementioned considerations, it should be assumed that  

it is not always possible to prepare a model from an identical type of elements. More-

over, already at the stage of inputting the geometric model, the user must be able to 

predict the places of the model in which concentration of stresses may occur, and 

create the geometric model in a way which enables mesh density increase for smooth 

transition of the dimensions of finite elements as well as prevent creation of these 

elements with irregular shape. 

In addition, when analyzing the computational model, if only possible, separate  

partial calculations should have been performed which would enable checking  

the correctness of the adopted assumptions. It should be kept in mind that a machine 

is capable of calculating virtually anything, if all the criteria concerning declaration 

have been fulfilled; however, the final assessment of the usefulness of the results  

and the correctness of the performed calculations always constitutes the responsibil-

ity of designers modeling a given subject. Therefore, it is required for the design 

team to have knowledge on the studied subject, and to have knowledge regarding  

the operation of a given computational tool. 

object 1 

object 2 
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AN INTRODUCTION TO USING THE SOFTWARE 

First work on the ADINA software started in 1974. The pioneer working on the soft-

ware was Klaus-Jürgen Bathe, who in 1975 was given a position in the Department 

of Mechanical Engineering at the Massachusetts Institute of Technology. In 1986, 

the ADINA R&D, Inc. company was founded in order to support the development 

of the ADINA system. Almost 30 years have passed since the founding of the com-

pany and the commercial release of the first software. During this period, the system 

of the software was in constant development, undergoing multiple modifications 

with respect to the input of the geometric model as well as the optimization of  

the solver and the addition of new functional modules. The entirety of the present 

publication is based onto versions up to ADINA AUI 23.0.0. It is recommended  

for the users to have at least the same or newer version of the software, since older 

versions of the software may not include certain functions used in the examples,  

or the location of certain functions may be different from what is presented. 

In order to run the software for the first time (having installed the ADINA suite),  

on a computer with the Windows system go to the “Start menu/All Programs/Bentley 

Engineering/ADINA CONNECT Edition/ADINA 23.00 User Interface (AUI)” or 

use the “AUI 23.00.exe” desktop shortcut. Alternatively, go to the location where 

the software is installed, e.g., “C:\ProgramFiles\Bentley\ADINA\23.00\bin\AUI.exe”. 

After running the software, a welcome window will appear, following which the 

software is ready to use. A view of the main window of the program is presented  

in Figure 16. 

In order to increase the clarity of further presentation of the program’s functionality, 

the background display parameters have been changed to white. The way in which 

this is accomplished will be described in a moment.  

The user’s communication with the software is quite simple, i.e., similarly to other 

programs in the Windows system, settings/selections are accomplished in menu tabs, 

by means of buttons, command lines, etc. 

Areas of communication with the program are presented in Figure 17. 

The areas of communication listed in Figure 17 stand for, respectively: 

1. upper menu tabs 

2. button and list box toolbars 

3. computational model tree 

4. main modeling window 

5. program command line window 

6. list of program messages 

7. list of current session messages 
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Fig. 16. Main program window 

 

Fig. 17. Areas of the user’s communication with the software. Description in the text 

The upper menu tabs enable basic operations, such as saving/loading/closing, etc. of 

the program. The tabs also include all options possible to be input, related to object 

modeling – modeling both the shape geometry as well as computational parameters. 

All the available tabs for “ADINA Structures” along with the functions will be  

discussed in a separate paragraph. 

The button and list box toolbars include the most frequently used options involving 

the modeling of shape geometry and computational parameters.  
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All the buttons for “ADINA Structures” and their functions are described in the 

ADINA primer, which can be accessed from “Help/Primer (pdf)…”. Buttons  

frequently used in the problem topics of this book will be described in the further 

separate chapter. 

Note: Not every function of the program has its equivalent in the form of a button/ 

combo box. 

The computational model tree comprises a list of currently used definitions and dec-

larations, i.e., declarations of external forces, boundary conditions, material proper-

ties etc. and definitions of parameters related to the shape of the model. The functions 

in the tree can be used to modify the existing assumptions without the necessity to 

search for functions among buttons or upper menu tabs. 

The main modeling window – this place shows in graphical form the model geome-

try along with other parameters, like, e.g., the applied external forces, the adopted 

boundary conditions, etc. 

Note: Not all parameters may be displayed. For example, it is not possible to display 

the parameters of the initial state. In example it is not possible to display initial 

stresses graphically in the preprocessing module. 

The program command line enables inputting computational and geometric param-

eters, material properties and others by means of specialized commands. A full list 

of commands can be found in the help files of the ADINA software. 

List of program messages is a window in which the program uses text messages to 

present the function type which has currently been input, whether the opening/saving 

of a file was successful, etc. 

The list of current session messages gives a possibility to read, what information are 

being saved in a temporary “xxx.ses” file. Each operation done in the ADINA envi-

ronment i.e. change of the title, assigning material properties, input of geometry 

points, lines etc. are being reflected as a list of commands appended in the “xxx.ses” 

file. The “xxx.ses” file is a temporary file stored in the “C:\Users\Current User\ 

AppData\Local\Temp\” folder. As soon as user saves a project file through the 

“File/Save as…” also the “xxx.ses” file is saved in the same location where the pro-

ject save has been done. That action prevents the “xxx.ses” file to be deleted after 

the computer reboot. 

As mentioned before, the background color of the main modeling window can be 

changed. In order to do this, choose “Edit/Background Color…” from the upper 

menu tabs. When a new window opens, choose one of the predefined colors from 

the selectable list, or click the “C” button and choose a color from the color palette 

of the Windows system. These windows are presented in Figure 18. 
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Note: In the drop-down list of the “Specify Background Color of Graphic Window” 

window, it is possible to enter colors of the RGB system using keyboard, e.g., 

#FFFFFF. 
 

 

 

Fig. 18. a) A selectable list window; b) Choosing a color from the color palette  

of the Windows system after clicking the “C” button in the “Specify  

Background Color of Graphic Window” window 

Regarding the examples provided in the present book, each time after running the 

program make sure that in the area of buttons and list boxes toolbar, the following 

drop-down list 

 

 

 
has the “ADINA Structures” function active. 

In order to go to the module responsible for displaying the results, choose the “Post- 

-Processing” option from the same drop-down list. 

 

 

 
Note: Before commencing execution of the examples, it is recommended for the 

reader to once again get acquainted with the descriptions of the upper menu tabs  

and their functions, as well as the descriptions of individual buttons. 

We wish you fruitful work, dear reader! 

a) b) 
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CHARACTERISTICS OF MAIN MENU TABS  

IN THE ADINA-STRUCTURES SOFTWARE 

Starting from the top left side, all functions of the software will be presented along 

with short descriptions. 

The “File” window 

 

 
1. “New” → open a new model window 

2. “Open” → open a file: a model (database) “*.idb”, a model (database) with  

a command line “*.in”, session file “*.ses”, plot with a command line “*.plo”,  

a porthole results file “*.por”, plot file (database) “*.pdb”,  

3. “Open Batch” → open and process an input file written as commands 

4. “Save” → save the current file 
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5. “Save As…” → save the current file as… 

6. “Import NASTRAN…” → import a data file from the NASTRAN software 

7. “Import IGES…” → import a data file from a CAD-type environment 

8. “Export NASTRAN…” → export model file to a format supported by the  

NASTRAN software 

9. “Export Universal…” → export file to the *.unv format 

10. “Initial Mapping…” → load a file containing initial conditions 

11. “Thermal Mapping” 

– “Define…”→ define a new thermal mapping file containing temperature  

and temperature gradient loads 

– “Delete…” → removes a thermal loads and gradients specified in a file from 

current model  

12. “Restart File Info…” → list of information about existing restart file  

13. “Batch Continue” → continue reading and processing a batch-type input file 

14. “Stop Recording” → stops recording steps taken by the user in the session 

“*.ses” file 

“Macro Mapping…” → assign a text file as a macro mapping file 

15. “Print…” → opens a window with print properties 

16. “Print Preview” → opens a print preview window for the current model 

17. “Snapshot/Movie Save” 

– “Snapshot (vector)…” → saves the current image as a vector graphic type 

– “Snapshot (bitmap)…” → saves the current image as a bitmap form 

– “Movie (bitmap)…” → saves the frames from a current movie created in  

the model as a movie picking bitmap graphics in the .avi file 

– “Movie (vector)…” → saves the frames from a current movie created in  

the model as a movie picking vector graphics in the .avi file 

18. “Snapshot/Movie Setup” 

– “PostScript…” → gives the possibility of specifying parameters associated 

with the PostScript plotting system 

– “Adobe Illustrator…” → gives the possibility of specifying parameters  

associated with the Adobe Illustrator plotting system 

19. “Fast Graphics” 

– “Save Animation (ani)…” → saves current model animation in the .ani  

format 

– “Load Animation (ani)…” → loads animation from an .ani file into the  

current model window 

20. “C:\Users\ …” → a list of few previously used files 

“Exit” → exit the program 
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The “Edit” window 

 

 
1. “Undo” → undo the last performed operation 

2. “Redo” → redo a previously undone operation 

3. “Copy” → gives the possibility of copying model/plot fragment 

4. “Erase” → selected item is erased from the graphic display (The item is not  

deleted from the model!) 

5. “Memory Usage…” → specify the amount of memory used by the program 

6. “Background Color…” → the background color of the main window 

7. “Graphics System…” → display mode options 

8. “Graphics Window Settings…” → display options for the main window of  

the model 

9. “Environment Settings…” → options allowing adjusting program interface  

settings  

10. “Preferences” → interface preferences like prompting for labels, confirmation 

via space-bar for picking objects etc. 

The “View” window 
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1. Toolbars 

– “General” → a bar with general buttons 

– “Modeling” → a bar with buttons responsible for modeling 

– “Adina-M” → a bar with buttons related to the Adina-M module 

– “Display” → a bar with display buttons 

– “Results” → a bar with buttons related to the results 

– “Macro” → a bar with buttons related to recorded macros 

– “Pick” → a bar with buttons related to pick/select items in the project 

– “Fast Graphics” → a bar with buttons related to fast graphics  

– “Reset” → resets the visibility of toolbars to the defaults settings 

2. “Module Bar” → a bar with analysis selection buttons 

3. “Status Bar” → toggles on/off status bar in the main window 

4. “Tree View” → a side bar specifying the characteristics of the model 

5. “Message Window” → toggles on/off the message window 

6. “Command Window” → toggles on/off the command line window 

7. “Session Window” → toggles on/off the session commands window 

8. “Customize…” → enables customizing the buttons of the existing toolbars 

The “Display” window 

 
 
1. “Redraw” → refresh the model drawing 

2. “Clear Window” → clear the main window of the program (the model is not  

deleted, becomes invisible) 
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3. “Graphics System Info” → information about project heading, current window 

width/height and plotting system 

4. “Geometry / Mesh Plot” 

– “Use Default” → show the model with default settings 

– “Use Zone…” → allow creating a mesh plot of a zone using default settings 

– “Use Style” → allow to create/specifies the style used for mesh plots 

– “Modify…” → modify parameters responsible of displaying parts of/whole 

model 

– “Change Zone” → change the displayed model area 

– “Define Style” → define the display style 

– “Select Groups” → select contact groups/elements to display 

– “General Element Connectivity…” → indicate connections between nodes  

for general elements 

5. “Boundary Conditions” 

– “Default” → show boundary conditions in the default style 

– “Custom…” → display settings for the boundary conditions 

6. “Load Plot” 

– “Use Default” → show model loads with default settings 

– “Use Style…” → show model loads using a style 

– “Modify…” → modify the style of the model loads 

– “Define Style…” → define the display style for the model loads 

7. “Band Plot” 

– “Create…” → create a plot with chosen properties for current model using 

user-defined or default style settings 

– “Modify…” → change of properties in an existing plot  

– “Define Style…” → various style options related to plot visualization 

8. “Highlight…” → highlight the selected fragment/part/whole model 

9. “Active Zone…” → specify the list of selected active areas 

10. “Color Zone…” → assign color to the area 

11. “Movie Shoot…” 

– “Rotation…” → create a movie through a rotation around the model 

– “Load Step” → record a movie in a specified time range 

– “Cut Plane…” → record the movement of a cut plane through the model 

– “Iso-Surface…” → record the movement of an iso-surface through the model 

12. “Movie Frame…” 

– “Define…” → define a single movie frame 

– “Show…” → show the movie in the specified frames range 

– “List…” → a list of created and stored movie frames 

– “Delete…” → delete a specified range of frames in a movie 

– “Remove All” → delete all movies in the current project file 
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13. “Animate…” → create an animation by specifying time intervals between the 

consecutive movie frames and movie cycles 

14. “Refresh” → refresh the model with the movie 

15. “Graph” 

– “Material Stress-Strain Curve…” → display a stress-strain graph for a selected 

material 

– “Time-Dependent Material Curve…” → display a graph for a time-dependent 

material 

– “Define User Data…” → define data for a graph with X and Y axes 

– “Plot User Data…” → display a XY graph from the defined data 

– “Modify…” → modify elements related to graph visualization 

– “List…” → a list of the user’s graphs along with defiend data 

– “Define Style…” → define the display style of the user’s graphs 

16. “Text” 

– “Define…” → displays a window for defining the user’s texts 

– “Draw…” → displays the selected text defined by the user on the screen with 

a possibility to change text attributes 

17. “Line segment” 

– “Define…” → displays a window for defining a line with the X- and Y-axis 

coordinate 

– “Draw…” → displays the selected line defined by the user on the screen with 

a possibility to change its attributes 

The “Control” window 
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1. “Heading…” → a window for entering the model heading  

2. “TMC Model…” → settings of a thermomechanical coupling analysis 

3. “Degrees of Freedom…” → specification of master boundary conditions used  

in the model 

4. “Time Function…” → set the options of load value factors in specified time 

intervals 

5. “Time Step…” → definition of total time steps and their intervals in performed 

analysis  

6. “Analysis Assumptions…”  

– “Fluid Structure Interaction…” → options related to interaction of ADINA 

structures with the ADINA CFD module 

– “Kinematics…” → specify the default formulation regarding calculations of 

displacements/rotations, strains etc. 

– “Mass Matrix…” → specify the type of mass matrix used for a dynamic  

analysis 

– “Rayleigh Damping…” → specify Rayleigh damping coefficients 

– “Modal Damping…” → specify modal damping factors for a mode superpo-

sition analysis 

– “Default Temperature Settings…” → settings related to initial model temper-

ature, prescribed temperature in time function, temperature gradient in regard 

to time function etc. 

7. “Solution Process…” → specify various settings related to the calculations/ 

solution of the model 

8. “Analysis Switch…” → allow to specify time, at which the current analysis will 

be switched into another one (i.e. from static to dynamic) 

9. “Solution Diagnostics…” → specify the amount of information related to solu-

tion and contact between elements stored in the output file 

10. “Solution Monitor…” → allows to define a variable/s being tracked during  

the solution 

11. “Miscellaneous Options…” → other options not listed above 

12. “Printout (.out)…” 

– “Volume…” → control of parameters stored in the output file, while working 

on a solution  

– “Result at Nodes…” → nodes selection, for which the information defined  

in “Volume…” will be stored in the output file 

– “Time Steps…” → the settings of time steps for which results are to be saved 

in the output file 



I. Major, M. Major, K. Kuliński 

28 

13. “Porthole (.por)…” 

– “Volume…” → control the options and data to be saved in results file 

– “Equilibrium Iteration Results…” → specifies options/parameters to be saved 

at equilibrium iterations 

– “Select Element Results…” → specifies options/parameters to be saved for 

3D solid elements in the results file 

– “Result at Nodes…” → specifies options/parameters to be saved for selected 

nodes in the results file 

– “Time Steps (Nodal Results)…” → an option for selecting time steps for 

which nodal results will be stored in the resultant file 

– “Time Steps (Element Results)…” → an option for selecting time steps for 

which element results will be stored in the resultant file 

14. “Nastran OP2” 

– “Output Options…” → options regarding data stored in the OP2 file 

– “Select Result Output…” → specifies parameters to be saved in the OP2 file 

– “Time Steps (Nodal Results)…” → an option for selecting time steps for 

which nodal results will be stored in the OP2 file 

– “Time Steps (Element Results)…” → an option for selecting time steps for 

which element results will be stored in the OP2 file 

15. “Energy View (.egy)…” → specifies displaying the output energy for whole 

model/whole model and all element groups/whole model and selected groups 

16. “Restart (.res) Options…” → options regarding the file for restarting calculations 

17. “Mapping (.map)…” → options for creating and formatting a mapping file 

18. “Miscellaneous File I/O” → specify an auxiliary file storage as well as input  

and output control 

19. Graph Variables Output… → options which allow to specify which variables 

will be saved during solution for plotting with the graph viewer 

The “Geometry” window 
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1. “Coordinate Systems…” → definition of a local coordinate systems 

2. “Points…” → specify points to create a model 

3. “Lines” 

– “Define…” → define a new model line 

– “Split…” → split the line into two separate lines with lengths specified by  

a non-dimensional length factor 

– “Extend…” → extends the existing line with specified options 

– “Thickness…” → line thickness 

4. “Surfaces” 

– “Define…” → define a new model surface 

– “Thickness…” → define the thickness of the input surface 

– “Check Orientation” → checks the inconsistency in the surfaces connection 

– “Delete All…” → deletes all unused surfaces from the model 

5. “Volumes” 

– “Define…” → define a new 3D figure in the model 

– “Delete All…” → delete all unused 3D figures from the model 

6. “Faces” 

– “Thickness…” → define surface thickness 

– “Face Link…” → create face links in order to generate consistent meshing  

of finite elements 

7. “Delete Geometry…” → window specifying delete of points, lines, surfaces, 

volumes etc. 

8. “Measure…” → an option for measuring the distance, angles, etc. 

9. “Transformations…” → an option for geometric transformations of the model 

(translation, rotation, scale etc.) 

10. “Spatial Functions” 

– “Line…” → define a linear variable function in space for a spline 

– “Surface…” → define a variable function describing the shape of a surface 

in space 

– “Volume…” → define a variable function describing the shape of a 3D figure 

in space 

11. “Tolerances…” → options regarding numerical tolerances 

12. “Domains…” → create domains for controlling coincidence checking  
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The “ADINA-M” window 

 

 
1. “Import Model…” → imports CAD file with appropriate .x_t or .x_b extension 

containing a 1/2/3D model 

2. “Import Step…” → imports CAD file with appropriate .stp extension containing 

surfaces/bodies 

3. “Define body…” → define a parameterized 3D figure, the so-called ‘body’ 

4. “Body Sweep…” → create a 3D figure by sweeping the surface 

5. “Body Revolve…” → create a 3D figure by revolving the surface around speci-

fied vector in space 

6. “Define Section Sheet…” → create a segment of a plate/layer 

7. “Boolean Operator…” → logical operations of a sum, difference, product, etc. 

for 3D figures  

8. “Body Modifier…” → modify the features of a 3D figure 

9. “Extend Sheet Body…” → extends sheet of a body 

10. “Thicken Sheet Body…” → makes sheet of a body thicker of slimmer 

11. “Trim Sheet Body…” → trims sheet of a body 

12. “Fill Holes in Bodies…” → Allow to create holes in sheet bodies 

13. “Remove Body Entities…” → removes points/edges from a body 

14. “Body Defeature…” → delete small features from a 3D body on the basis of  

the adopted criteria 
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15. “Midsurface Extraction…” → options for extracting a layer/plate from a thin-

walled 3D figure 

16. “Transform Faces…” → allow to use predefined by user transformations on 

body faces (move face through translation, rotate face through rotation etc.) 

17. “Split” 

– “Edge…” → split the edge of a 3D body into segments 

– “Face…” → split the surface of a 3D body into two separate surfaces on  

the basis of two points included in this surface 

18. “Options…” → options for checking the errors of 3D figures 

The “Model” window 

 
 
1. “Materials” 

– “Manage Materials…” → manage all the available materials 

– “List Material Info…” → a list of defined materials in the model 

– “Elastic” → (elastic materials) 

a) “Isotropic…” → define an isotropic material 
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b) “Orthotropic…” → define an orthotropic material 

c) “Nonlinear…” → define a material with nonlinear characteristics 

– “Plastic” → (plastic materials) 

a) “Bilinear…” → define a bilinear material 

b) “Multilinear…” → define a multilinear material 

c) “Mroz Bilinear…” → define a bilinear Mroz material 

d) “Orthotropic…” → define an orthotropic material 

e) “Gurson…” → define a Gurson material 

f) “Cyclic…” → define a cyclic material 

g) “Cast Iron…” → define a cast iron material 

– “Thermo” → (materials with thermal characteristics) 

a) “Isotropic…” → define an isotropic material 

b) “Orthotropic…” → define an orthotropic material 

c) “Bilinear Plastic…” → define a bilinear plastic material 

d) “Plastic Cyclic…” → define a plastic-cyclic material 

e) “Cast Iron…” → define a bilinear plastic material 

– “Creep” → (materials with creep characteristics) 

a) “Elastic…” → define an elastic material 

b) “Irradiation…” → define an irradiated material 

c) “Thermo-Bilinear-Plastic…” → define a bilinear plastic material with 

thermal characteristics 

d) “Thermo-Multilinear-Plastic…” → define a multilinear plastic material 

with thermal characteristics 

– “Creep Variable” → (materials with variable creep characteristics) 

a) “Elastic…” → define an elastic material 

b) “Thermo-Bilinear-Plastic…” → define a bilinear plastic material with 

thermal characteristics 

c) “Thermo-Multilinear-Plastic…” → define a multilinear plastic material 

with thermal characteristics 

– “Rubber/Foam” → (materials made of rubber/foam) 

a) “Ogden…” → define an Ogden material 

b) “Mooney-Rivlin…” → define a Mooney-Rivlin material 

c) “Sussman-Bathe…” → define a Sussman-Bathe material 

d) “Arruda-Boyce…” → define an Arruda-Boyce material 

e) “Eight Chain…” → define a eight chain rubber material 

f) “Hyperfoam…” → define a hyperfoam material 

– “Geotechnical” → (geotechnical materials) 

a) “Cam-Clay…” → define a Cam-Clay-type material model 

b) “Drucker-Prager…” → define a Drucker-Prager material 

c) “Curve Description…” → define a material by means of a described curve 

d) “Mohr-Coulomb…” → define a Mohr-Coulomb material 
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– “Others” → (the remaining materials) 

a) “Potential-based Fluid…” → define a potential-based fluid 

b) “Concrete…” → define a concrete-type material 

c) “Gasket…” → define a sealing material 

d) “Viscoelastic…” → define a viscoelastic material 

e) “Anand…” → define an Anand material 

f) “Shape Memory Alloy…” → define a shape memory alloy 

g) “Piezoelectric…” → define a piezoelectric material 

h) “Three-Network…” → define a three-network alloy 

i) “User Coded…” → define a material created by the user 

– “Stress-Strain Curve…” → a material defined by the stress-strain curve 

– “Stress-Strain Input Options…” → options regarding stress-strain material in-

terpretation etc. 

– “Porous Media Property…” → define the property of a porous material 

– “Spring Property” → define a spring with specific properties 

– “6-DOF Spring Property” → define a spring with specific properties, with 6 

degrees of freedom 

– “Beam Rigidity” → define beam rigidity 

2. “Cross-Sections…” → define cross-sections properties 

3. “Concentrated Masses…” → allow to assign concentrated masses on model  

entities or nodes 

4. “Concentrated Dampers…” → allow to assign concentrated dampers on model 

entities or nodes 

5. “Element properties” → (the characteristics of elements) 

– “Truss…” → define elements with a truss structure for lines or edges 

– “Beam…” → define a beam for lines or edges 

– “Isobeam…” → define an isobeam for lines or edges 

– “Pipe…” → define a pipe for lines or edges 

– “Plate…” → define a plate/layer for a surface 

– “Shell…” → define a shell for a surface 

– “2D Solid…” → define a layer element (constituting a cross-section of a 3D 

element) for a surface 

– “3D Solid…” → define a solid figure element for a 3D figure or ‘body’ 

– “2D Potential-based Fluid…” → define a potential-based fluid for a surface 

– “3D Potential-based Fluid…” → define a potential-based fluid for a 3D figure 

or ‘body’ 

– “1D General Element” → define characteristics for line- or edge-type  

elements 

– “2D General Element” → define characteristics for surface-type elements 

– “3D General Element” → define characteristics for 3D figure- or ‘body’-type 

elements 
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6. “Alignment Properties” → (the characteristics of elements) 

– “Translation Alignment…” → defines stiffness for translational elements 

alignment and prescribed translational alignment as a function of solution time  

– “Distance Alignment…” → defines stiffness for distance elements alignment 

and prescribed distance alignment as a function of solution time 

– “Rotation Alignment…” → defines stiffness for elements rotation alignment 

and prescribed rotation alignment as a function of solution time 

– “Triad Set…” → defines the initial orientation of triadsets, which are used  

by elements alignment 

– “Assign Triad Set…” → Assigns triad set to nodes of alignment elements 

7. “Boundary Conditions” → (boundary conditions) 

– “Define Fixity…” → creates a new boundary condition in the model 

– “Apply Fixity…” → assigns a boundary condition to an existing model entity 

– “Apply Fixity On Nodes…” → assigns a boundary condition to finite ele-

ments nodes 

– “Define End Release…” → define a release condition for the beam end 

– “FSI Boundary…” → defines a boundary conditions for fluid – structure  

interactions 

– “Potential Interface…” → define an interface between potential-based fluid 

elements and structural elements 

– “Surface Tension…” → define boundary conditions for surface tensions 

8. “Loading” → (loads) 

– “Apply…” → allow to add load to model entities 

– “Apply On Nodes/Elements…” → add a load to existing nodes or elements 

– “Load Options…” → specify the treatment of multiple loads added to nodes 

– “Load Case…” → define a load case for a linear static analysis 

– “Load Combination…” → define a load combination 

9. “Constraints” → (constraints/limitations) 

– “Constraint Equations…” → define constraints for geometry entities 

– “Constraint Equations (Multiple Slaves)…” → define constraints for multiple 

geometric entities, where one entity is a master entity and multiple entities  

are treated as slaves 

– “Constraint Equations (Nodes)…” → define constraints between nodes 

– “General Constraints (Nodes)…” → define generalized constraints for nodes 

– “Glue Mesh…” → allow to glue two dissimilar meshes together 

– “Glue Mesh Control…” → various options for controlling the glue mesh 

– “RBE3 Constraint…” → define Nastran RBE3 contraint 

– “Rigid Link Default Settings…” → settings regarding rigid links 

– “Rigid Links…” → define rigid links in the model 

– “Rigid Links (Nodes)…” → define rigid links between nodes 
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– “Ovalization Constraints…” → define ovalization constraints for pipe ele-

ments (at points) 

– “Ovalization Constraints (Nodes)…” → define ovalization constraints for 

pipe elements (at nodes) 

10. “Initial Conditions” → (initial conditions) 

– “Define…” → create a new initial condition 

– “Apply…” → apply the initial condition to the model entity 

– “Apply On Nodes…” → apply the initial condition on specified nodes of  

the model 

– “Rotational Velocity…” → creates and assigns the rotational velocity in the 

model 

– “Imperfection…” → define geometrical imperfections 

– “Geological Strain Field…” → define a ground strain field for 2D and 3D 

solid elements 

11. “Contact” → (contacts) 

– “Contact Version…” → specifies contact version used in contact modelling 

– “Contact Control…” → specifies options regarding behavior of the algorithm 

used in contact modelling 

– “Contact Group…” → create groups elements in contact 

– “Contact Surface…” → define a contact surface 

– “Contact Pair…” → define pairs of contacting elements 

– “Contact Search…” → automatically create a contact surface (3D) within  

a specified search distance 

– “Mesh Rigid Contact Surface…” → mesh surfaces including rigid contact  

between them 

– “Delete Mesh…” → deletes the rigid contact surface mesh 

– “Contact Surface Offset…” → define the offset for individual contact surfaces 

– “Variable Coulomb Friction…” → define friction between contact parts  

using Coulomb friction coefficient 

– “Contact Body…” → define the contact between ‘bodies’ 3D figures 

– “Contact Point…” → define a contact between points 

– “Drawbead…” → define drawbeads for a metal forming analysis 

– “Analytical Rigid Target…” → define parameters for an analytical rigid  

target contact analysis 

– “Contact Surface (Element Set)…” → create a contact surface from a set of 

elements 

– “Contact Surface (Node)…” → define a contact surface using nodes 

– “Contact Surface (Face Node)…” → define a contact surface by means of 

nodes related to a Face-type surface 

– “Result At Nodes…” → define nodes for which results are saved in the output 

file  
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12. “Cohesive Interface” → (cohesive interface) 

– “Define…” → define cohesive interfaces, splits the mesh during datafile  

generation or when rebuilding the model 

– “Properties…” → specifies various properties for cohesive interface 

– “Split Interface…” → define interfaces where mesh will be split 

13. “Bolt” → (bolt) 

– “Bolt Options…” → various options for bolt elements 

– “Bolt Sequence…” → define loads sequence applied on a bolt 

– “3D Bolt Plane…” → define a 3D plane for the direction of a bolt and its 

splitting 

14. “Cyclic Symmetry” → (cyclic symmetry) 

– “Control…” → options related to cyclic symmetry 

– “Boundaries…” → define cyclic symmetry boundary conditions 

– “Loads…” → specifies on which cyclic part subsequent loads act on 

15. “Fracture” → (a crack/fracture) 

– “Fracture Control…” → specifies various options for fracture analysis 

– “3D SVS Crack…” → define 3-D crack with SVS method used for calcula-

tion of stress intensity factors in 3-D analysis 

– “3D Crack Front (ADINA-M)” → (options related to 3D cracks) 

a) “Define…” → define a crack in the model 

b) “Subdivide…” → specify the finite element mesh density for a crack 

c) “Mesh Crack…” → create a mapping mesh for a crack 

d) “Mesh Body…” → create a free mesh for a crack ‘body’ 

e) “Quarter Point…” → controls the placement of mid-side nodes in elements 

adjacent to the crack-tip 

f) “Virtual Shift…” → define a virtual shift for a crack front 

– “Virtual Crack Extension…” → options related to virtual crack extension  

in fracture analysis 

– “Line Contours…” → define J-integral line contours  

– “2D Crack Propagation…” → crack propagation control data used in 2D  

analysis 

– “Crack Generator…” → a tool enabling the generation of an initial crack  

point and/or a crack pathway  

– “Singular Elements…” → define singularities for fracture analysis 

16. “Substructure” → (substructure) 

– “Define/Set…” → define a new substructure in current model 

– “Reuse…” → reuse a previously defined substructure 

– “From Element Group…” → create a new substructure from an existing  

element group 
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17. “Skew Systems” → (skew coordinate systems) 

– “Define…” → define a skew coordinate system 

– “Apply…” → apply a skew coordinate system for selected geometric  

elements 

18. “Orthotropic Axes System” → (a local coordinate system of the elements of  

orthotropic materials) 

– “Define…” → define axes of a local coordinate system for an orthotropic  

material 

– “Assign (Material)…” → assign axes of a local coordinate system to  

an orthotropic material 

– “Assign (Initial Strain)…” → assign initial strain orthotropic axes system  

to geometry or elements 

– “Specify To Elements (Material)…” → assign local orthotropic material  

coordinate system to specified finite elements 

– “Specify To Elements (Initial Strain)…” → assign local initial strain coordi-

nate system to specified finite elements 

19. “Shell Midsurface Nodes…” → specify 5 or 6 degrees of freedom for shell  

midsurface nodes 

20. “Phi Model Completion…” → a set of options completing the definition of  

characteristics for a potential-based fluid  

21. “Radiosity” → (direct matrix input) 

– “Radiosity Group…” → define radiosity groups 

– “Radiosity Surface…” → define radiosity surfaces on model geometry 

– “Meshing…” → creates mesh of radiosity surface in model geometry with 

selected properties 

– “Delete Mesh…” → deletes mesh on a radiosity surface 

– “Radiosity Surface (Element Set)…” → define radiosity surface using element 

edge or face sets 

– “Radiosity Surface (Node)…” → define radiosity surface using nodes 

22. “Direct Matrix Input” → (direct matrix input) 

– “Define…” → define direct input data included in matrices based on nodal 

degrees of freedom 

– “Apply…” → apply definitions of direct input data included in matrices 

23. “Rebuild” → rebuilds an existing model 
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The “Meshing” window 

 

 
1. “Element Groups…” → define a specific type of finite elements used with vari-

ous options 

2. “Modify Element Groups…” → modify properties of existing element groups  

in the model 

3. “Mesh Density” → (mesh density) 

– “Point…” → specify the size of division under finite elements at geometry 

points 

– “Line…” → specify the size of division under finite elements for geometry 

lines  

– “Surface…” → specify the size of division under finite elements for surface 

objects  

– “Volume…” → specify the size of division under finite elements for 3D  

geometry objects 

– “Edge…” → specify the size of division under finite elements for edges of  

a ‘body/ies’ 

– “Face…” → specify the size of division under finite elements for faces  

(surfaces) of ‘body/ies’ objects 

– “Body…” → specify the size of division under finite elements for 3D ‘bodies’ 
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– “Complete model…” → specify the size of elements into which a complete 

model will be divided 

– “Default Mesh Size…” → specify the default size of elements created in  

a model for new geometry 

– “Point Size…” → specify the size of finite elements at geometry points 

providing various options 

– “Mesh Size Function…” → specify a function for an element size located  

at X/Y/Z position 

– “At Locations…” → define the size of a mesh elements for specific places  

in the coordinate system for association with surfaces and ‘body’ 3D figures  

4. “Create Mesh” → (create a mesh) 

– “Point…” → generate nodes at geometry points 

– “Line…” → generate 1D elements on a line 

– “Surface…” → generate 2D finite elements on a surface 

– “Volume…” → generate 3D finite elements on a 3D figure 

– “Edge…” → generate 1D finite elements on edges 

– “Face…” → generate 2D finite elements on a ‘body’-type surface 

– “Body…” → generate 3D finite elements on a ‘body’-type 3D 

– “Body (Simulate Only)…” → adjusts division of the edges of a ‘body’ 3D 

figure in preparation for meshing 

– “Brick Dominant…” → generate a mesh of brick elements as dominant in  

a geometric 3D figure 

– “Lofted Body…” → generate a mapped mesh on lofted type of ‘body’ 

– “Brick Dominant…” → generate a brick-dominant mesh in a solid geometry 

‘body’ 

– “Element Spider…” → generate beam/truss elements between entities located 

on two different sides 

– “Shell Transition…” → generate shell transition elements between a shell  

and a 3D figure 

– “From Element-Face Set…” → generate mesh from element-face sets 

– “Options…” → assignment of meshing algorithm regarding ADINA version 

5. “Copy Mesh” → (copy a mesh) 

– “Body…” → copy a mesh from one ‘body’ 3D figure to another with a similar 

shape 

– “Triangulation…” → copy a mesh from the surface (‘face’) of a ‘body’ to 

another surface (‘face’) by means of triangulation technique 

– “List Triangulation…” → display a list of surfaces (‘faces’) which have  

a mesh copied by means of the triangulation technique 

– “Delete Triangulation…” → delete a copied mesh created with the use of  

the triangulation method 
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6. “Glue Mesh…” → glue dissimilar meshes between surfaces/’faces’ 

7. “Mesh Quality…” → checks the quality of created finite elements 

8. “Re-Mesh…” → once again create mesh on a selected region 

9. “Delete Mesh/Elements…” → delete mesh/finite elements from the selected 

model entities 

10. “Mesh Sweep…” → sweep 2D mesh elements to create 3D elements 

11. “Mesh Revolve…” → revolve 2D mesh elements to create 3D elements by 

means of revolving 2D elements around specified vector 

12. “Boundary Cells” → (boundary cells – connected with ADINA fluids analyses) 

– “Define…” → define boundary cells 

– “Create 3-D Mesh…” → create a 3D mesh from boundary cells 

13. “Feature Removal” → (the removal function) 

– “Body Cleanup…” → delete small features of a ‘body’ 3D figure before 

meshing 

– “Remove Edge…” → delete selected edges in the model  

– “Remove Face…” → delete selected ‘faces’ in the model 

– “Body Restore…” → restore all deleted edges and ‘faces’ removed with 

above presented options 

– “Discrete BREP…” → Creates a discrete boundary representation for a given 

‘body’, which provides simply a triangular surface mesh (of the body) that 

has the advantage of being modified with feature removal options 

– “Body Defeature…” → deletes the features on a ‘body’ based on its discrete 

boundary representation 

14. “STL Body” → (stereographic 3D figures) 

– “Import STL…” → import a 3D model file containing a stereographic part 

prepared in CAD software 

– “Convert Parasolid Body…” → converts Parasolid ‘body’ into the STL body 

type 

– “All-Brick Meshing…” → creates brick elements on an STL ‘body’ 

– “Discrete BREP…” → creates a discrete boundary representation for a given 

STL ‘body’  

– “Adapt Discrete BREP…” → update mesh density on the basis of discrete 

representation of boundary elements of a ‘body’ in a stereographic part 

– “Export STL…” → export triangulation of 2D, 3D surfaces or shell elements 

to a file with the .stl extension 

– “Import Cloud Data…” → import points from the point-cloud data file 
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15. “Nodes” → (nodes) 

– “Define…” → define points to be meshed as nodes 

– “Node Set…” → define a set of points to be meshed as nodes 

– “Delete…” → deletes unused nodes in the model 

– “Renumber…” → renumber the nodes not associated with the geometry 

– “Snap Nodes…” → moves nodes to the most closed geometry 

– “Split mesh…” → split mesh at an interface 

– “Detach Mesh…” → detaches mesh from one part to another 

– “Join Mesh…” → joins two meshes by merging coincident nodes 

16. “Elements” → (elements) 

– “Element Set…” → define a set of finite elements 

– “Element-Edge Set…” → define a set of finite elements consisting of element 

edges 

– “Element-Face Set…” → define a set of finite elements consisting of  

‘body’-type ‘faces’ (surfaces) 

– “Connector…” → define connector elements between model entities 

– “Truss…” → define truss-type elements across two geometry lines 

– “Axisymmetric Truss…” → define axisymmetric truss elements (ring) on 

specified geometry points 

– “Spring…” → define a spring on the basis of geometric points or lines 

– “6-DOF Spring…” → define a spring with six degrees of freedom on the 

basis of geometric points or lines 

– “Shell Thickness…” → specify shell elements thickness 

– “Shell Layer…” → define data for a complex shell layer 

– “Element Nodes…” → define connections between finite elements nodes 

– “Element Data…” → define data for individual selected element/s 

– “Renumber…” → renumber finite elements 

– “Change Group…” → allow to select elements which will be considered  

in different element group than preliminarily specified 

– “Transform…” → transform finite elements (copy / move elements) 

– “Convert…” → convert elements with 8 nodes (2D elements and shells)  

or elements with 20 nodes (3D elements) into elements with 9 or 27 nodes 

– “Settings…” → compatibility checking of CFD mesh options, checking  

for duplicate elements, possibility of creating unique element labels 

17. “List F.E. Model…” → information in the form of a list about the current  

finite elements in the model 

18. “Copy F.E. Model…” → copy elements/nodes from one model to another 

19. “Delete F.E. Model…” → delete an entire finite elements in the model 
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The “Solution” window 

 

 
1. “Data File/Run…” → creates an output data file, and optionally runs a solving 

module  

2. “Run ADINA Structures…” → runs a solving module for solid models 

3. “Run ADINA-FSI…” → runs a solving module for fluid based structures 

4. “Run ADINA Structures/EM…” → runs a solving module for structures includ-

ing electromechanical coupling 

5. “Run ADINA FSI/EM…” → runs a solving module for fluid based structures 

including electromagnetic coupling 

6. “Run ADINA TMC…” → runs a solving module for thermos-mechanical  

coupling problems 

7. “Run Steered Adaptive…” → run a fluid structure interaction FSI/ CFD module 

analysis with adaptive meshing including various options concerning solution 

process 

The “Help” window 

 

 
1. “Getting Started (html)…” → a “getting started with the program” help file in the 

HTML format. 

2. “Index (html)…” → an index of typical keywords located in the help file 

3. “Hints (html)…” → hints/troubleshooting list 
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4. “Release Notes (pdf)…” → information/news related to the currently used version 

of the ADINA software 

5. “Manuals (pdf)…” → a set of .pdf documents containing materials for modeling/ 

commands/verification etc. in the ADINA program  

6. “ADINA Primer (pdf)…” → a vast set of examples presenting the program  

abilities 

7. “About ADINA-AUI…” → information about the current version 
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CHARACTERISTICS OF MAIN MENU TOOLBAR BUTTONS 

USED ACROSS EXAMPLES 

As previously mentioned all the buttons for “ADINA Structures” and their functions 

are described in the ADINA primer, which can be accessed from “Help/Primer 

(pdf)…”. In this chapter only the most frequently used buttons across presented  

in this book problems are shown and explained. 

The “General” bar 

 
“Open” → open a saved model file 

 
“Save” → save the current model to a file/overwrite a file 

 
“Redraw” → redraw/update the model 

 

“Clear” → clear the current model window (does not delete the model  

permanently) 

 
“Mesh Plot” → show the model with default settings 

 
“Modify Mesh Plot” → modify model display parameters 

 
“Load Plot” → display loads defined in the model 

 
“Boundary Plot” → display boundary conditions assigned in the model 

 
“Pick” → an option which enables picking elements of the model 

 
“Dynamic Resize” → dynamic resize of the model and the elements 

 
“Dynamic Pan” → dynamic pan of the model and the elements 

 
“Dynamic Rotate (XY)” → dynamic rotation of the XY plane 

 
“Zoom” → zoom to an indicated part of the screen 

 
“Unzoom All” → unzoom the whole screen until the default view 
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“Unzoom Partially” → gradually unzoom the screen content until  

the default value 

 

“Refit” → exit the magnified selected mesh to a view of the entire  

model of finite elements 

 

“Measure” → an option enabling measurement of the distance between 

two points 

The “Modeling” bar 

 
“Define Points” → displays a window for defining points in space 

 

“Define Lines” → allows for defining lines by means of previously  

created points 

 
“Define Surfaces” → define a surface 

 
“Define Volumes” → define volumetric elements 

 

“Define Element Groups” → define a group with specified type of finite 

elements and assigns material to them as well as gives the possibility to 

modify additional options regarding finite elements  

 
“Mesh Lines” → generate finite elements on a line 

 
“Mesh Surface” → generate finite elements on a surface 

 
“Mesh Volume” → generate finite elements on a 3D volumetric figure 

 
“Apply Load” → define/assign loads 

 
“Apply Fixity” → define/assign boundary conditions 

 
“Manage Materials” → manage material models and its properties 

 
“Cross-Section” → define a cross-section 

 
“Data File/Solution” → create an output file/start calculations 
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The “Display” bar 

 
“Wire Frame”→ show the model along with hidden lines 

 

“Hidden Surfaces Removed”→ show the model with hidden surfaces  

removed 

 
“Shading”→ shading of the model 

 
“Cull Front Faces”→ do not show front faces in the model 

 
“ISO View” → view the model in accordance with the selected axes 

 

“Show Geometry” → activate/deactivate displaying the geometry of the 

model 

 
“Point Labels” → activate/deactivate displaying the numbers of points  

 

“Line/Edge Labels” → activate/deactivate displaying the numbers of 

lines and edges of the model 

 

“Surface/Face Labels” → activate/deactivate displaying surface  

numbers of the model 

 

“Volume Body Labels” → activate/deactivate displaying the numbers  

of 3D figures and ‘body’-type volumetric elements 

 

“Node Labels” → activate/deactivate displaying the numbers of nodes  

of a finite element mesh 

 

“Node Symbols” → activate/deactivate displaying the nodes of a finite 

element mesh 

 

“Element Labels” → activate/deactivate displaying the numbers of  

elements of a finite element mesh 

 

“Color Element Groups” → activate/deactivate displaying differentiation 

of groups of elements used in the model by means of colors 
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“Create Band Plot” → create a plot of model characteristics 

 
“Modify Band Plot” → modify the created plot of characteristics 

 
“Clear Band Plot” → delete the plot of model characteristics 

 
“Smooth Plots” → smooth the plot of model characteristics 

 

“Group outline” → options for displaying finite elements and the model 

itself 

 

“Show Deformed Mesh” → show a deformed finite element mesh  

depending on the time step 

 
“Original Mesh” → show the original state of the finite element mesh 

 

“Scale Displacement” → show a rescaled (for better visibility of the 

strains) deformed finite element mesh of the model 

 
“First Solution” → go to the solution from the first time step 

 
“Fast Rewind” → fast rewind the time steps of the solution 

 
“Previous Solution” → rewind the solution by 1 time step 

 
“Next Solution” → fast forward the solution by 1 time step 

 
“Fast Forward” → fast forward the time steps of the solution 

 
“Last Solution” → go to the solution from the last time step 

 

“Movie Load Step” → create a stop motion movie of the model’s  

response to the input loads 

 
“Animate” → display the declared movie in the form of an animation 

 
“Refresh” → delete the stop motion movie from the cache memory 

 

“Save Avi” → save the stop motion movie from the cache memory on  

a drive in the form of an *.avi file 

 

 
 



I. Major, M. Major, K. Kuliński 

48 

The “Module Bar” 

 
“Program Module” → choose an active program module 

 
“Analysis Type” → choose the type of the performed  

analysis of the model 

 

“Analysis Options” → options related to the performed 

analysis 

 
“Multiphysics Coupling” → define an additional performed 

analysis (models consisting of two analyses) 

 
“Coupling Options” → options of a coupling analysis 
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Examples regarding building statics  

and dynamics 
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● Statics 

○ Two-dimensional problems 
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EXAMPLE 1  

A SIMPLY SUPPORTED BEAM. DETERMINING  

THE MAXIMUM BENDING MOMENT AND DISPLACEMENT 

The example presents the modeling of a beam subjected to a linear constant load. 

The consecutive steps present the manner of specifying the basic functions necessary 

to model a system and to perform an analysis. A static scheme of the analyzed beam 

is presented in Figure 19. 

 

 

Fig. 19. Scheme of a simply supported beam 

The span length of the beam between supports, diameter and value of constant linear 

load are: 

� = 2.00 m 
� = 0.05 m 

 = 5.00 kN/m 

A beam with a circular cross-section has been modeled from steel, assuming the 

following material constants: 

� = 210 GPa = 2.1e�� Pa 
� = 0.30 
� = 7859 kg/m� 

Note: It is recommended for models prepared in two-dimensional (2D) environment 

to be created in the first quarter of the coordinate system, preferably in the YZ plane. 

This is due to the fact that the previous versions of the ADINA software experienced 

problems with meshing when 2D elements were located in a different quarter and in 

a different plane than YZ. Currently it is possible to set the plane for the analysis of 

2D solid elements in “Control→Miscellaneous Options…”. It is also recommended 

for all the values in the program to be entered in accordance with the basic units of 

the SI system – this will make the interpretation of results much easier.  
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STEP 1. Definition of the type of analysis 

Upon opening the ADINA software, choose “ADINA Structures” from the “Module 

Bar” in the “Program Module” section, and choose “Statics” from the drop-down list 

next to “Analysis Type”. 

 

 

STEP 2. Entering the heading of the model 

Choose “Control→Heading” from the upper menu tabs, and then in the newly  

displayed window enter the heading and confirm it with the “OK” button. 

 

 

STEP 3. Changing the background color of the model window 

In order to change the displayed background color, change the color value in “Edit 

→ Background Color” in the main window, choose the color desired by the user, 

and then confirm it with the “OK” button. As an example white color will be used. 

 

 

Note: If the background color does not change, it may be connected with wrong 

graphics system chosen in the ADINA program. In order to change it, go to “Edit → 

Graphics System…” and change the “Graphics System:” option to “Windows GDI”. 

STEP 4. Definition of global boundary conditions 

Global boundary conditions simply mean exclusion or inclusion of displacements 

and rotations related to the entire model. The current example deals only with  
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the ability to move along the Y and Z axes and rotate with respect to the X axis.  

The remaining conditions do not occur in the present example, so they should be 

excluded. In order to open the window of global boundary conditions, choose  

“Control → Degrees of Freedom” from the upper menu tabs. 

 

 

 
In the new versions of ADINA, one can leave the check mark enabled for the option 

“Set Master Degrees of Freedom Automatically for Planar Model”. According to 

that ADINA will automatically adjust master boundary conditions in regard to the 

specified calculated problem. In older ADINA versions it was rather necessary to 

include/exclude master boundary conditions. For the older ADINA software taking 

into account studied problem, following boundary conditions should have check 

mark enabled: “Y-Translation”, “Z-Translation” and “X-Rotation”. Remaining 

boundary conditions should have empty check boxes. The “Ovalization/Warping 

DOF at Pipe Element Nodes:” as well as “Deafult Number of DOF Associated with 

Shell Midsurface Nodes:” should have been left as it is automatically adopted. 

STEP 5. Definition of points 

In order to define the points needed to create a model, go to the “Geometry → Points 

→ Define…” tab, or click  in the toolbar available in the main menu of the 

program. To ensure backwards compatibility the model is created in the first quarter 

– the YZ plane. Therefore, the table opened in the new window should be filled out 

in accordance with the figure, in which X1 means values on the X axis, X2 – values 

on the Y axis, and X3 – values on the Z axis.  
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It is possible to choose the coordinate system specified by user changing the ‘0’ value 

in the “Default Coordinate System”, however the local coordinate system must have 

been introduced by the user. Moreover, the local coordinate system may be created 

through the “…” button in the line of “Default Coordinate System” option. 

‘System’ in the table means the coordinate system currently used to specify the X1, 

X2, and X3 coordinates. Different points may be referred to different coordinate sys-

tems.  

It should be noted that the numeration of points is not created automatically, and thus 

each new point must have a number assigned by the user in the “Point #” column. 

Upon clicking the “Save” button, the remaining values of the table will be automat-

ically filled out as zeros. So far, no local coordinate system has been defined,  

and the global coordinate system always has a value of 0, which is why it was not 

required to enter any numbers in the “System” column. Currently, the window  

can be closed with the “OK” button. Upon clicking the “OK” button, the point defi-

nition window will disappear, and two orange points will appear in the main model 

window. 

Although the program fills out the column with zeros automatically, for a larger 

number of points it is recommended for the user (especially a beginner) to enter  

the given zeros manually. This makes it easier to identify whether a given point with 

a value of 0 on one of the axes is actually supposed to have such a value, or whether 

it can have a different one. 
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STEP 6. Model view 

In older ADINA software program assumes certain display values automatically, 

which is not always satisfactory to the user, e.g., in this case, after defining two 

points, the program switched to the main model but with a perspective view,  

which makes it much harder to work with a two-dimensional model 2D; therefore, 

the button  should be used to choose “YZ View” in order to change the 

view.  

STEP 7. Displaying the numbers of points 

In order to display the points assigned numbers for their easier identification, click 

. 

STEP 8. Definition of lines 

In order to define a line between two visible points, choose “Geometry → Lines → 

Define…” from the upper menu tabs, or click  in the main menu of the program. 

In the newly opened window, click the “Add…” button for adding a new line, make 

sure that the line type is a straight line, meaning “Straight”, and then in Point 1 and 

Point 2 enter numbers like in the figure below. 

 

 
 
There is no relevance whether a line is made from left to right by entering 1 in Point 

1: and 2 in Point 2:, or it is made from right to left in this problem. Upon entering 

the identification numbers of points, it is always advisable to first click the “Save” 

button, and then “OK” button. As it will turn out soon, such a procedure allows for 

adding further lines with no need to reopen the same window. An orange line con-

necting the two previously defined points should appear in the main model window. 
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STEP 9. Displaying the numbers of lines 

In order to display the numbers of lines for their easier identification, click . 

STEP 10. Definition of boundary conditions (fixity characteristics) 

In order to declare fixities in the model, choose “Model → Boundary Conditions → 

Define Fixity…” from the upper menu tabs, which will cause the user to go to a new 

window for defining boundary conditions. Two fixities are needed, i.e., immovable 

hinged support and the hinged support with the ability to move in the Y axis direc-

tion. In order to create an immovable support in the newly opened window, press the 

“Add…” button, input the name of the new fixity, and then the requested displace-

ments and rotations will be blocked for all options with check mark enabled.  

The definition of a immovable hinged support fixity is presented in the figure  

below. 

 

 

 
In this case, displacements along the Y and Z axes have been blocked, while rotation 

with respect to the X axis remains unrestricted. The remaining values are not taken 

into consideration in the abovementioned example. Some of the boundary conditions 

are gray – inactive, which was caused by the earlier setting of global boundary  

conditions in the model. 
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In order to define a movable hinged support, click the “Save” button, and then  

the “Add…” button in the current window, once again enter the name of the fixity, 

and then select proper translations to be blocked. 

Once the abovementioned operations are completed, click the “Save” button,  

and then “OK”. 

STEP 11. Definition of boundary conditions (applying fixities  

in nodes) 

In order to apply created fixity to a node, choose “Model → Boundary Conditions 

→ Apply Fixity…” from the upper menu tabs, or click  in the main program 

menu. In the new window, make sure that the “Apply to:” option shows “Points”, 

since the boundary conditions are to be applied to points. At first the immovable 

hinged support will be added to the one of the model points. In order to do that, in 

the “Fixity:” drop-down list select the name of immovable hinged support (in this 

case “PRZ_NIEP”) and check if in the “Apply to:” drop-down list “Point” is selected 

(if not, please select “Point”). Then enter the number of point manually in the 

“Points” column, or double-click the first row of the “Point {p}” column and choose 

the nodes manually. When the choice has been made, press the ESC key on the  

keyboard to return to the definition window. Then save the status of the boundary 

condition by means of the “Apply” button. Properly defined boundary condition of 

immovable hinged support is presented in the window below: 
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As a consecutive step, in the “Fixity:” drop-down list, one must choose the hinged 

support with the ability to move on the X axis (in this case one should chose 

“PRZ_PRZES”), leave the “Apply to:” option unchanged i.e. “Point” and in the first 

row of the table in column “Point {p}” introduce in the similar way as before the 

second point “2”. Properly defined boundary condition of hinged support with the 

ability to move is presented in the window below: 
 

 
 

Going back to the remaining options of the window for applying boundary conditions: 

– “Define…” is used to create additional boundary conditions in the same way as 

by going to “Model → Boundary Conditions → Define Fixity…”, 

– “Apply to:” gives the possibility to choose to which model entity the boundary 

condition should have been applied. Once different entity is selected, the title of 

table reflects the chosen element, i.e. if in the “Apply to:” drop-down list one 

choose “Line” the title of table column will be “Line {p}”. It should be noted that 

in order to have possibility of choosing different entities they must be created  

in the main model window beforehand. 

The remaining buttons in the window are: 

– “Auto…” is used to input points, lines, etc. from a number to a number, with  

an increment number,  
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– “Import” and “Export” enable importing and exporting the numbers of points, 

lines, etc. from/to a text file *.txt.  

– “Clear” enables complete clearing of the currently selected list of boundary  

conditions (e.g., having selected “Apply to: Points”, clicking the “Clear” button 

will allow for clearing a full list of boundary conditions related to points. Others 

such as lines etc. will remain unchanged, until the user’s intervention.).  

– “Del Row” and “Ins Row” enable deleting a single row or several rows, or adding 

a new row in the column. 

STEP 12. Definition of loads 

In order to define a load, choose “Model → Loading → Apply…” from the upper 

menu tabs, or click  in the main menu. Then in the newly opened window  

define both the mass-proportional load and external load in the form of a linear con-

tinuous load. The mass-proportional load is the first one to be defined; therefore, 

choose “Mass Proportional” from the drop-down list in “Load Type:”, and then click 

the “Define…” button next to the “Load Number:” drop-down list. In order to define 

a new load, click the “Add…” button in the next newly opened window. The values 

should look like in the figure below. 
 

 
 

Since the options presented in the new window are satisfactory, click the “Save” 

button, and then “OK”. The description label may be omitted. 

Going back to the mass-proportional load definition window, the following options 

are included: 

– The “Mass-Proportional Load Number” option in the form of a drop-down list, 

informing us about the number of mass-proportional loads which have been  

defined for the entire model. Of course, there is usually one mass-proportional 

load, since the software calculates the bulk density of an element by itself; when 
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this type of load is applied, there is no need to differentiate that one mass-propor-

tional load belongs to element A, and mass-proportional load no. 2 belongs to 

element B. A larger number of mass-proportional loads is usually used mainly 

for model tests. 

– The “Magnitude” option enables increasing or decreasing the distribution of  

the mass-proportional load of a model by means of values. For a value of one,  

the mass-proportional load is calculated as 100%, while for other values it is  

respectively higher or lower. 

– The “Direction Vector” options indicate the direction of the applied load with 

respect to the global coordinate system. –1 next to “Z” indicates that the weight 

will act opposite to the Z axis. It is important to note that any number can be 

entered in this box (not only 1), but it will not affect the value of load. Only  

the +/– sign informs the software whether the load is acting in accordance with 

the direction of the axis, or against it. The load can also act obliquely to the global 

coordinate system with no problems; therefore, in each box it is possible to enter 

values of, e.g., X: 2, Y: 2, Z: 2, and the load will act in accordance with the  

directions of the axes, at an angle of 45° to each one of them. 

– The “Interpret Loading as” options (for potential-based fluid element only) only 

apply to a potential-based fluid model. In any other module, they do not take part 

in the analysis. 

– The “Description” field correspond to the ‘naming’ of load. One can write a name 

for a load, which will be furtherly visible in the model tree. 

When the definition of mass-proportional load in its own window has been com-

pleted, the program returns to the window in which the load data are assigned to the 

model; for instance, in the case of mass-proportional load, the load definition  

window for the model should look like this: 
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Note: Especially in older versions of ADINA it is important that each time the load 

is introduced, the user should enter the subsequent number in the “Label #” column, 

since when doing this automatically (with no input from the user), the program some-

times ‘skips’ the loads. When the values have been entered into the table, click  

the “Apply” button in order to apply the entered values, and do not leave the load 

definition window yet. 

The next step corresponds of adding a continuous load. In order to do this, choose 

“Distributed Line Load” from the drop-down list next to “Load Type:”, then click 

the “Define…” button near the drop-down list next to “Load Number:”, and enter 

values like in the figure below. 
 

 
 
Then click “Save” and “OK” in order to return to the main load definition window. 

When the digit 1 has been entered in the first row and the “Line {p}” column, and 

then after clicking the “Apply” button, the resulting information will be like in the 

figure below: 
 

 
 
This means that the model needs an additional point, the so-called “Aux. Point”,  

with respect to which the load will be assumed. However, we cannot use any of the 

currently provided points in the model. 

STEP 13. Definition of an additional point 

In order to add another point to the model, use the same operation as in step 5  

called “Definition of Points”. Therefore, open the window by means of the upper 
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“Geometry → Points → Define…” tab, or by means of . Upon opening the new 

window, input point 3 in any place on the Y axis, and with any coordinate on the  

Z axis (however, one should think whether the load must have a direction same  

with the Z axis, or opposite). Since in the current example the load is opposite to  

the Z axis, the point should be set in the positive half of the Z axis. Then click the 

“Apply” button and “OK”. If the data have been entered like in the figure below, 

point “P3” should appear in the model above the “P2” button. 

Pay attention to the fact that the definition of a point specifying the direction of load 

may take place already in the beginning of the definition of the model. One or more 

of such points are defined in the model, later playing an important role for options 

related to the direction of load, the cross-section, etc.  

Note: In the case of loads (if a load has been declared as positive), the assumed 

direction of a load extends from the auxiliary point towards the defined part of  

the model. 

 

STEP 14. Definition of loads part 2 

Let’s go back to the “Apply Load” window once again. Options of the table for  

declaring a linear load are: 

– “Line {p}” specifies the line to which the load is applied; 

– “Aux. Point” is an auxiliary point identifying the direction of the load from  

the specified point towards the defined line; 

– “Deform Dependent?”, with “Default/Yes/No” options to choose from, specifies 

whether the load is calculated following deforming geometry under applied  

load “Yes” or the load does not change its line of action “No”. The usual option 

used in here is “No”. 
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– “Load Direction” specifies the load direction. The choices are: “X-Comp. only/ 

Y-Comp. Only/Z-Comp. only”, meaning load acting opposite the X/Y/Z axes, 

respectively, “Tangential Traction” meaning a force acting tangentially to the 

axis of a given bar, and “Global X-Dir./Global Y-Dir./Global Z-Dir.”, where  

the action of a force declared as positive causes its action in accordance with  

the direction of the X/Y/Z axis, respectively. In most cases, it is best to leave  

the value as default – “Total (Normal)”. 

– “Load Plane” specifies the plane in which the load works. It is best to leave the 

value as default – “In Plane” (when the auxiliary point has already been speci-

fied), which causes the load to be adopted in a plane between the defined point 

and the line of the model to which the load refers. The second one of the possible 

options is “Perpendicular to Plane”. 

– “Time Function” refers to a time function specified by the user. In the current 

example, the value should be left as default. 

– “Arrival Time” specifies the return of load over a time of x seconds. For a static 

analysis without declared time steps, like in the present example, the value should 

be left as default. 

– “Spatial Function” – the spatial function describing the variation of a quantity 

along a line. Leave the value as default. 

– “Label #” – a number specifying the next defined load. As described earlier, it 

should be controlled by the user, so that the program would not ‘skip’ the loads. 

Since the model has an auxiliary point for load, all that remains is to add a linear 

load. Declaration of load is shown in the figure below: 
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As soon as all the values are introduced in the window, click the “Apply” button  

and then “OK”. 

STEP 15. Displaying load values and boundary conditions 

In order to display the defined loads in the main model window, click . In order 

to show boundary conditions, click .  

The alternative method is to activate the view by the upper menu tabs of the program. 

In order to show the loads, choose “Display → Load Plot → Use Default”, while 

showing the fixities is done by “Display → Boundary Conditions → Default”.  

The user’s good eye might have noticed that the “Custom…” option for boundary 

conditions in the “Display” tab enables the introduction of changes in the view, while 

for loads such options are “Use Style…” and “Define Style…”. Since in most cases 

it is sufficient for the program to display the standard styles, modifications or creat-

ing new styles will not be discussed in the present example. 

It often happens that the legend of the displayed parameters overlaps the model,  

in which case two buttons should be clicked in the main program menu: 

 – the “Pick” button enables the selection of elements 

 – the “Dynamic Pan” button enables the panning of elements 

For monitors with high screen resolutions, the descriptions of legends may be very 

small, however they can be enlarged by means of zooming in/out, which is done  

by means of the “Dynamic Resize” button: . 

STEP 16. Definition of material constants 

In order to define material constants, choose “Model → Materials → Manage Mate-

rials” from the upper menu tabs, or click . In the newly opened window, choose 

and click the “Isotropic” button in the “Elastic” group of materials. An alternative 

method of reaching the window with the characteristics of an isotropic material is  

to select “Model → Materials → Elastic → Isotropic…” in the upper tabs of the 

program. In the newly opened window, first click “Add…” in order to add a new 

material, and then enter the values of material constants like in the figure below: 



Example 1 A simply supported beam. Determining the maximum bending moment and displacement 

65 

 

 
The “Description” option means ‘name’ of a given material. The box does not need 

to be filled out; the program identifies the material anyway by its number presented 

next to “Material Number:”. Unfortunately, the user must remember/write down the 

material number which they have defined, since later assignment of a given material 

to the model takes place via its number. 

The “Young Modulus (> 0)” option specifies Young’s modulus. It is allowed to use 

the format 210 000 000 000, or an engineering format as shown above. The box is 

obligatory. 

The “Poisson’s Ratio (–1.0 < NU < 0.5)” option enables inputting the Poisson’s ratio. 

The box is obligatory, although the default value is 0.0. 

The “Density (>= 0)” option specifies the density of the material. The box is required 

especially in the case of an analysis with a mass-proportional load. 

The “Coef. of Thermal Expansion (>= 0)” option is a box not required if the per-

formed analysis is not a thermal analysis of a given material. 

The “Put MDB” button – when the button is clicked, the declared material is added 

to the program database. This database is shared between all the opened ADINA 

AUI windows, however after closing down the program it is not stored, thus it cannot 

be imported in new problems. 

Upon inputting all the data, click the “Save” button and “OK”. When the program is 

in the “Manage Materials” window, this window can also be closed with the “Close” 

button. This window is presented in the figure below. 
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The “Manage Materials” window is more useful than the alternative method of  

adding materials through upper menu bars, as the user has an access to any material 

possible to declare. 

STEP 17. Specifying the type of the analyzed construction 

The next step is to define the element group/groups of the model. This means that 

certain constants, such as the type of material, the size of displacements, the group 

type, etc., are specified in a given group. In order to define a group, choose “Meshing 

→ Element Groups…” from the upper tabs of the program, or choose  from 

the toolbars. Since a beam has been modeled in the present example, in the newly 

opened window click the “Add…” button in order to add one group, then choose  

the “Beam” option from the drop-down list next to the “Type:” description. Then in 

the “Description” bar in the same window it is possible to enter a title characterizing 

the group (however, like when defining a material, in the remaining declarations the 

program uses the number of the group rather than its description). The next step is 

to change the “Element Sub-Type” to “2-D”. In the “Stiffness Definition” group of 

options, make sure that the use of a defined cross-section and material “Use Material 

and Cross Section” is selected. Set the “Default Material” value as “1” (it is a previ-

ously defined steel material with the number 1), and set the value of the cross-section  
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“Default Cross Section” as “1” as well. At this moment, no cross-section of the beam 

has been declared yet, but as soon as it is declared, it will have the number “1”.  

The remaining values in the tabs remain unchanged. Due to the plurality of options 

in the window, not all functions have been described – they will be described in  

an ongoing manner when used in other examples. A properly filled out window is 

presented in the figure below: 

 

 

 
Upon inputting all the data, click the “Save” button and “OK” in order to save the 

input data and leave the window. 

STEP 18. Definition of the cross-section of a beam 

In order to define a cross-section, go to “Model → Cross-Sections…” in the upper 

tabs of the program, or click  in the program toolbars. In the newly opened 

window, click the “Add…” button. In the place where the bar type “Type:” is to be 

specified, choose the “Pipe” option from the drop-down list, and then input the  

diameter in “Diameter D:”. In order to make the bar solid, select the “Solid Section” 

option. A properly filled out window should look as follows: 
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Click “Save” and leave the window through “OK” button. 

STEP 19. Mesh subdivision 

In order to divide an element into proper segments, choose “Meshing → Mesh  

Density → Line…” from the upper tabs of the program, or click the arrow next to 

the button  located in the toolbar, and then choose “Subdivide Lines” from 

the drop-down menu. The ‘number of divisions’ method will be used in the newly 

opened window. Therefore, in the “Mesh Density” group of options, choose the  

“Use Number of Divisions” option from the drop-down list in the “Method” box, 

then enter 200 in the “Number of Subdivisions” box (this means that each segment 

of the mesh has a length of 1.00 cm). Leave the remaining options unchanged. 

An alternative method of achieving the desired effect is to choose the “Use Length” 

option in the “Method:” drop-down list. Then enter a value of 0.01 in “Element Edge 
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Length”. Leave the remaining options unchanged. In both cases, the desired result 

produces segments with a length of 0.01 cm. In the table in “Line {p}” column  

introduce “1” in the first row, what means that only the line no. 1 is going to be 

divided. It is also possible to divide line, if from the “Base Line” drop-down list,  

the line no. 1 will be checked. 

 

 
 
When the option has been selected, click the “Save” button and “OK”. 

STEP 20. Definition of finite elements 

The next step is to prepare a finite elements on prepared division. In order to accom-

plish this, choose “Meshing → Create Mesh → Line…” from the upper tabs of  

the program, or achieve the same by clicking  from the toolbar. 

In “Type:”, make sure that the type of the finite element mesh being defined is  

a beam – “Beam”. The “Element Group” option should have a value of “1”, meaning 

the assignment of a previously defined group of elements.  

The previously modeled auxiliary point “P3” will be used in the “Orientation (Point 

Overrides Vector)” group of options. Therefore, in “Auxiliary Point” enter a number 

corresponding to auxiliary point “3”, or by clicking the “P” button choose the desired 

point from the model. Enter the number of the desired line “1” in first row of the 

table on the right side of the window, or choose a line from the model by double-

clicking the table row, and after selection press ESC on the keyboard. The second 

tab called “Nodal Options” is left unchanged. A view of the window along with  

the input data is presented in the figure below: 
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Then click the “Apply” and “OK” buttons. The model should look as follows: 
 

 

STEP 21. Starting calculations 

In order to start calculations, choose “Solution → Data File/Run” from the upper 

menu tabs, or choose  from the toolbars. Subsequently, input the path for saving 

the resultant file. However, before the user clicks the “Save” button, they should 

make sure that the “Run Solution” and “Automatic” function near the “Maximum 

Memory for Solution” options are selected in the window in the “Adina Structures 

Solution” group of options. 

The “Run Solution” option enables solving a task; when unselected, it will result  

in only indicating a location for saving the resulting model file. 

The “Automatic” option allows the program to automatically choose the necessary 

internal memory of the computer to solve a given problem. 
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The accompanying windows are presented below: 

– a window showing the status of calculations, along with the used memory, etc. 

 

 
 
– a window displaying comments and errors present in the model. When an error 

occurs, the program will not perform further calculations. 

 

 
 
– a window informing whether the calculations were successful, or whether they 

were interrupted. 
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STEP 22. Transition to the post-processing module (results) 

In order to go to the results module, change “ADINA Structures” to “Post-Pro-

cessing” in the drop-down list of the “Module” toolbar. 

 

 

 
When switching between modules (as soon as the program recognizes the introduc-

tion of changes such as, e.g., recalculations of the construction, a window will be 

displayed, asking whether to reject the changes or save the file. The decision about 

saving is up to the user, although usually it is best to save the existing model, and  

do not go to the post-processing module before doing so). 

STEP 23. Opening the resultant file 

In order to open the resultant file, choose  from the toolbar, or choose “File → 

Open” or “File → Open porthole…” from the upper menu tabs. The “Open  

porthole…” option comprises several options, but they will not be discussed in this 

example. When the resultant file has been selected and confirmed, the model should 

be displayed on the main screen of the program. 

STEP 24. Displaying the results in the form of a map 

In order to display the results in the form of maps, choose “Display → Band Plot → 

Create…” from the upper menu tabs, or choose  from the toolbars. The follow-

ing window will open after this operation: 
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Displaying results related to displacements/flexures 

In order to display results related to the beam displacements in the Z-axis, choose 

the “Displacement” option from the drop-down list in “Band Plot Variable:”, and 

“Z-Displacement” in the second drop-down list on the right. Then click the “OK” 

button (clicking “Apply” and then “OK” will result in the appearance of one model 

and two identical legends in the main model window. Of course, the legends can be 

deleted by clicking a given legend and pressing the DELETE key on the keyboard. 

It is recommended to only click the “OK” button). A window along with the gener-

ated vertical displacement is presented below: 

 

 

Interpretation of the results 

The maximum Z-axis displacement of the beam is in its center, and it is 0.01622 m. 

On the basis of an analytical calculations, the displacement of a simply supported 

beam with a constant load amounts to: 

� = 5 ∙ 
 ∙ ��

384 ∙ � ∙ ! = 0.01618 m 

According to the above, the result is almost perfect. The difference is due to the fact 

that the finite element method is an approximate method which may be ‘less’ precise 

than typical engineering calculations. Moreover, the approximation strongly depends 

on nodes of finite elements, number of divisions for a mesh, the shape of finite ele-

ments etc. In this case the small error is caused by the division into finite elements. 

The higher the mesh density, the better the results in this case, however, it is always 

important if the user needs such precision, which is costly in computing time and 

virtual memory necessity. 

STEP 25. Changing the displayed plot/map 

In order to display other resultant values, use “Display → Band Plot → Modify”,  

or click . In such a case, a new window will open, in which it is possible to 
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introduce a larger number of modifications than just the type of the displayed results. 

The window in question is presented below: 

 

 
 
The “Band Plot Name:” option specifies the style to which the plot is related. There 

can be different band plots in a single result file. 

The “Mesh Plot Name:” option specifies the displayed plots to which the changes 

should apply. 

The “Band Plot Variable:” options mean the type of the displayed results. 

The “Smoothing Technique” option specifies the type of smoothing functions used 

in analyses of two- and three-dimensional objects with a mesh of finite elements 

consisting of geometry with 3 or more terminal nodes. 

The remaining options will be described when they are used in the following  

examples. 

Using the modification window for a plot/map, let us also try to display bending 

moments in the beam. Therefore, when using the “Modify” window, choose “Force” 

from the first drop-down list in “Band Plot Variable”, and “BENDING_MOMENT_T” 

in the second one, and then close the window with the “OK” button. 

 

 



Example 1 A simply supported beam. Determining the maximum bending moment and displacement 

75 

The maximum moment achieved in the software is 2508 N⋅m. 

The value of the moment in the center of the beam determined using the analytical 

method amounts to: 


��
 =
� ∙ ��

8
= 2500 N·m 

As can be seen, the solutions produced in the ADINA software are similar to analyt-

ical solutions. 

STEP 26. Displaying reaction values in the form of list of values 

In order to check the values of support reactions, use the upper menu tabs: “List → 

Extreme Values → Zone…”. In the top right corner of the newly opened window, in 

the “Variables to List” group of options set the display type as “Reaction” in the first 

row/first column, and the type of displayed reactions as vertical reactions “Z-REAC-

TION” in the second column, then click the “Apply” button. The remaining options 

in the window remain unchanged. If everything was done properly, the results should 

be displayed in the same window in the following form: 

 

 
 
In older ADINA versions the program is unable to display reactions on the model 

screen; the only possibility is to obtain them via a list.  

STEP 27. Deleting the displayed map 

When wishing to delete the map (but not the model), use the button  from the 

toolbars. 

STEP 28. Displaying reactions in the form of plot 

In the new ADINA 23.00.01 one can press the following button corresponding 

to the option “Display → Reaction Plot → Create…”, choose the “Reaction Quantity:” 
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as “Reaction”, remaining fields leave as its defaults and click “OK”. The main window 

should look alike: 

 

 

 
Once the reactions are shown, one can delete the plot (not the model), through  

the following button  located on the toolbars. 

STEP 29. Options for displaying deformations of a finite element 

mesh 

In order to display a deformed finite element mesh with respect to the construction, 

just use . When the displacements are quite large, it may be necessary to display 

the original finite element mesh (it can be activated along with displaying the  

deformed mesh). This is done by . 

It is not uncommon for the displacements/flexures of the model to be very small; 

they may be invisible on the screen. In order to improve legibility, or check whether 

an anticipated flexure took place, just use .  

Of course, if the scale of flexure is still unsatisfactory, it can be set manually  

by means of options included in “Display → Geometry / Mesh Plot → Modify…”,  

or by means of . When choosing the “Model Depiction” button in the “Dis-

placement Display Options” group of options, change the value in the “Magnifica-

tion Factor” box to a higher number. Then click the “Save” button and “OK” in this 

window; the program will return to the main “Modify…” window; while there, click 

the “Apply” button, and then “OK”. Changes related to the view should take place 

in the model. 
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STEP 30. Simultaneous view of two or more different plots/maps 

In order to display two plots simultaneously, clear the window of the previous  

models by means of . Subsequently, in order to add one plot/map, use  
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and add a plot/map with . The next step is to shrink the model, so that it would 

occupy no more than ½ of the window along with descriptions. This is done by 

means of scaling  and moving the components of the plot/map . In order 

to add another plot, repeat the action of adding another model to the window by 

means of . The use of the remaining functions remains unchanged. 

A user may want to introduce changes to one of the existing models (if there are 

more than one). In order to do this, just use the left mouse button to select the proper 

plot (the current choice will be indicated by a frame with wider gray lines next to the 

vertices of the frame), and then use the function which interests the user. The figure 

below presents two plots in one window: 
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EXAMPLE 2  

A TRUSS SYSTEM. DISPLACEMENT OF A NODE DUE TO 

THE ACTION OF A CONCENTRATED FORCE. 

DETERMINING ZERO FORCE MEMBERS  

The present example shows the consecutive steps related to the modeling of a truss 

system. Some steps will be analogical to the previous example, thus no commentary 

will be added to the applied functions which were discussed previously. Scheme of 

the analyzed truss is presented in Figure 20. 

 

 

Fig. 20. Truss scheme 

Bar lengths � and ) as well as the load value are equal: 

� = 1.00 m 
) = 1.00 m 
* = 5.00 kN 

Material constants for steel material: 

� = 210 GPa = 2.1e�� Pa 

� = 0.30 

The diameter of each truss bar is assumed as:  

+ = 0.10 m 

therefore, the cross-section area of a single bar needed in further computations is 

equal to: 

, = - ∙ +(

4 = 7.853981∙10.� m( 

Note: In this example mass-proportional load is not included in the calculations.  

The truss system is a planar system, thus the definition should take place in the  

positive quarter of the coordinate system (the YZ axes). 
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STEP 1. Definition of the type of analysis 

Upon opening the ADINA software, choose “ADINA Structures” from the “Module 

Bar” toolbar in the window comprising a drop-down list, and choose “Statics” in  

the second drop-down list. 

 

 

STEP 2. Entering the heading of the model 

In order to specify a heading, choose “Control → Heading” from the upper menu 

tabs, and then enter a heading, e.g., “Planar truss system”. Upon entering a heading, 

click the “OK” button. 

STEP 3. Definition of the background color of the main model  

window 

In order to define the background color, go to “Edit → Background Color…”. Then, 

in the newly opened window choose the color white from the drop-down list. Choose 

the item called “WHITE” from the drop-down list, and confirm the choice with  

the “OK” button. 

 

 

Note: The background color is not saved along with the model. This means that after 

each opening of the file, the background color will return to default – “black”. 

STEP 4. Definition of global boundary conditions 

Because the analysis is performed in two dimensions (2D), one should select the 

master boundary conditions to give the ability to move along the Y and Z axes,  

as well rotate with respect to the X axis. 
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STEP 5. Definition of points 

The definition of points takes place by selecting “Geometry → Points → Define” 

from the upper menu tabs, or by means of . Input the data in accordance  

with the figure below: 
 

 
 
Then confirm the data by clicking “Save” and “OK”. 

STEP 6. Definition of lines 

In order to define a line, go to “Geometry → Lines → Define…”, or use .  

In order to add a larger number of lines, the pattern is as follows: “Add… → Type: 
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Straight → Point 1: … → Point 2: … → Save”. This action should be performed  

as many times as the number of lines needed in the figure. 

The definition of lines may take place in any sequence. In the example the following 

sequence is used: 
 

Line Number: Point 1: Point 2: 

1 1 2 

2 2 3 

3 4 5 

4 1 4 

5 2 5 

6 1 5 

7 5 3 

 
A view of the window with data input for line no. “3” is presented in the figure below: 

 

 
 
As soon as all the lines are introduced, confirm changes with the “OK” button. 

STEP 7. Displaying the lines numbers 

In order to display the lines numbers for their easier identification, click  . 

STEP 8. Definition of boundary conditions (fixity characteristics) 

In order to define and apply a fixity, go to “Model → Boundary Conditions → Apply 

Fixity…”, or do it by means of . In the newly opened window, click the  

“Define…” button, and then “Add…” in order to add a new fixity (immovable 
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hinged support). Enter “Hin_immov” as the title, and then select Y and Z transla-

tions. Leave rotation around the X axis unrestrained. The remaining entities are  

unrelated to the current model, so it may remain unchanged. Confirm the introduced 

changes with the “Save” button. 

 

 
 
Following this, confirm changes in the fixity definition window by clicking “OK” 

and move on to the applying of boundary conditions window. Make sure that the 

“Apply to:” option is set to “Point” and the “Fixity” option is set to “HIN_IMMOV”. 

Then in the table rows insert points 1 and 4 (nodes I and IV shown in Figure 20). 

 

 
 
Then confirm the changes by clicking the “Apply” and “OK” buttons. 
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STEP 9. Definition of loads 

In order to add a load to the model, go to “Model → Loading → Apply…”, or choose 

this option by means of . In the newly opened window make sure that “Load 

Type:” shows a concentrated force – “Force”. Then click the “Define…” button, 

“Add…” button and enter 5000 in the “Magnitude:” box, and a value of –1 in the 

“Force Direction → Z:” box, because the force acts opposite to the Z axis. Descrip-

tion may be left unchanged. When the values have been specified, click the “Save” 

button and leave the window with the “OK” button. 

 

 

 
Upon exiting, make sure that the “Apply to:” option in the main load definition win-

dow in the model displays “Point”.  

Subsequently, enter the node number “3” manually in the “Point {p}” column of the 

table, or choose the construction node by double-clicking the row of the column. 

After this operation, press the ESC key on the keyboard. Leave other options un-

changed. 

Then close the window by clicking the “Apply” and “OK” buttons. 
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STEP 10. Displaying boundary conditions and loads 

In order to display the defined loads in the main model window, click . In order 

to show boundary conditions, click .  

STEP 11. Definition of material constants 

In order to go to the declaration of material constants, choose the “Model → Mate-

rials → Manage Materials” tab, or click . In the newly opened window, find 

and click the “Isotropic” button in the “Elastic” group of materials. An alternative 

method of reaching the window with the characteristics of an isotropic material  

is to find “Model → Materials → Elastic → Isotropic…” in the upper tabs of the  

program. 

In this window, first click “Add…” in order to add a new material, and then enter 

the values of material constants like in the figure below: 

 
 



I. Major, M. Major, K. Kuliński 

86 

 

 
The density of the material may be omitted, since the mass-proportional load of the 

truss is not taken into consideration in the calculations. Upon declaring the values 

for a material, changes are confirmed by clicking “Save” and “OK”, respectively.  

In the material manager window, press the “Close” button to leave the window. 

STEP 12. Specifying the type of the analyzed construction 

In order to furtherly create finite elements treated as truss elements, one need to add 

the proper group by means of “Meshing → Element Groups…”, or by means of 

. Then in the newly opened window click “Add…”, and from the drop-down 

list choose “Truss” for the “Type:” option. Make sure that the “General 3D” option 

is selected in “Element Sub-Type”. The “Axisymmetric” option is used only for 

trusses that has one degree of freedom per node along the Y axis direction. According 

to that the Z axis is the axis of rotational symmetry and the Y axis is the radial direc-

tion. Such elements may be subjected only to circumferential force. It should be 

noted that most of truss systems will be created with “General 3D” option. 

Apart from the presented options, enter a value of “7.853981e-3” in the “Default 

Section Area” box in order to define a cross-sectional area for each of the truss  

bar element in this element group. 
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It should be noted that some trusses have bars with various cross-sectional areas; 

therefore, for this purpose, one enters “1” in the “Default Section Area:” box, while 

“Model → Element Properties → Truss…” provides the ability to define both the material 

and the cross-section areas as well as a vast of other options for each bar separately. 

For the truss from this example, the figure below demonstrates a general idea how 

to fill out the table of characteristics for each bar, assuming that a value of “1” would be 

entered in the “Define Element Group” window next to the “Default Section Area” option. 
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Both methods of introducing cross-section areas in the presented problem would lead 

to obtaining the same numerical results. 

STEP 13. Definition of finite elements 

A truss is a structural arrangement consisting of a large number of bar elements 

which can be considered as segments. An attempt of subdividing them via mesh 

density will produce error in the window during the model calculations, and the 

structure will not be calculated. 

In order to generate finite elements on the bars of a truss, go to “Meshing → Create 

Mesh → Line”, or choose  from the toolbars. 

Then make sure that the “Type:” option shows “Truss”. According to that only 

stretching/compressing forces are considered in the truss, the “Nodes per Element:” 

option should be left as “2”. Then, fill out the table manually with values (bar num-

bers) from 1 to 7. One alternative way is to click any row of the table and choose 

lines from the model, and then confirm selection by pressing the ESC key on the 

keyboard.  

Another way to fill out the table is to use the “Auto…” button located over the table. 

Enter a value of “1” in “From” – this option specifies the line number from which 

the program start; subsequently, in the “Step” box also enter a value of “1”, since 

this is the value of the increment of line numbers. In this case, enter the number of 

the last bar in the “To” option, i.e., “7”. The figure below presents a properly filled 

out window: 

 

 
 
Confirm the introduced changes by clicking “OK”; this will also cause the table to 

be filled out with numbers from 1 to 7. Further, in the “Mesh Lines” window, click 

“Apply” and “OK” to return to the main model window.  
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STEP 14. Starting calculations 

In order to start calculations, choose “Solution → Data File/Run” from the upper 

menu tabs, or choose  from the toolbars. Subsequently, input the path for saving 

the resultant file. However, before the user clicks the “Save” button, they should 

make sure that the “Run Solution” and “Automatic” function near the “Maximum 

Memory for Solution” options are selected in the window in the “Adina Structures 

Solution” group of options. After starting the calculations and recalculating the 

model, close all three dialogue windows which appeared during the calculations. 

STEP 15. Post-processing module (results) 

In order to go to the results module, change “ADINA Structures” to “Post-Processing” 

in the drop-down list of the “Module” toolbar. 

 

 

 
When a message appears stating that changes in the drawing have not been saved,  

it is recommended to save the model. 
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STEP 16. Opening the resultant file 

In order to open the resultant file, choose  from the toolbar, or choose  

“File → Open” from the upper menu tabs. 

STEP 17. Displaying the results in the form of a map 

In order to display the results in the form of maps, choose “Display → Band Plot → 

Create…” from the upper menu tabs, or choose  from the toolbars. The follow-

ing window will open after this operation: 
 

 
 

In the window, choose the map of resultant values which interests the user. 

STEP 18. Determining the displacements of nodes 

Before defining the group of nodes which are the points of interest one should click 

following buttons on the toolbars:  – this button shows the numbers assigned to 

finite elements nodes and  – this button shows the finite elements nodes, which 

can be furtherly chosen by another windows from the ADINA program. 

Now let’s go back to determine the displacement values of nodes II, III and V. In 

order to do this, go to “Definitions → Zone…”, and then in the newly opened win-

dow click the “Add…” button and enter the name of a new set, e.g., “Nodes_2_3_5”. 

For the “Picking Filter:” option, change the value from “ALL” to the value which 

refers to the nodes – “Node”. Once the picking option has been selected, double-

click the first row of the table and choose the nodes which interest the user, then use 

the ESC key on the keyboard for confirmation. The numbers of nodes in the table 

can also be input manually (however, the name “node” should also be specified  

before the number). 
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In this case, the remaining options remain unchanged. When the nodes have been 

selected, confirm changes by means of the “Save” button, and then “OK”. A properly 

defined window of nodes is shown in the “Define Zone” figure below: 

 

 
 
In order to display values of displacement in selected nodes, go to “List → Filtered 

Values → Zone…” (the window shown below). In order to show only final values 

for the selected nodes, for the “Zone Name:” option choose the name of the nodes 

defined by the user from the drop-down list, in this case “Nodes_2_3_5”. Then make 

sure that the “Type:” option displays “Absolute Maximum”. In the “Response  

Option” group of options, select the “Single” option, and in “Response” choose 

“LATEST” from the drop-down list. In this case, all that remains is to specify the 

type of the displayed final results for the selected nodes; therefore, choose the result 

which interests the user in the right part of the “Variables to List” window. 

In this example, displacements along the Z axis have been selected, so this type of 

results should be “Displacement”, and more precisely “Z-DISPLACEMENT”. It is 

also possible to display a larger number of results for the input nodes, just by select-

ing the boxes next to a value of 2 or 3, etc., in the “Variables To List” group of 

options, and then choose the requested type of the displayed results. 
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Each time, all changes in the above window should be approved by the “Apply” 

button, while the “Close” button should be clicked to leave the window. 

It should be noted that the ‘presented’ at the moment list of results can be exported 

to a *.txt file by means of the “Export…” button. 

STEP 19. Determining the “zero force members” of a truss by means 

of maps 

This operation can be performed by displaying a force value map. In order to display 

the zero force members, go to “Display → Band Plot → Create…”, or click . 

In the newly opened window, click the button with three dots next to the “Band  

Plot Style” option. 
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Subsequently, in the “Define Band Plot Style” window, click the button with three 

dots next to the “Band Table” option. The next window called “Define Band Table 

Depiction” will open, in which it is possible to define the values of the sought results. 

 

 
 
In order to define the sought values, change the values corresponding to “Minimum” 

and “Maximum” in the “DEFAULT” style in the “Value Range” group of options to 

the value very close to “0”. This is caused by a fact, that the numerical values are not 

equal zero, they are very close to, but not equal. It should be taken into account that 

the “Minimum” value obligatorily have a negative sign. Subsequently, in the “Color 

at Specific Value” group of options (indicating a specific value with an individual 

color), select the box belonging to the “Set Color at Value” option. 
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Enter a value of “0” in the value box, and specify the color as desired. Then click  

the “Save” button and “OK”. 

Note: Definition of one’s own style in the window (along with its name) will cause 

its absence from the “Band Table” drop-down list of the “Define Band Plot Style” 

window; therefore, it is recommended to change the “DEFAULT” style. 

Upon returning to the “Define Band Plot Style” window, click the “Save” and “OK” 

buttons, until the “Create Band Plot” window is displayed. In this window, from 

“Band Plot Variable” choose “Force” as the type, and “AXIAL_FORCE” as the sub-

type. Subsequently, the “OK” button will display the map in the window. 

Note: An important problem of this method is that on the next plot/map after chang-

ing the requested parameters, e.g., from forces to displacements etc., the program  
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will still pick previously set values. In such a case, delete the plot completely by 

means of , and then repeat this entire step, until reaching the “Maximum”  

and “Minimum” options. In order to let the program automatically adopt a legend of 

results, enter the word “automatic” in both “Maximum” and “Minimum” option. 

Moreover, unselect highlighting the value “0” with a specified color.  

STEP 20. Determining a reaction in the support nodes of a truss 

In order to display support reactions (the direction of their impact), go to “Display/ 

Reaction Plot/Create…” or click , and then in the newly opened window choose 

“REACTION” from the “Reaction Quantity” menu. Then click the “OK” button.  

The window should look like this: 

 

 

 
As can be seen, the displayed reactions have two directions of impact. In order  

to learn the reaction values, go to “List/Filtered Values/Zone…”, then in the  

“Variables to List” group of options in the newly opened window choose “Reaction” 

in the first box, and choose “Y-REACTION” from the neighboring drop-down list. 

Select the second row so that it would also be included when displaying the results, 

and change the right drop-down lists to “REACTION” and “Z-REACTION”. When 

these actions are completed, click the “Apply” button. The program window should 

look like in the figure below: 
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STEP 21. Determining normal forces in the bars of a truss 

Similarly to specifying the reactions, it is possible to start with displaying normal 

forces occurring in the bars of a truss in the form of a plot. To this end, go to “Display 

→ Element Line Plot → Create…”, and then in the “Element Line Quantity” box 

choose “AXIAL_FORCE”, leave the remaining options unchanged, and then click 

“OK” in order to confirm the changes and leave the window. 

 

 
 



Example 2. A truss system. Displacement of a node due to the action of a concentrated force … 

97 

The plot only indicates which bars are stretched and which ones are compressed.  

It is impossible to read the precise values of axial forces in the bars from that plot. 

In order to read the real values of forces in bars, go to “List → Value List → Zone…”, 

and in the “Variables to List” group of options in the newly opened window choose 

“Force” in the first row, and the “FORCE-R” subtype from the neighboring drop- 

-down list. Then click the “Apply” button. 
 

 

Note: Since the results values are presented for the finite elements “Element” itself, 

and not directly are referred to the lines, there may be a situation in which a given 

line will have a different number of finite element. This should be checked by click-

ing  in the model window. Upon clicking this button next to each line (in the 

truss), a proper element number will appear for a given line.  

STEP 22. Creating a raster object of the current model 

If there is an interesting graph, or simply a need to save the current model in the form 

of a snapshot, click  or go to “File → Snapshot/Movie Save → Snapshot 
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(bitmap)…”, then choose a file save location and a format (*.jpg or *.bmp). A sample  
 

snapshot looks like this: 

 

 

Note: A snapshot results in displaying only the main resultant model window.  

Therefore, all the buttons, toolbars, etc. become hidden. 
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EXAMPLE 3  

DEFORMATION OF A PLANAR FRAME WITH RIGID 

CONNECTIONS AT NODES SUBJECTED TO THE VARIABLE 

EXTERNAL FORCE  

In this example the activities related to modeling of a frame with stiffeners at the 

connection nodes using a perfectly stiff material are presented. Each stiffener is  

assumed to be 0.25 m long, measuring from the center of the node along a given bar. 

The reader is advised to refer to the previous examples as some of the features have 

been discussed earlier. The diagram of the analyzed model is shown in Figure 21. 

 

 

Fig. 21. Scheme of analyzed frame 

The following data have been assumed in the calculations: 

linear load 
 = 10 kN/m (static and sinusoidal)  

concentrated force *%&' = 20 kN 

Material: steel 

� = 210 GPa = 2.1e�� Pa  

� = 0.30 

� = 7860 kg/m� 

Boundary conditions: Clamped supports on the external parts of the aisle (removal 

of 3 degrees of freedom for planar calculations), pinned support (release of rotation 

around the X axis in the left part of the inner aisle at the connection with the ground) 

and pinned support with the ability to move in the horizontal direction (release of 

rotation around the X axis and release of displacement in the Y direction in the right 

part of the internal aisle at the connection with the ground) 
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STEP 1. Specifying the type of analysis 

Choose “Adina Structures” from the drop-down list in the “Module Bar” toolbar, 

and “Static” as the analysis type from the second drop-down list on the right. 

 

 

STEP 2. Entering the heading of the model 

In order to specify a heading, choose “Control → Heading” from the upper menu 

tabs, and then enter a heading, e.g., “Rigid frame”. Upon entering a heading, click 

the “OK” button. 

STEP 3. Definition of the background color of the main model  

window 

In order to define the background color, go to “Edit → Background Color…”. Then, 

in the newly opened window choose the color white from the drop-down list. Choose 

the item called “WHITE” from the drop-down list, and confirm the choice with the 

“OK” button. 

 

 

Note: The background color is not saved along with the model. This means that after 

each opening of the file, the background color will return to default – “black”. 

STEP 4. Definition of global boundary conditions 

Since the considered model is a planar model considered in the program default YZ 

plane, boundary conditions that do not participate in the analysis process should be 

excluded. To check which boundary conditions are active, go to “Control → Degrees 

of Freedom...”. In the newly opened window, all boundary conditions in the “Master 

Degrees of Freedom (Selected = Active)” option group should have their boxes 

checked. Make the following changes in the window: 
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X-Translation Unchecked 

Y-Translation Checked 

Z-Translation Checked 

X-Rotation Checked 

Y-Rotation Unchecked 

Z-Rotation Unchecked 

 

The figure below shows the window with selected boundary conditions: 
 

 
 

The remaining data is left unchanged. After selecting the appropriate boundary  

conditions involved in the analysis, exit the window by pressing the “OK” button. 

STEP 5. Definition of the number of time steps 

To define time steps, go to “Control → Time Step...”. Then, in the newly opened 

window, enter the value of “90” in the first row of “# of Steps” column and in the 

same row under the “Magnitude” field, make sure that the value is “1.0”. The window 

view is shown in the figure below: 
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After entering the data, press the “Save” button and then leave the window with  

the “OK” button. 

Note: In this example the number of steps means, that the analysis will take solved 

for 90 steps (each step of magnitude 1.0). In real problems it refers to the number of 

‘time’ steps. In example, if we would like to take an analysis of 50 seconds with  

an interval of 2.5 s between consecutive steps, in the “# of steps” should be intro-

duced “20” and in the same row under the “Magnitude” should be placed “2.5”.  

It means that 20 multiplied by 2.5 s would give the full time of 50 s, however in the 

post-processing one will be able to observe the model behavior in 2.5 s intervals. 

STEP 6. Definition of load variability in subsequent time steps 

In this step, three different types of load variability over time will be defined.  

The first type will determine a static load with a constant value along the whole 

analysis, the second type will determine the increase in force from 0 to 20 000 N 

using a load multiplier (in fact, a unit load will be used under the definition of load, 

due to the fact, that it will be multiplied by magnitude value from “Time Function”), 

while the third type will determine a sinusoidal variable load, in which the force 

multiplier at the highest points of sinusoid will be “1.0” and “–1.0” respectively. 

Hence, for this case the load magnitude will be defined using the load definition. 

To declare load variability over time, go to “Control → Time Function...”. In the 

newly opened window, enter the following data: 

 

Time Function Number: 1 

Function Multiplier: Constant (=1.0) 

 
Values in the table 

 

 Time Value 

1 0 1 

2 1.00000000e+020 1 

Note: It is possible to create time steps with a variable value of time. In such a case, 

declare a specified number of steps for the requested value of time in each row of 

the table. The time of the final step in the calculations equals the sum of: 
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Then press the “Add...” button to add the load variation function no. 2 and enter  

the following data: 

 

Time Function Number: 2 

Function Multiplier: Constant (=1.0) 

 
Values in the table 

 

 Time Value 

1 0 0 

2 90 20 000 

 
After entering the data, press the “Save” button and then “Add...” again to enter  

the sine function, and then enter the following data in the window: 

 

Time Function Number: 3 

Function Multiplier: Sinusoidal 

Function Parameters 

Angular Frequency  

(deg/time): 
4 

Phase Angle: 0 

 
Values in the table: 

 

 Time Value 

1 0 1 

2 90 1 

 
After entering the data for function number “3”, you can press the “Graph” button – 

the following graph should appear: 
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The chart window should then be closed by pressing the “X” button in the upper right 

corner. After entering all the data, press the “Save” button and then leave the window 

with the “OK” button. The window views showing the above provided entries are 

shown in the figures below: 

 

 
 



Example 3. Deformations of a planar frame with rigid connections at nodes subjected to the variable … 

105 

 

 

 

STEP 7. Definition of points 

In this step, points describing the frame will be created. The points will be created 

on the program default YZ plane. To go to the definition of points, select “Geometry 

→ Points → Define…” from the menu or press the button . In the newly opened 

window, add points according to the table below: 
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Point # X1 X2 X3 System 

1 0 0 0 0 

2 0 0 2.5 0 

3 0 2.5 0 0 

4 0 2.5 2.5 0 

5 0 2.5 5.0 0 

6 0 7.5 0 0 

7 0 7.5 2.5 0 

8 0 7.5 5.0 0 

9 0 10 0 0 

10 0 10 2.5 0 

 
The window view with the entered data is shown in the figure below: 

 

 

Note: There is no need to enter zero values in the table. After pressing the “Save” 

button, the table will be automatically completed with these values. 

After entering the values from the table, press the “Save” button and then “OK”. 
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STEP 8. Displaying point ID numbers 

To display point identifiers in the YZ plane, press the  button on the toolbar, 

and then press the  button, respectively. The model should look something  

like this: 

 

 

STEP 9. Definition of lines 

In this step, having the points already defined, lines describing the frame will be 

introduced. To add a new line in the model, go to “Geometry → Lines → Define...” 

or press the button , then in the newly opened window, press the “Add...” button 

and enter the data in accordance with the table below: 

Note: After entering data from each table, press the “Save” button and then “Add...” 

to add a new line from the next table until data from the last table is entered. 

Line Number: 1 

Type: Straight 

Point 1: 1 

Point 2: 2 

 

Line Number: 2 

Type: Straight 

Point 1: 3 

Point 2: 4 
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Line Number: 3 

Type: Straight 

Point 1: 4 

Point 2: 5 

 

Line Number: 4 

Type: Straight 

Point 1: 6 

Point 2: 7 

 

Line Number: 5 

Type: Straight 

Point 1: 7 

Point 2: 8 

 

Line Number: 6 

Type: Straight 

Point 1: 9 

Point 2: 10 

 

Line Number: 7 

Type: Straight 

Point 1: 2 

Point 2: 4 

 

Line Number: 8 

Type: Straight 

Point 1: 5 

Point 2: 8 

 

Line Number: 9 

Type: Straight 

Point 1: 7 

Point 2: 10 
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The window with data entered for the line with ID “9” is shown in the figure below: 

 

 
 

After entering all the data, press the “Save” button and then leave the window  

with the “OK” button. 

STEP 10. Displaying line ID numbers 

In order to display the numbers of lines for their easier identification, click . 

The model should look like in the figure below: 

 

 

STEP 11. Definition of material constants 

In order to go to the definition of material constants, choose the “Model → Materials 

→ Manage Materials” tab, or click . In the newly opened window, find and 

click the “Isotropic” button in the “Elastic” group of materials. An alternative 

method of reaching the window with the characteristics of an isotropic material is to 

find “Model → Materials → Elastic → Isotropic…” in the upper tabs of the program. 
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In this window, first click “Add…” in order to add a new material, and then enter 

the values of material constants as shown in table below: 

 

Material Number: 1 

Description: Steel 

Young’s Modulus 

(> 0) 
2.1e11 

Poisson’s Ratio 

(–1.0 < NU < 0.5) 
0.30 

Density 7859 

Coef. of Thermal Expansion 

(>= 0) 
0 

 
The view of a window with the material constants introduced in the elastic material 

definition is shown in the figure below: 

 

 

 
If the user wants to add material to the program’s database, press the “Put MDB” 

button. After completing the operation, you can exit the window by pressing the 

“OK” button. Again, as in the previous case, after leaving the window, in the lower 

part of the “Manage Material Definitions” window, the table should contain the 

“Steel” material model with an assigned identification number of “1”. 
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Note: After the program restart, in any new model user may retrieve the material 

added to the ADINA program database. To retrieve a material with all constants  

defined (previously by the user), go to “Model → Materials → Manage Materials...” 

or press the button , then in the newly opened window (if the material has been 

previously added to the program database), press the “Get MDB” button. A new 

window with a table should open, then select the material named “Steel” in the table 

and press the “Retrieve” button. No there is no need in defying the material constants 

every time the new model has been created.  

STEP 12. Definition of cross-section(s) 

In order to define cross-section shapes, select “Model → Cross-Sections...” from the 

menu or press the button . After opening of a new window, press the “Add...” 

button and enter the following data: 
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Section Number: 1 

Type: I-Beam 

Dimensions 

Width W1: 0.08 

Height H: 0.15 

Width W2: 0.08 

Thickness T1: 0.012 

Thickness T2: 0.008 

Thickness T3: 0.012 

 

The remaining options are left unchanged. The window view with the entered data 

is shown in the figure below. 

After entering the data, save them by pressing the “Save” button and then you can 

exit the window by pressing the “OK” button. 
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STEP 13. Definition of boundary conditions (fixity characteristics) 

In this step, it is needed to define following supports: clamped, pinned, and pinned 

with ability to move against horizontal direction. To define supports and their type, 

go to “Model → Boundary Conditions → Apply Fixity...” or press the button . 

When a new window opens, enter the following data: 

 

Apply to: Points 

Default Fixity: All 

 
The next step is to press the “Define...” button located next to the drop-down list  

for the “Fixity” option. After opening the next window, press the “Add...” button, 

then enter the following name of the support “Clamped”, confirm the fixity name 

with “OK” button and make following changes in the window:  

 

Y-Translation Checked 

Z-Translation Checked 

X-Rotation Checked 

Fluid Potential Unchecked 

Pore Fluid Pressure Unchecked 

Beam Warp Unchecked 

Temperature Unchecked 

 
After entering the data, press the “Save” button and then “Add...” again to add the 

pinned support. When prompted to enter a name, you can enter “Pinned” and then 

press the “OK” button. Then enter the following data: 

 

Y-Translation Checked 

Z-Translation Checked 

X-Rotation Unchecked 

Fluid Potential Unchecked 

Pore Fluid Pressure Unchecked 

Beam Warp Unchecked 

Temperature Unchecked 
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Once again press “Save”, then “Add…” to add the last support – pinned one with the 

ability to move in the horizontal direction. According to that, name the support as 

“Pinned_FTY” – the ‘FTY’ suffix is a abbreviated hint which means ‘free translation 

Y’ – and press “OK”. In the window make check/uncheck following options: 

 
Y-Translation Unchecked 

Z-Translation Checked 

X-Rotation Unchecked 

Fluid Potential Unchecked 

Pore Fluid Pressure Unchecked 

Beam Warp Unchecked 

Temperature Unchecked 

 
The Define Fixity windows should look similar to that: 
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As soon as the fixities are defined, please press “OK” button in the “Define Fixity” 

window, and in the “Apply Fixity” window make following changes: 
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Fixity: CLAMPED 

Apply to: Points 

 Point {p} 

1 1 

2 9 

 
Then, press “Apply” button. It applies the clamped support to point ID “1” and “9” 

in the model. Now let’s focus on pinned support. Make the following changes in the 

“Apply Fixity” window: 
 

Fixity: PINNED 

Apply to: Points 

 Point {p} 

1 3 

 
Once again press “Apply” button, and make the following changes: 

 

Fixity: PINNED_FTY 

Apply to: Points 

 Point {p} 

1 6 

 
After entering the data, press the “Apply” button and then leave the window with  

the “OK” button. 

Windows presenting entered data are shown below: 
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STEP 14. Displaying boundary conditions 

To display the defined boundary conditions in the main window of the model, press 

the  button. 

STEP 15. Definition of loads 

Three types of loads will be defined in this model. Load by the structure's own 

weight, linear load and concentrated force. 

In order to define loads, go to “Model → Loading → Apply...” or press the  

button. After opening a new window, the self-weight load of the structure will be 

declared first, so for the “Load Type:” option, select “Mass Proportional” from  

the drop-down list, then for the “Load Number:” option, press the “Define...” button.  

A new window will open, in which one should press “Add...” button to add a new 

load, then enter the data as shown in the table: 
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Mass Proportional Load  

Number: 
1 

Magnitude: 1 

Body #: 1 

Direction Vector 

X: 0 

Y: 0 

Z: –1 

Interpret Loading as (for potential-based fluid  

element only) 

Body Force Checked 

Description: None 

Note: As mentioned in previous examples entering a number greater than 1 in the 

“Direction Vector”, that value is still interpreted as 1 with the sign specified by the 

user. It is possible to enter also “–0.01” in the “Z:” field, which will also be treated 

as “–1”, i.e. a load acting opposite to the “Z” axis. 

Note: The load interpretation “Interpret Loading as (for potential based fluid element 

only)” as the English name suggests only works with potential based fluid elements. 

After entering the data in the window, press the “Save” button and then “OK”, thus 

returning to the “Apply Load” window. The window with the entered data is shown 

in the figure below: 
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Since the declared load is constant throughout the entire analysis, in the main win-

dow – “Apply Load” in the table, this load should be assigned to the load variability 

function over time with id number “1”. The “Apply Load” window should therefore 

be completed as follows: 
 

Load Type: Mass Proportional 

Load Number: 1 

Apply to: Model 

 
In the table, the data should look like this: 
 

 Time Function… Label # 

1 1 1 

 
The window view with the entered data is shown in the figure below: 
 

 
 
After entering the data, press the “Apply” button, and then, without leaving the  

“Apply Load” window, select “Distributed Line Load” from the drop-down list next 

to “Load Type:”, and then press the “Define...” button next to the drop-down list of 

the “Load Number:” field. In the newly opened window, press the “Add...” button 

and enter the following data: 
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Distributed Line Load  

Number: 
1 

Magnitude (Force/Length): –10 000 

Description: None 

 
After entering the data, the window should look like this: 

 

 

 
After declaring the load value, press the “Save” button and then “OK” closing the 

“Define Distributed Line Load” window and return to the “Apply Load” window.  

In the “Apply Load” window following data should be entered: 

 

Load Type: Distributed Line Load 

Load Number: 1 

Apply to: Line 

 
In the table, the data should look like this: 

 

 Line {p} 
Aux.  

Point 
… 

Time  

Function… 
… 

Apply-Load 

Label # 

1 7 1 Empty 1 Empty 2 

2 9 1 Empty 3 Empty 3 

 
After entering the data, press the “Apply” button – this will cause the program to fill 

in the empty spaces with default values. 
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The view of the windows along with the entered data is shown in the figures below: 

 

 

 

 

 
One can notice in the above introductions, the load for line no. “7” was assumed  

to be constant throughout the entire length of the analysis, while for the line with 

identification number “9” a sinusoidal load was applied. 

Lastly, without closing the “Apply Load” window, change the load type “Load 

Type:” by selecting the “Force” option from the drop-down list – concentrated force. 

Declare the force again by pressing the “Define...” button located next to the  

drop-down list for the “Load Number:” option. When a new window opens, enter  

the following data: 
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Concentrated Force Number: 1 

Magnitude: 1 

Force Direction 

X: 0 

Y: 1 

Z: 0 

Description: None 

 
After entering the data, the “Define Concentrated Force” window should look as 

shown in the figure below: 

 

 
 
After entering the data, press the “Save” button and then close the window with  

the “OK” button. Returning to the “Apply Load” window, complete it as follows: 

 

Load Type: Force 

Load Number: 1 

Apply to: Point 

 
In the table, the data should look like this: 

 

 Point {p} Time Function… … Label # 

1 5 2 Empty 4 
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The view of the “Apply Load” window with the entered data is shown in the figure 

below: 

 

 

 
After entering the data, press the “Apply” button – the program will automatically 

fill the empty table columns with default values. After performing all the above  

operations, you exit the window by pressing the “OK” button. 

STEP 16. Displaying active model loads 

To display the loads acting in the model, press the button . The model should 

look like this: 
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Note: The load on the right part of the frame is 0 in the “TIME 90.00” step because 

the value of the load variation multiplier is “0”. To track the load behavior in indi-

vidual time steps, use time manipulators – . 

Note: The concentrated force load is equal to 20 kN in the “TIME 90.00” step  

because the load variation multiplier value is “20000”. As before, manipulators 

should be used to monitor the load behavior in individual time steps. 

STEP 17. Specifying the type of analyzed construction  

In this step, a group of elements with assigned steel material and a cross-section in 

the form of an I-beam will be defined. To go to the definition of a group of elements, 

select “Meshing → Element Groups...” from the menu or press the button . 

After opening a new window, press the “Add...” button and then enter the following 

data: 

 

Group Number: 1 

Type: Beam 

“Basic” tab 

Description: Frame 

Element Sub-Type 2-D 

Displacements: Default 

Stiffness Definition 

Use Material and Cross  

Section 
Checked 

Default Material: 1 

Default Cross Section: 1 

 
The remaining data is left unchanged. The window with the entered data is shown  

in the figure below: 
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After entering the data, press the “Save” button and then close the window with  

the “OK” button. 

STEP 18. Mesh subdivision 

The mesh density will be the same for the entire model, i.e. a mesh with a size of 

0.50 m. To define the mesh density in relation to the entire model, go to “Meshing 

→ Mesh Density → Complete Model...” and then enter the following data in the  

new window: 

 

Subdivision Mode: Use Length 

Element Edge Length: 0.50 

 
The window with the entered data is shown in the figure below: 
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After entering the data, exit the window by pressing the “OK” button. 

STEP 19. Definition of finite elements 

To define finite elements in this example, go to “Meshing → Create Mesh → Line...” 

or press the button , then enter the following options in the window: 

 

Type: Beam 

Element Group: 1 

Nodes per Element: 2 

Orientation (Point overrides Vector) 

X: 0 

Y: 0 

Z: 0 

Auxiliary Point: 6 

Vector System: Skew 

Table “Lines to be Meshed” 

 Line {p} 

1 1 

2 2 

3 3 

4 6 

5 7 

6 8 

7 9 
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Note: Line IDs “4” and “5” have been omitted due to the fact, that they would have 

been collinear with the chosen auxiliary point. The introduction of finite elements 

must have been divided into two stages, because if a point number “6” is used as  

an “Auxiliary Point” and lines numbered “4” and “5” are entered, the program will 

return an error that the line coincides with the point. Moreover, in the program it is 

not possible to indicate the direction of the local cross-section coordinate system. 

This option is particularly important when cross-sections other than bisymmetric  

are used. The content of the error message is shown in the figure below: 

 

 
 
The window with the properly entered data is presented in the figure below: 

 

 
 
After entering the data, press the “Apply” button and then, without leaving the  

window, enter the following data: 
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Type: Beam 

Element Group: 1 

Nodes per Element: 2 

Orientation (Point overrides Vector) 

X: 0 

Y: 0 

Z: 0 

Auxiliary Point: 3 

Vector System: Skew 

Table “Lines to be Meshed” 

 Line {p} 

1 4 

2 5 

 
Window view with entered data: 

 

 
 
After entering the data, press the “Apply” button and then leave the window with  

the “OK” button. 
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After entering all the data, the model should look something like this: 
 

 

STEP 20. Definition of perfectly rigid connections 

To define perfectly rigid connections and their graphical representation in the model, 

you must first enable the display of the cross-section. To do this, go to “Display → 

Geometry / Mesh Plot → Modify...” or press the button . Then, in the newly 

opened window, locate the “Element Depiction...” button in the “Mesh Attributes” 

group and press it. When the new window opens, select the “Display Beam Cross 

Section” checkbox. The window view with the introduced change is shown in the 

figure below: 
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After making changes, press the “Save” button, then leave the window with the “OK” 

button. Then, in the “Modify Mesh Plot” window, press “Apply” and also leave  

the window with the “OK” button. 

The next step is to enable the display of finite element identification numbers.  

First, you can disable the display of point ID numbers by turning off the button , 

then activate the display of finite element ID numbers by pressing the button . 

With the finite element ID numbers enabled, you should proceed to the definition of 

perfectly rigid connections. To do this, select “Meshing → Elements → Element 

Data...” from the menu and after opening a new window, enter the following data: 

 

 
Beam  

Element # 
… 

Rigid End-Zone 

(Length from 

Start) 

Rigid End-Zone 

(Length from 

End) 

… 

… … … … … … 

5 5 … 0 0.25 … 

… … … … … … 

10 10 … 0 0.25 … 

11 11 … 0.25 0 … 

… … … … … … 

15 15 … 0 0.25 … 

… … … … … … 

20 20 … 0 0.25 … 

21 21 … 0.25 0 … 

… … … … … … 

25 25 … 0 0.25 … 

26 26 … 0.25 0 … 

… … … … … … 

35 35 … … 0.25 … 

36 36 … 0.25 0 … 

… … … … … … 

40 50 … 0 0.25 … 

… … … … … … 

45 55 … 0 0.25 … 

46 56 … 0.25 0 … 

… … … … … … 

50 60 … 0 0.25 … 
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The window with example data is shown in the figure below: 

 

 
 
After entering all the data in the table, press the “Apply” button and then “OK”. 

Note: The “Rigid End-Zone (Length from Start)” and “Rigid End Zone (Length from 

End)” options refers to the lines directions. In the case of the “Length from Start” 

option, the length of a perfectly rigid element is measured from the beginning of  

a given finite element in the same directions as an arrow indicating the direction  

of the line, while for “Length from End” works opposite – the distance is measured 

from the line end in the opposite direction of line direction arrow. 
 

 
 

Note: The “Beam Elements” ID numbers do not have to match the table row numbers. 

Also, the numbers of finite elements may differ between those given in the example 

and those that the user sees in his model. Particular attention should be paid to this 

when introducing perfectly rigid elements. In case the user have different element 

numbers at the connections, please use them, instead of that given in the table. 

End 

Start 
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Note: User can check the number of a given finite element by selecting the button 

 and then pressing the given finite element. The element ID number and element 

group are displayed in the “Message Window” at the bottom of the screen: 

 

 
 

After returning to the main modeling window, press the button  causing the 

display of the current model to be refreshed. The current model should look like this: 

 

 
 
One can notice in the drawing above, perfectly rigid elements in the frame nodes  

are marked with bold lines. If the lines meet at the nodes (as in the drawing above), 

it means that these elements have been defined as intended. 

STEP 21. Saving existing model to a file 

Each model should have been saved to a file between few steps taken in order to  

not lose the data. According to that select “File → Save as...” from the menu. When 

a new window opens, indicate the location of the saved file and its name. 

Note: Do not uses spaces in the file names, because it leads to an error! The space 

can be replaced with the underline character __. 
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STEP 22. Starting calculations 

In order to start calculations, choose “Solution → Data File/Run” from the upper 

menu tabs, or choose  from the toolbars. Subsequently, input the path for saving 

the resultant file. However, before the user clicks the “Save” button, they should 

make sure that the “Run Solution” and “Automatic” function near the “Maximum 

Memory for Solution” options are selected in the window in the “Adina Structures 

Solution” group of options. After starting the calculations and recalculating the 

model, close all three dialogue windows which appeared during the calculations. 

Note: Depending on the complexity of the model and the number and type of finite 

elements used, model calculations may take from a few seconds to even several hours. 

Note: In new versions of ADINA software start of calculations may fail due to  

the following messages: 
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It means that the “warping DOF” – warping degree of freedom should have been 

introduced to the beam model, cause existing one may lead to incorrect results.  

According to that, one should go back to the definition of element groups. Please 

select “Meshing → Element Groups...” from the menu or press the button . 

After opening a new window, check if the “Element group:” drop-down list has  

number “1”, if yes change the following data: 

 

Group Number: 1 

 “Basic” tab 

Element Sub-Type 3-D 

Include Warping DOF Checked 

 
The window with applied options is shown below: 

 

 

 
The remaining data left unchanged, press “Save” and “OK” button to leave the win-

dow. Now, once again start the calculations by choosing “Solution → Data File/Run” 

from the upper menu tabs, or choose  from the toolbars.  



Example 3. Deformations of a planar frame with rigid connections at nodes subjected to the variable … 

135 

STEP 23. Post-processing module (results) 

In order to go to the results module, change “ADINA Structures” to “Post-Process- 

ing” in the drop-down list of the “Module” toolbar. 

 

 
 
When the user is prompted that the changes in the drawing have not been saved, it is 

recommended to save the model by going to “File → Save” or using the button . 

STEP 24. Opening the resultant file 

In order to open the resultant file, choose  from the toolbar, or choose “File → 

Open” from the upper menu tabs. 

STEP 25. Determination of the maximum vertical and horizontal 

displacement and the maximum normal force,  

shear force and bending moment 

To determine the maximum horizontal and vertical displacement in the resulting 

model, go to “List → Extreme Values → Zone...”, then select the following data in 

the newly opened window: 
 

Zone Name: WHOLE_MODEL 

Type: Absolute Maximum 

Number: 1 

Response Option 

Range: Checked 

Response Range: DEFAULT 

Result Grid: DEFAULT 

Response Control: DEFAULT 

Smoothing Technique: DEFAULT 

 

Variables to List 

1 Displacement Z-DISPLACEMENT 

2 Displacement Y-DISPLACEMENT 
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After entering the data, press the “Apply” button. The window view with the entered 

data is shown in the figure below: 

 

 

 
As can be seen in the figures above, the maximum vertical and horizontal displace-

ments are: 
 

Displacement Z Time 

–1.91487E-02 9.00000E+01 

Displacement Y Time 

1.44052E-01 9.00000E+01 

 
User can also display the maximum normal and shear forces and moments at finite 

element nodes. To do this, in the same window (List Zone Extreme Values), change 

the values to be displayed: 
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Variables to List 

1 Force NODAL_FORCE-R 

2 Force NODAL_FORCE-S 

3 Force NODAL_MOMENT-T 

 

After entering the data, press the “Apply” button. The maximum values should be  

as follows: 
 

Normal force Time Node Element 

2.02108E+04 9.00000E+01 1 6 

–2.02108E+04 9.00000E+01 2 6 
 

Shear force Time Node Element 

2.05601+04 9.00000E+01 1 25 

–2.05601E+04 9.00000E+01 2 25 
 

Moment Time Node Element 

1.93204E+04 9.00000E+01 2 25 

 

The window view with the entered data is presented in the figure below. After  

completing the operation, you can close the window with the “Close” button. 
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STEP 26. Preparing diagram of the global displacement  

of the connected nodes of the main aisle and the side ones 

First, user need to reset the model view. To do this, press the  and  button, 

respectively. Then, turn on the display of finite element node numbers by pressing 

the button , you also turn on the graphical display of these nodes by pressing 

the button . Currently the model should look like this: 

 

 

 
The nodes in relation to which the displacement graph will be drawn are marked 

with dashed line circles. In the author’s case, the node number of the left aisle is “13” 

and the right one is “33”. 

Note: Node numbers may differ between the user's model and the author’s model. 

The next stage is to define the points of interest by the user that will be involved  

in the presentation of the diagram. To do this, go to “Definitions → Model Point → 

Node...”. After opening a new window, press the “Add...” button and enter the title 

for the first point, e.g. “Left_aisle”, and then use the “P” button to select the connect-

ing node of the left aisle with the main one from the model. The data in the window 

should look like this: 
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Model Point Name: LEFT_AISLE 

Node #: 13 

Substructure: 0 

Reuse: 1 

 
After entering the data, press the “Save” button and then “Add...” again. Enter the 

title for the “Right_aisle” node again, press the “P” button in the “Define Model 

Point (Node Point)” window and select the connecting node of the right aisle with 

the main one. The data in the window should look like this: 

 

Model Point Name: RIGHT_AISLE 

Node #: 39 

Substructure: 0 

Reuse: 1 

 
The view of the windows along with the entered data is shown in the drawings below: 
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After entering the data, press the “Save” button and then leave the window with the 

“OK” button. One can also clear the results window by pressing the button . 

To create a graph, go to “Graph → Response Curve (Model Point)”, then when  

a new window opens, press the “...” button next to the “X-Axis” option. In the newly 

opened window, press the “Add...” button and enter “X” as the title. Then change  

the following options in the window: 

 

… 

Label Attributes 

Type: Custom 

Color: BLACK 

Font Size: 0.30 

Unit: CM 

Scale Factor: 1 

Table: 

 Label: 

1 time 
 

Appearance 

Color: GRAY 

Line Width: 0 

Unit: CM 

Font Size: 0.30 

Unit: CM 

Draw Line at Value = 0 Checked 

Tick Direction 

Out Checked 

Number of Minor Ticks: 10 

Draw Line at Each Major Tick Checked 

 
After entering the data, press the “Save” button and close the window with the “OK” 

button. The window view with the entered data is shown in the figure below: 

 



Example 3. Deformations of a planar frame with rigid connections at nodes subjected to the variable … 

141 

 
 
After returning to the “Display Response Curve (Model Point)” window, press  

the “...” button next to the “Y-Axis” option in “Graph Attributes” group. Once the 

window opens, press the “Add...” button and enter “Y” as the axis title. Then enter 

the following data in the window: 
 

… 

Axis Type and Value Range 

Linear Checked 

Min. Value: 0 

Max. Value: 0.08 

Label Attributes 

Type: Custom 

Color: BLACK 

Font Size: 0.30 

Unit: CM 

Scale Factor: 1 
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Table: 

 Label: 

1 Displacement 
 

Appearance 

Color: GRAY 

Line Width: 0 

Unit: CM 

Font Size: 0.30 

Unit: CM 

Draw Line at Value = 0 Checked 

Tick Direction 

Out Checked 

Number of Minor Ticks: 10 

Draw Line at Each Major Tick Checked 

 

Once again, after entering the data, press the “Save” button and then leave the  

window with the “OK” button. The window view with the entered data is shown  

in the figure below: 
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After returning to the “Display Response Curve (Model Point)” window, press the 

“...” button, this time next to the “Curve Depiction” option in “Graph Attributes” 

group. When the window opens, press the “Add...” button and enter “Left_aisle”  

as the line title. Then enter the following data in the window: 

 

 “Curve” tab 

Symbol Attributes 

Display Curve Symbol Checked 

Symbol: CURVE 

Interval: 10 

Color: RED 

Size: 8 

Unit: Pixels 

Line Attributes 

Solid Checked 

Color: RED 

Width: 3 

Unit: Pixels 

X-Axis-To-Curve Line Attributes 

Draw Lines from X-Axis  

to Curve Points 
Unchecked 

 “Legend” tab 

Legend Attributes 

Type: Custom 

Color: RED 

Font Size: 0.25 

Unit: CM 

Scale Factor: 1 

Placement 

Automatic Checked 

Display Curve Symbol  

in Legend 
Checked 

Custom Legend: 

 Legend: 

1 Left aisle 
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After entering the data, press the “Save” button, then press the “Add...” button again, 

enter the title “Right_aisle”, press the “OK” button, and then enter the following data 

in the window: 
 

 “Curve” tab 

Symbol Attributes 

Display Curve Symbol Checked 

Symbol: CURVE 

Interval: 10 

Color: BLUE 

Size: 8 

Unit: Pixels 

Line Attributes 

Solid Checked 

Color: BLUE 

Width: 3 

Unit: Pixels 

X-Axis-To-Curve Line Attributes 

Draw Lines from X-Axis  

to Curve Points 
Unchecked 

 “Legend” tab 

Legend Attributes 

Type: Custom 

Color: BLUE 

Font Size: 0.25 

Unit: CM 

Scale Factor: 1 

Placement 

Automatic Checked 

Display Curve Symbol  

in Legend 
Checked 

Custom Legend: 

 Legend: 

1 Right aisle 
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After entering the data, press the “Save” button and then leave the window with  

the “OK” button. The view of the windows along with the entered data is shown  

in the drawings below: 
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After returning to the “Display Response Curve (Model Point)” window, one need to 

enter the model title. To do this, press the “...” button next to the “Graph Depiction” 

option. In the newly opened window, press the “Add...” button, and when prompted 

for an identifying name for the data entered for the chart, enter “Diagram”. Then 

enter the data presented in the table below: 
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Box Attributes 

Display Graph Box Unchecked 

Title Attributes 

Type: Custom 

Color: BLACK 

Font Size: 0.50 

Unit: CM 

Scale Factor: 1 

Placement 

Automatic Checked 

Graph Title: 

 Title 

1 Graph of displacement in time function 

2 for left and right aisle 

 

After entering the data, save the changes with the “Save” button and then exit the 

window with the “OK” button. The window view with the entered data relating to 

the appearance of the diagram is shown in the figure below: 
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In the “Display Response Curve (Model Point)” window, enter the following data: 
 

X Coordinate 

Variable: Time 

 TIME 

Model Point: LEFT_AISLE 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Y Coordinate 

Variable: Displacement 

 DISPLACEMENT_MAGNITUDE 

Model Point: LEFT_AISLE 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Graph Attributes 

Plot Name: Empty 

Graph Style: Empty 

X-Axis: X 

Y-Axis: Y 

Curve Depiction: LEFT_AISLE 

Graph Depiction: DIAGRAM 

Subframe: DEFAULT 

Response Range: DEFAULT 
 

After entering the data, press the “Apply” button to apply the entered data. The window 

view with the entered data is shown in the figure below: 
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Then, in the “Display Response Curve (Model Point)” window, make the following changes: 
 

X Coordinate 

Variable: Time 

 TIME 

Model Point: RIGHT_AISLE 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Y Coordinate 

Variable: Displacement 

 DISPLACEMENT_MAGNITUDE 

Model Point: RIGHT_AISLE 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Graph Attributes 

Plot Name: Empty 

Graph Style: Empty 

X-Axis: X 

Y-Axis: Y 

Curve Depiction: RIGHT_AISLE 

Graph Depiction: DIAGRAM 

Subframe: DEFAULT 

Response Range: DEFAULT 
 

After entering the data, press the “OK” button to apply the entered data and close  

the window. The window view with the entered data is shown in the figure below: 
 

 



I. Major, M. Major, K. Kuliński 

150 

After performing all the above operations, the diagram in the main results window 

should look something like this: 

 

 

Note: Title and lines depiction are rearranged with mouse click and drag-drop. 
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○ Three-dimensional problems 
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EXAMPLE 4  

THE SPATIAL MODEL OF A SINGLE-CLAMPED ROUND BAR 

SUBJECTED TO STRETCHING 

In this example a one-sided clamped bar with a circular cross-section subjected to 

stretching and mass-proportional load is modelled. In the analysis the spatial Carte-

sian coordinates system is used. It is recommended for the reader to get acquainted 

with the previous examples, since some of the functions were discussed earlier.  

A diagram of the analyzed model is presented in Figure 22. 

 

 

Fig. 22. Scheme of a bar with circular cross-section 

The following data is used in the analysis: 

– bar cross-section: 

circular with + = 0.10 m 

– load: 

tensile: 
 = 10000 N/m( 

– material constants: 

steel S235JR 

� = 210 GPa = 2.1e�� Pa 

� = 0.30 

� = 7859 kg/m� 

STEP 1. Definition of the type of analysis 

Upon opening the ADINA software, choose “ADINA Structures” from the “Module 

Bar” in the “Program Module” section, and choose “Statics” from the drop-down list 

next to “Analysis Type”. 
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Moreover, click , and in the newly opened window make sure that in the drop-

down list a “Use Automatic Time Stepping (ATS)” option is chosen, if not please  

it should be chosen, then confirm the choice with the “OK” button. 

 

 

STEP 2. Entering the heading of the model 

In order to specify a heading, go to “Control → Heading…”. Subsequently, enter the 

project heading in the text box, e.g., “Stretched bar with circular cross-section”. 

Upon entering a heading, click the “OK” button. 

STEP 3. Definition of the background color of the main model  

window 

In order to define the background color, go to “Edit → Background Color…”.  

Then, in the newly opened window choose the color white from the drop-down list. 

After choosing confirm the choice with the “OK” button. 

 

 

Note: The background color is not saved along with the model. This means that after 

each opening of the file, the background color will return to default – “black”. 

STEP 4. Definition of global boundary conditions 

Since the model is a spatial model, all degrees of freedom should be included. Go to 

“Control → Degrees of Freedom…”. In the newly opened window, select all boxes 

related to the degrees of freedom.  
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Note: Although the example uses a circular element (similar to ‘pipe’) and bending 

with respect to the Z axis and stretching along the X axis will be taken into consid-

erations (similarly as for 2D type of analysis), the “Ovalization/Warping DOF at 

Pipe Element Nodes” option should remain as “None”. It is connected with fact,  

that the model will be represented with volumetric finite elements, not via 1D (line) 

elements with assumed cross-section. The cross-section of a bar will be modeled 

directly in this example. Window with the input data is presented above. 

STEP 5. Definition of the number of time steps 

In order to define time steps, go to “Control → Time Step…”. Then in the newly 

opened window enter a value of “100” in the first row of the “Number of Steps” 

column, and a value of “0.1” in the same row of the “Constant Magnitude” column. 

Upon the values are introduced, click the “Save” button, followed by “OK”.  

The window view is shown in the figure below: 
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STEP 6. Definition of load variability in subsequent time steps 

Linear variability of load over time will be used for the purpose of the present exam-

ple. It is assumed that the load will increase from 0 to its maximum value over a time 

of 5 s, then the load will decrease linearly to reach a value of 2000 N at a time of  

10 s from the start of the analysis. 

In order to declare the variability of load over time, go to “Control → Time Func-

tion…”. In the newly opened window enter following data: 
 

Time Function Number: 1 

Function Multiplier: Constant (=1.0) 

 

And in the table make the following changes: 
 

 Time Value 

1 0 0 

2 5 1 

3 10 0.2 

 

After entering the data for function number “1”, user can press the “Graph” button 

and the following graph should appear: 
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The chart window should then be closed by pressing the “X” button in the upper right 

corner. After entering all the data, press the “Save” button and then leave the window 

with the “OK” button. The “Define Time Function” window with introduced data 

should look as: 

 

 

STEP 7. Definition of points 

In order to define points, go to “Geometry → Points → Define…” in the main model 

window, or click . Upon opening a new window, input points in accordance 

with the table below: 

 

Point # X1 X2 X3 System 

1 0 0 0 0 

2 1 0 0 0 

3 0 0.05 0 0 

4 1 0.05 0 0 

 
As soon as all the data is introduced, click the “Save” button, followed by “OK”. 

The window view with the entered data is shown in the figure below: 
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Note: There is no need to enter zero values into the table. The software will assume 

them by itself after clicking the “Save” button. 

Note: In older ADINA software versions, once the points are introduced in the table 

and saved, the program will display an XY plane (2D); a proper view of the space 

may be achieved later. Currently, it is easier to work in a planar rather than in  

a spatial system. In newer ADINA versions program automatically shows points  

in the isometric view. 

STEP 8. Displaying point ID numbers 

To display point identifiers in the XY plane, press the arrow located on the  

button and select “+XY view”. Subsequently press the  button. The model 

should look something like this: 
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STEP 9. Definition of surface(s) 

Due to the fact that points have already been created, it is possible to define surface 

on that points. In order to declare a surface, go to “Geometry → Surfaces →  

Define…”, or click . Upon opening a new window, click the “Add…” button 

in order to add surface no. 1. Since the surface will be created on the basis of existing 

points, the surface type “Type:” should be set as “Vertex”. Enter the data as provided 

in the table below: 

 

Surface Number: 1 

Type: Vertex 

Point 1: 1 

Point 2: 2 

Point 3: 4 

Point 4: 3 

 
The points numbers forming the surface may be entered using the keyboard or by 

mouse – previously hitting the “P” button standing near the empty field of “Point 1:” 

option. It should be noted, that the order of points is important. Picking points which 

would form a planar surface with crossing lines should be avoided. 

A window with properly input data is presented in the figure below: 
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STEP 10. Displaying line ID numbers 

In order to display the numbers of lines for their easier identification, click  

button. 

STEP 11. Displaying surfaces ID numbers 

In order to display the numbers of surfaces for their easier identification, click  

button. The model should look like in the figure below: 

 

 

STEP 12. Displaying the model in a desired plane/space 

In order to display the model on a proper plane or in space, click the arrow next to 

. Then choose a proper display option from the drop-down list. For the pur-

pose of the present example, choose “IsoView 1”. A view of the model is presented 

in the figure below: 
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STEP 13. Mesh subdivision 

Definition of the density of a finite element mesh before the creation of a volumetric 

element enables the generation of a radially propagating mesh for circular elements. 

In order to define the mesh density for the surface, go to “Meshing → Mesh Density 

→ Surface…”. Then in the newly opened window make following changes: 

 
Base surface: 0 

Method: Use Number of Divisions 

Progression of Element  

Edge Lengths: 
Geometric 

Number of Subdivisions 

u: 100 

v: 5 

Length Ratio of Element Edges (Last/First) 

u: 1 

v: 1 

Use Central Biasing for 

u Direction Unchecked 

v Direction Unchecked 

Assign to Following Surfaces (Table) 

 Surface {p} 

1 1 

 
Upon introducing all the data, click the “Save” button, followed by “OK”. A view 

of the data window is presented in the figure below: 
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Note: Creating a mesh before creating a volumetric element has an additional  

advantage. Such an approach of specifying a mesh density before creating a volu-

metric element allows to save time – in case a volumetric element is created first,  

the density of meshing must be adjusted to the faces of a cylinder, and to the line 

forming the mantle of the cylinder. Moreover, the definition of finite elements in  

a model created in this manner may cause these elements to not be created  

radially. 

STEP 14. Definition of a volumetric element 

In order to define volumetric elements, go to “Geometry → Volumes → Define…”, 

or click . When a new window opens, click the “Add…” button in order to add 

a volumetric element to the model, with the id number “1” and enter following  

data: 
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Volume number: 1 

Type: Revolved 

Initial surface: 1 

Number of Mesh Subdivisions 50 

Angle of Rotation (Degrees) 360 

Axis of Revolution 

Defined by: Axis 

Axis: X 

Coord. System: 0 

Coincidence Checking 

Check Coincidence Checked 

Tolerance 0 

 
Choosing the “Revolved” option from the drop-down list in “Type:” box will cause 

the creation of a volumetric element by revolving a surface around a specified axis 

of revolution. Enter a value of “1” in the “Initial Surface” box, or click the “P” button 

and indicate a surface for rotation in the main program window. In the “Angle of 

Rotation:” box, enter a value of “360” – full rotation, and enter a value of “50”  

for the “Number of Mesh Subdivisions:” option. It is a value of division of a finite 

element mesh for a circle created by rotation of the surface. All that remains is to 

make sure that rotation will proceed with respect to the “X” axis, meaning that  

the “Axis of Revolution” group of options in the “Defined by:” box should have  

the “Axis” option selected from the drop-down list, with the “X” option selected  

in the “Axis” box. In addition, the “Check Coincidence” option should be selected. 

Upon inputting all the data, click the “Save” button, and then “OK”. The figure  

below presents the window along with the input data: 
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Note: Upon clicking the “Save” button, the following message will be displayed: 

 

 

 
This message pays user attention to the fact that the created volumetric element  

has two vertices, and that some of the loads, such as pressure, heat flux or traction, 

may have a wrong direction compared to the definition. 
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In such a case, when this message is displayed, it is recommended to take special 

care when defining loads. After getting acquainted with this message, close it using 

the “OK” button. 

When a volumetric element has been input into the model via rotating a surface 

around the X axis, the view of the lines ID numbers can be deactivated with , 

and those of points with . 

Note: Only one possible way of creating a volumetric element by rotating a surface 

is presented above. Rotation can be performed in 4 ways – by indicating an axis  

of the coordinate system as the axis of rotation (as it was done in the example),  

by choosing two points between which an invisible line forming the axis of rotation 

is generated, by selecting a line specifying the axis of rotation from the model,  

or by defining a rotation vector. 

STEP 15. Displaying volumetric elements ID numbers 

In order to display the ID numbers of volumetric elements, click  button.  

The model window should look like this: 

 

 

STEP 16. Definition of material constants 

In order to go to the definition of material constants, choose the “Model → Materials 

→ Manage Materials” tab, or click , then click the “Get MDB” button in the 
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newly opened window (when materials have previously been added to the program 

database). Then select a material named “Steel” from the table, and click the  

“Retrieve” button. When the material has been loaded from the program database, 

click the “Close” button. In the lower part of the “Manage Materials” window,  

the Steel material returned from the database should be present in the table cell with 

the id number “1”. A view of the window for retrieving materials from the database 

is presented below: 
 

 
 
When the material required in the example is absent from the database, in the  

“Manage Materials” window find a group referring to elastic materials – “Elastic”, 

and then click the “Isotropic” button (isotropic material).  
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In the newly opened window, first click “Add…” in order to add a new material, and 

then enter the values of material constants as shown in table below: 

 

Material Number: 1 

Description: Steel 

Young’s Modulus 

(> 0) 
2.1e11 

Poisson’s Ratio 

(–1.0 < NU < 0.5) 
0.30 

Density 7859 

Coef. of Thermal Expansion 

(>= 0) 
0 

 
The view of a window with the material constants introduced in the elastic material 

definition is shown in the figure below: 

 

 

 
Upon inputting the data, click the “Save” and “OK” buttons. The main material  

manager window “Manage Materials” looks like in the figure below: 
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The last step is to close the “Manage Materials” window with the “Close” button. 

STEP 17. Definition of boundary conditions (fixity characteristics) 

In order to define and apply a fixity in the system, go to “Model → Boundary  

Conditions → Apply Fixity…”, or click . Since the example includes clamped 

support, and the program has a declared fixity with all degrees of freedom fixed  

by default (fixity name: “All”), there is no need to declare the fixity once again.  

In the “Apply Fixity” window, choose: 

 

Fixity: ALL 

Apply to: Face/Surface 

 Face Surface {p} 

1 4 

 
A surface having its center at the point 0;0;0 should have been chosen above. In case 

of selecting by mouse method when a proper surface has been selected from the 

model window, press the ESC key to end the selection, and return to the window  

for applying boundary conditions. Upon entering the surface number in the “Apply 

Fixity” window, click the “Save” button, and then “OK”, therefore closing the  

window. A view of the window with the input data is presented below: 
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Note: Since double-clicking the table with the left mouse button results in moving 

the user to the model window, prior care should be taken to make the interesting 

surface or another element visible before performing this operation. It should be 

taken into considerations due to model cannot be rotated during the selection.  

Therefore (even with an open window for applying boundary conditions, loads, etc.), 

the model should be rotated, so that the part which is going to be selected should be 

visible. In order to activate the rotation option, click , and then hold the left 

mouse button over the model and move the mouse to rotate the model. Different 

method is to click the model once, to get the model in a dashed line box, then hold 

“SHIFT” button from the keyboard, click and hold left mouse button on the model, 

and then move the mouse, which will result in model rotation. In case of view  

the model from a different side/angle, it may prove helpful to use , which 

allows displaying the proper view plane. In this case, a perfect view of surface “S4” 

is achieved by clicking the arrow next to the button, and selecting “IsoView 3”. 

STEP 18. Displaying boundary conditions 

In order to display the defined boundary conditions in the main model window,  

click  (after selecting the “IsoView 3” view type from ). Currently,  

the model should look like this: 
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STEP 19. Definition of loads 

In order to define a load, choose “Model → Loading → Apply…” from the upper 

menu, or click . In the newly opened window, define both the mass-propor-

tional load and an external load in the form of a surface load (pressure). After open-

ing a new window, the self-weight load of the structure will be declared first,  

so for the “Load Type:” option, select “Mass Proportional” from the drop-down list, 

then for the “Load Number:” option. 
 

Load Type: Mass-proportional 

Apply to: Model 

 

Then press the “Define...” button. A new window will open, in which one should 

press “Add...” button to add a new load, then enter the data as shown in the table: 

 

Mass Proportional Load Number: 1 

Magnitude: 1 

Body #: 1 

Direction Vector 

X: 0 

Y: 0 

Z: –1 

Interpret Loading as (for potential-based fluid element only) 

Body Force Checked 

Description: None 

 

Finally, save the defined load by clicking the “Save” and “OK” buttons. 
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Upon returning to the “Apply Loads” window, insert following data: 
 

Load Type: Mass Proportional 

Load Number: 1 

Apply to: Model 
 

In the table, the data should look like this: 
 

 Time Function… Label # 

1 1 1 
 

The window view with the entered data is shown in the figure below: 
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When this operation is completed, click the “Apply” button to apply a load caused 

by the mass-proportional load in the model without leaving the window. A view of 

the window along with the input mass-proportional load is presented in the figure 

above. 

As soon as mass-proportional load is defined and assigned, choose “Pressure” from 

the “Load Type:” drop-down list and choose following data: 

 

Load Type: Pressure 

Apply to: Surface 

 
After this operation, click the “Define…” button, and the “Add…” button in the 

newly opened window and enter following data: 

 

Pressure Number: 1 

Magnitude (Force/Area): 10000 

Description: None 

 
Remaining options leave unchanged and then confirm the input data with the “Save” 

button, and subsequently close the window with the “OK” button. The figure below 

presents the define pressure window: 
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Upon leaving the window for defining pressure, in the “Apply Load” window enter 

the following data: 

 

Load Type: Pressure 

Load Number: 1 

Apply to: Surface 

 
In the table, the data should look like this: 

 

 Surface {p} 
Deform.  

Dependent? 

Load  

Direction 
… 

Apply-Load 

Label # 

1 2 YES X-direction Empty 2 

 
First of all the surface no. 2 should have been chosen.Therefore, enter a value of “2” 

in the first row. This can also be entered by double-clicking the “Surface {p}” column 

with the left mouse button, selecting the desired surface directly from the model,  

and completing the selection with the “ESC” key. 

Note: As already previously mentioned, double-clicking the table with the left 

mouse button results in moving the user to the model window. Therefore, prior care 

should be taken for the surface or another element to be visible before performing 

this operation (see the previous Note). In this case, a perfect view of surface “S2” 

will be achieved by selecting “IsoView 1”. 

The “Deform. Dependent?” option set as “yes” means that the load will adjust its 

direction together with the rod deflection. In example, having a load perpendicular 

to the plane, as soon as the finite element starts to deform, the pressure is divided 

into appropriate concentrated forces acting on finite element nodes, and this load 

during the analysis will always be perpendicular to the tangent line/plane of finite 

element outline. Choosing the “Global X-Dir.” option specifies that the load will act 

in accordance with the X axis of the main coordinate system. Once these operations 

are completed, the horizontal scroll bar in the “Apply Load” window should be 

moved to the right, until the “Label #” column appears. In this column, enter a value 

of “2” in the first row, which becomes the identification number of the pressure load. 

As soon as all the values are introduced, click the “Apply” button and “OK” closing 

the window for defining and assigning loads. The following figures present the  

application of pressure load in the model: 
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STEP 20. Displaying active model loads 

In order to display defined loads in the main model window, click  (a view for 

the “IsoView 1” option selected by means of the arrow next to ). The model 

window looks like this: 

 

 

Note: The figure above may be unclear. Since during earlier declaration of the  

volumetric element, there was a message that some of the loads such as pressure, 

heat flux and traction may have a different direction compared to the definition,  

it is necessary to check whether the existing load is consistent with our declaration. 

To this end, magnify the model in the area of load by means of  (selecting the 

area of interest). The arrows of load should be directed toward surface S2, as shown 

in the figure below. 
 

 
 

If everything is correct, shrink the element to the default view by means of . 
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Since the default choice of the program is to display the last time step (in the present 

example 10 s – “Time 10.000” on the screen), the load is also adjusted to this time 

step. It was previously declared that at the 10 s the load is supposed to reach 0.2  

of the maximum value, meaning 2000 N. 

 

 
 

Changing the time in the model by means of  until “Time 

5.000” is displayed (for a maximum load), and then double-clicking  will cause 

the displayed load value to amount to “10000”. The figure below presents the model 

with the time set as “Time 5.000”. It should be noted that changing the time step  

via  buttons does not update the values of applied loads. 

STEP 21. Specifying the type of analyzed construction 

The present example requires the creation of only one element group. It is connected 

with the analyzed bar is made of a single type of material only. 

In order to create an element group, go to “Meshing → Element Groups…”, or click 

. After opening a new window, press the “Add...” button and then enter  

the following data: 
 

Group Number: 1 

Type: 3D-Solid 

 “Basic” tab 

Description: Round_bar 

Element Option: None 

Default Material: 1 
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The remaining options remain unchanged. The window with the entered data is shown 

in the figure below: 
 

 
 

Upon inputting all the data, click the “Save” button, and then “OK”.  

STEP 22. Definition of finite elements 

In order to define finite elements in the model, go to “Meshing → Create Mesh → 

Volume…”, or click . Once the new window has opened enter following data: 
 

“Basic” tab 

Type: 3-D Solid 

Element Group: 1 

Nodes per Element: 8 

Volumes to be Meshed 

 Volume {p} 

1 1 

“Options” tab 

Rule-Based Checked 

Preferred Cell Shape: Hexahedral 
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Remaining options leave unchanged. Window with entered data are presented  

below: 
 

 
 

 

 
Upon inputting all the above mentioned data, click the “Apply” button, and then 

“OK”. When all the settings have been applied, the model should look like in the 

figure below (the view is set as “IsoView 1”). 
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Once the view of the identification numbers of surfaces has been deactivated with 

, and those of volumetric elements with , and the view of boundary  

conditions  and loads  has been deactivated, the model should display  

the finite element mesh only. 
 

 
 

Magnification of the cylinder base can be achieved by means of ; the view 

looks like this: 
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As can be seen in the figure above, finite elements propagate radially, as was  

previously assumed.  

Note: For a different way of creating an element with a cylindrical shape, and when 

willing to prepare a finite element mesh, it may be helpful to select the “Wedge 

Volumes Treated as Degenerate” function in the “Mesh Volume” window, which  

in the present example was active by default. 

STEP 23. Model presentation types 

By keeping the magnification of the analyzed bar, it is possible to demonstrate  

the action of the following buttons: , , , and . 

In the program, the button named “Hidden Surfaces Removed”  is active  

by default, which means that all things located inside the model are not visible. 

Activation of the button named “Wire Frame”  will display all the lines  

(the invisible ones are shown as dashed lines), like in the figure below. 

 

 
 

When the button named “Cull Front Faces”  is activated, all the lines of the 

outer surfaces will be displayed (including those which are on the other side of  

the model). All the lines will be solid. 
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Deactivation of , and activation of the button named “Shading”  will  

display a shaded model. Work is made much easier when numerous various notches 

have been made in the model. When this button has been activated, the model looks 

like this: 
 

 
 

After viewing the possible presentations of the model, return to the default settings 

by clicking . Subsequently, the view of the load and the boundary conditions 

can be reactivated. When  has been selected, move the legend of both the loads 

and the boundary conditions to a convenient place. All that remains is to activate  

the view of the finite element mesh without shading, using . 

STEP 24. Save existing model to a file 

Each model should have been saved to a file between few steps taken in order to  

not lose the data. According to that select “File → Save as...” from the menu.  

When a new window opens, indicate the location of the saved file and its name. 
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Note: Do not uses spaces in the file names, because it leads to an error! The space 

can be replaced with the underline character __. 

STEP 25. Starting calculations 

In order to start calculations, choose “Solution → Data File/Run” from the upper 

menu tabs, or choose  from the toolbars. Subsequently, input the path for saving 

the resultant file. However, before the user clicks the “Save” button, they should 

make sure that the “Run Solution” and “Automatic” function near the “Maximum 

Memory for Solution” options are selected in the window in the “Adina Structures 

Solution” group of options. After starting the calculations and recalculating the 

model, close all three dialogue windows which appeared during the calculations. 

Note: Depending on the complexity of the model and the number and type of finite 

elements used, model calculations may take from a few seconds to even several 

hours. 

STEP 26. Post-processing module (results) 

In order to go to the results module, change “ADINA Structures” to “Post-Process- 

ing” in the drop-down list of the “Module” toolbar. 

 

 

 
When the user is prompted that the changes in the drawing have not been saved, it is 

recommended to save the model by going to “File → Save” or using the button . 

STEP 27. Opening the resultant file 

In order to open the resultant file, choose  from the toolbar, or choose “File → 

Open” from the upper menu tabs. 

Note: Depending on the specifications of the computer, the loading of a file in which 

a spatial analysis has been performed may take between about a dozen seconds up 

to even several minutes. The number of the applied finite elements and the number 

of nodes used have the greatest impact on the loading time of the file. 
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STEP 28. Creating a longitudinal section and a cross-section along 

with a map of stresses 

Initially, two models should be created in a single window. Therefore, the existing 

model should be shrunk after opening, so as to occupy less than half of the results 

window. The model is shrunk by activating , then clicking the displayed model 

with the left mouse button and holding it while making vertical movements with the 

mouse. Zooming out/in can also be done in another way – by holding the CTRL key 

along with the left mouse button over the model and moving the mouse vertically. 

Having properly zoomed out, activate the moving button , and move the model 

to the upper part of the window. Once these actions are completed, add another 

model. To do this, click  and also shrink the model using the method described 

above. Then move the shrunk model to the lower part of the window. Elements with 

data related to a given model such as the time step and the coordinate system should 

also be moved closer to a given model. It is also possible to deactivate the view of 

the finite element mesh, in order to improve the visibility of the maps which will be 

displayed in the future. According to that, click the arrow next to , and 

choose the “Group Outline” option. The operation should be performed for both 

models. A model active at the present moment is indicated by a frame. The post- 

processor window should look like in the figure below. 
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Note: The lines visible along the side surface of the cylinder are lines specifying the 

discretization of the arc. Although the surface of the ring/circle is displayed as round, 

in reality, a smooth arc is discretized into straight lines, and the density of dividing 

a finite element mesh for a given element of a circle/ring determines the number  

of straight lines making up the arc. 

Start with selecting the model present in the upper part of the window. In order to 

create a longitudinal section, go to “Display → Geometry / Mesh Plot → Modify…”, 

or click , and in the newly opened window check whether the “Mesh Plot 

Name:” box displays “MESHPLOT00001”, which in this case specifies the first  

default displayed model in the post-processor window, shrunk and moved to the  

upper part of the window. Upon checking, or selecting “MESHPLOT00001” from 

the drop-down list, click the “Cut Surface” button from the “Mesh Plot Name:” box. 

A view of the “Modify Mesh Plot” window is presented below. 

 

 

 
Upon clicking the “Cut Surface” button, a new window will appear. Check whether 

the “Cutsurface Name:” box displays “MESHPLOT00001”, then choose the “Cutting 

Plane” option from the drop-down list in the “Type:” box. A view of the window is 

presented in the figure below: 
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In the same window, there are options related to the settings of a cross-section. 

Description of specific options 

“Cutsurface Name:” – a setting specifying the displayed model to which the cross- 

-section refers. 

“Defined by:” – specifies the manner in which a cross-section is created. The possi-

ble choices are planes: “X-Plane”; “Y-Plane”; “Z-Plane”, a plane created by means 

of vectors – “Origin and Normal”, a plane created by means of three nodes – “Three 

Nodes”, and a plane defined by means of node and vector – “Node and Normal”. 

Depending on the selected option, the following boxes located below the “Defined 

by:” function are activated. 

“Type:” – allow to specify one of three options – “None” means that none cutting 

plane will be used, “Cutting Plane” allow to adjust options regarding cutting plane, 

“Isosurface” allow to set cutting plane with options to display/not display a given 

range of results in a cut plane. 

The following settings are available in the “Cutting Plane Details” group of options 

(details related to the cross-section): 

– “Distance between Planes” – an option specifying the distance between the con-

secutive cross-sections. Pay attention to the value adopted while declaring this 

function, since, for example, for a bar with a length of 1.00 m when a value of 

0.25 is entered in the box, cross-sections will be displayed in the 0.00 m, 0.25 m, 

0.50 m (the basal cross-section), 0.75 m, and 1.00 m points.  



Example 4. The spatial model of a single-clamped round bar subjected to stretching 

185 

Note: In order to be able to create two independent cross-sections for one model 

and being able to move them across window separately, first take care to display 

two identical models, then declare a cross-section for each of them separately. 

– “Display the Plane(s)” – an option determining the ability to display cross-sec-

tions. 

– “Color” – allows for changing the color of the displayed lines, surfaces, etc., for 

a given cross-section. 

– “Line width:” – defines the line thickness. 

– “Unit:” – specifies the units in which the line thickness is displayed. 

The “Mesh Display” group of options displays the finite element mesh: 

– “Below the Cutplane:” – specifies the ability to display the finite element mesh 

below the cutplane. 

– “Above the Cutplane:” – specifies the ability to display the finite element mesh 

above the cutplane. 

– “Show band/vector plot on displayed mesh” – specifies whether to show the  

resultant map or a vector map on the displayed mesh. 

Since a longitudinal section should be prepared in the present example, the model 

should be cut by the XZ plane. All it takes to do is to change the “Defined by:” option 

from “X-Plane” to “Y-Plane” in the window, leaving “Coordinate Value:” as “0”, 

since the beginning of the coordinate system is located at the beginning of the bar 

axis. A view of the window along with the input data is presented below. 
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Then click the “Save” and “OK” buttons. Upon returning to the “Modify Mesh Plot” 

window, click the “Apply” button. 

Without closing the “Modify Mesh Plot” window, in the “Mesh Plot Name:” option 

choose “MESHPLOT00002” from the drop-down list, and click the “Cut Surface” 

button again. In the newly opened window, make sure that “MESHPLOT00002”  

is shown in the “Cutsurface Name:” box, and choose “Cutting Plane” from the  

drop-down list in the “Type:” box. Once editable options are displayed in the same 

window, create a cross-section located in the middle of the presented bar, meaning 

at 0.50 m. A method of creating a section on the basis of a plane defined by vectors 

will be discussed for the purpose of the present example (of course, a method defin-

ing it by a plane at specified coordinate value would be faster and easier; however, 

other solutions should also be demonstrated). The definition of a plane by vectors 

provides the ability to arrange it in any direction in space.  

Once editable options have been displayed enter the following data: 

 

Cutsurface Name: MESHPLOT00002 

Type: Cutting Plane 

Defined by: Origin and Normal 

Origin 

X: 0.50 

Y: 0 

Z: 0 

Outwards Normal 

X: 0.50 

Y: 0 

Z: 0 

Cutting Plane Details 

Distance between Planes: 0 

Display the Plane(s) Checked 

Color: Inverse 

Line Width: 0 

Unit: CM 

Mesh Display 

Below the Cutplane: Do not display 

Above the Cutplane: Do not display 

Show band/vector plot on  

displayed mesh 
Checked 
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This means that the plane will be created in accordance with the Y and Z axes in  

a point distant by 0.50 m from the beginning of the global coordinate system,  

in accordance with the X axis. Also the mesh plot will not be displayed both before 

and after the cutting plane. A view of the window along with the input data is  

presented in the figure below. 

 

 

 
Upon inputting all the data, click the “Save” and “OK” buttons, and upon returning 

to the “Modify Mesh Plot:” window click “Apply” and “OK”. The main results  

window should look like this: 
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Subsequently, change the view for the upper model. Select it by clicking it once with 

the left mouse button, and then choose “XZ+ View” from the options next to 

 (by clicking the arrow). The XZ plane of the cross-section should be  

presented. 

The next step is to create the resultant map. In this case, a map of effective stresses 

will be created. In order to create the map, go to “Display → Band Plot → Create…”, 

or click . In the newly opened window, for the “Band Plot Variable:” option 

choose “Stress” from the first drop-down list and “EFFECTIVE_STRESS” from  

the second one, and click the “OK” button. A view of the window along with the 

selected maps is presented below. 
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Once a map of stresses has been displayed for the longitudinal section, it is possible 

to move the legends related to this model to a more convenient place. 

The next step is to select the model located in the lower part of the window with  

the left mouse button. Subsequently, click the arrow next to , and choose 

“YZ View” from the options to directly show the generated cross-section of the bar. 

Once again, create a map of effective stresses. In order to create the map, go to  

“Display → Band Plot → Create…”, or click . In the newly opened window, 

for the “Band Plot Variable:” option choose “Stress” from the first drop-down list 

and “EFFECTIVE_STRESS” from the second one, and click the “OK” button.  

A view of the window along with the selected maps is presented below: 

 

 

Note: Once effective stresses have been confirmed for a cross-section, a map of these 

stresses (in older ADINA versions) may appear in the form presented in the figure 

below: 
 

 
 
This is a display error in the program; in order to display the map properly, rotate 

this cross-section slightly by means of . After the rotation, the map on the  

cross-section should look similar to this: 
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The displayed maps of stresses should still be smoothened by activating   

for both presented cross-sections. When all the descriptions have been cleaned up,  

the main results window should look like this: 
 

 

STEP 29. Creating several cross-sections in a single model 

In order to present the importance of the option which creates several cross-sections 

within a single resulting model, it is recommended to clear all the previously created 

models with . Subsequently, activate the view of a single resulting model  

with . The next step is to deactivate the view of the finite element mesh  

by clicking the arrow next to  and selecting the “Model Outline” option.  

Once these operations are completed, set the time as “Time 5.000” by means of 
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. Then go to “Display → Geometry / Mesh Plot → Modify…”, 

or click . A window will open like the one presented in the figure below. 
 

 
 

In the newly opened window cut-planes created in the present example will be 

spaced apart by 0.25 m along X-axis; therefore, a value of “0.25” should be entered 

in the “Distance Between Planes:” option and the “X-Plane” should be chosen for 

“Defined by:” option. Following data should have been introduced in the “Define 

Cutsurface Depiction” window: 
 

Cutsurface Name: MESHPLOT00001 

Type: Cutting Plane 

Defined by: X-Plane 

X, Y, or Z Plane 

Coordinate Value: 0 

Cutting Plane Details 

Distance between Planes: 0.25 

Display the Plane(s) Checked 

Color: Inverse 

Line Width: 0 

Unit: CM 

Mesh Display 

Below the Cutplane: Do not display 

Above the Cutplane: Do not display 

Show band/vector plot on  

displayed mesh 
Checked 
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The window with introduced data is presented below: 

 

 
 

Then confirm the input data with the “Save” button, and click “OK” to close the 

window. 

Upon returning to the “Modify Mesh Plot” window, click the “Apply” button,  

and then “OK”. 

In the results window, one more map will be created for tangential XY stresses.  

To this end, go to “Geometry → Band Plot → Create…”, or click . Subsequently, 

in the newly opened window, the first drop-down list for the “Band Plot Variable” 

option must display “Stress”, with “STRESS-XY” chosen from the drop-down list 

to the right. Upon inputting the data, click the “OK” button. A view of the window 

along with the introduced changes is presented in the figure below. 
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When the maps have been displayed, it is still necessary to activate smoothing of the 

presented maps by activating . As a result of the performed actions, the model 

should look like this: 
 

 
 

Note: The “abrupt end” of the results for the surface located at the bottom of the 

figure above, and the lack of results for the surface located at the top, are related to 

the improper displaying of the outermost cutting-planes by the program. This should 

also be kept in mind when defining a single cross-section prepared on one end of the 

bar. In such cases, when the cross-section has not been displayed, enter a value close 

to 0 in the “Coordinate Value” box.  

The figure below presents a cross-section which was not displayed earlier (the top 

right cross-section). 
 

 
 

The baseline cross-section was set to be placed 0.0001 m from the beginning of  

the coordinate system. A window with the defined values is presented below. 
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As can be seen, in the figure below there are already only 4 cross-sections. This is 

due to the fact that the fifth cross-section would be placed at a distance of 1.001 m, 

meaning beyond the assumed length of the bar. 
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EXAMPLE 5  

THE SPATIAL SHELL CONSTRUCTION. CALCULATIONS 

INCLUDING THE IRREGULAR SHAPE OF SURFACE LOAD 

In this example activities related to modeling of bending of a shell fixed to the ground 

in a three-dimensional Cartesian system (3D) are demonstrated. The reader is advised 

to refer to the previous examples as some of the features have been discussed earlier. 

The diagram of the analyzed model is shown in Figure 23. 

 

 

Fig. 23. Scheme of the three dimensional shell 

The following data is used in the analysis: 

– load: 

pressure 
 = 1000 N/m 

– material constants: 

steel S235JR: 

� = 210 GPa = 2.1e��Pa 

� = 0.30 

� = 7859 kg/m� 

– boundary conditions:  

full fixity (6 degrees of freedom blocked) along the entire length at the line of 

contact between shell wall and the ground 
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STEP 1. Definition of the type of analysis 

Upon opening the ADINA software, choose “ADINA Structures” from the “Module 

Bar” in the “Program Module” section, and choose “Statics” from the drop-down list 

next to “Analysis Type”. 
 

 

STEP 2. Entering the heading of the model 

In order to specify a heading, go to “Control → Heading…”. Subsequently, enter  

the project heading in the text box, e.g., “Shell bending”. Upon entering a heading, 

click the “OK” button. 

STEP 3. Definition of load combinations 

To define a load combination in the model, press the button , then in the newly 

opened window for the option “Automatic Time Stepping Scheme” select “None” 

from drop-down list, and after that locate the “Multiple Load Cases” option  

and check it. After making changes, exit the window by pressing the “OK” button. 

The window view is shown in the figure below: 
 

 

STEP 4. Definition of the background color of the main model  

window 

In order to define the background color, go to “Edit → Background Color…”.  

Then, in the newly opened window choose the color white from the drop-down list. 

After choosing confirm the choice with the “OK” button. 
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Note: The background color is not saved along with the model. This means that after 

each opening of the file, the background color will return to default – “black”. 

STEP 5. Definition of global boundary conditions 

Since the model under consideration is a spatial, it is recommended that all global 

boundary conditions involved in the modeling and calculation process are active.  

To check which boundary conditions are active, go to “Control → Degrees of  

Freedom...”. In the newly opened window, all boundary conditions in the “Master 

Degrees of Freedom (Selected = Active)” option group should have their boxes 

checked. The figure below shows the window with selected boundary conditions: 

 

 

STEP 6. Definition of material constants 

In order to define materials constants, go to “Model → Materials → Manage Mate-

rials...” or press the button , then in the newly opened window (if the material 

has been previously added to the program database), press the “Get MDB” button.  

A new window with a table should open, then select the material called “Steel” in the 

table and press the “Retrieve” button. After loading the material from the program 

database, press the “Close” button. In the “Manage Materials” window, in its lower 

part, in place of the table, there should be a material – “Steel” with the id number 

“1”. The retrieving material window is presented below: 
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If the database does not contain the material required in the example, in the “Manage 

Materials” window, find the group relating to elastic materials – “Elastic”, and then 

press the “Isotropic” button – isotropic material. In the newly opened window, press 

the “Add...” button and enter the data in accordance with the table below: 

 

Material Number: 1 

Description: Steel 

Young’s Modulus 

(> 0) 
2.1e11 

Poisson’s Ratio 

(–1.0 < NU < 0.5) 
0.30 

Density 7859 

Coef. of Thermal Expansion 

(>= 0) 
0 

 
After entering the values, press the “Save” button. If the user wants to add material 

to the program's database, press the “Put MDB” button. After completing the opera-

tion, you can exit the window by pressing the “OK” button. Again, as in the previous 

case, after leaving the window, in the lower part of the “Manage Material Defini-

tions” window, the table should contain the “Steel” material model with an assigned 

identification number of “1”.  

The window view with the entered material in the elastic material definition window 

is shown in the figure below: 
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The view of the material manager window should look similarly as: 

 

 

 
After performing all operations, exit the “Manage Material Definitions” window  

by pressing the “Close” button. 
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STEP 7. Definition of points 

In this step, auxiliary points will be created to model shell elements describing the 

given scheme. For this purpose, points will be created on the YZ plane, which will 

then be extruded. In order to define points, go to “Geometry → Points → Define…” 

in the main model window, or click . Upon opening a new window, input points 

in accordance with the table below: 

 

Point # X1 X2 X3 System 

1 0 –0.5 0 0 

2 0 0.5 0 0 

3 0 –0.5 1 0 

4 0 0.5 1 0 

5 0 0 1 0 

 
The window view with the entered data is shown in the figure below: 

 

 

Note: There is no need to enter zero values in the table. After pressing the “Apply” 

button, the table will be automatically completed with these values. 
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After entering the values from the table, press the “Apply” button and then “OK”. 

STEP 8. Displaying point ID numbers 

To display point identifiers, press the button  on the toolbar. 

STEP 9. Definition of auxiliary lines. Part I 

In order to define auxiliary lines for later extrusion to surfaces, go to “Geometry → 

Lines → Define...” or press the button . When a new window opens, press  

the “Add...” button to add a new line. 

For this step the user needs three lines. Two defining walls and one showing a roof 

in the form of an arch. At the moment, it is only possible to enter straight lines,  

but the line representing the arc will be created in a non-standard way by rotating  

the point around the axis of the local coordinate system later in the study. 

To create the mentioned lines, enter data in accordance with the following tables, 

taking into account to save the entered data after the first table with the “Save”  

button, and then add a new line with the “Add...” button. The data to be entered is 

presented in the tables below: 

 

Line Number: 1 

Type: Straight 

Point 1: 1 

Point 2: 3 

 

Line Number: 2 

Type: Straight 

Point 1: 2 

Point 2: 4 

 
After completing the entry, press the “Save” button and exit the window with the 

“OK” button. 

The view of the window defining the line with id number “2” is shown in the figure 

below: 
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STEP 10. Definition of local coordinate system 

The local coordinate system will be created at a point (0; 0; 1.00), which corresponds 

to the center point of the arc. This definition will be needed when entering an arc 

created by rotating a point in regard to the X axis of the defined local coordinate 

system. To define a local Cartesian coordinate system with the X axis perpendicular 

to the plane of the displayed model, go to “Geometry → Coordinate Systems...”  

or press the button . After opening a new window, press the “Add...” button  

and enter the following data: 

 

System Number: 1 

Type: Cartesian 

Defined by: Origin and Direction Vectors 

Origin 

X: 0 

Y: 0 

Z: 1 

Vector A: 

X: 1 

Y: 0 

Z: 0 

Vector B: 

X: 0 

Y: 1 

Z: 0 
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After entering the data, press the “Save” button and leave the window with the “OK” 

button. The window view with the entered data is presented in the figure below: 

 

 

STEP 11. Definition of auxiliary lines. Part II 

Since a local coordinate system has been defined, it is possible to rotate point “P3” 

around the X axis of that system. To define an arc, go back to the line definition 

window by selecting “Geometry → Lines → Define...” from the menu or pressing 

the button . In the newly opened window, press the “Add...” button and enter 

the following data: 
 

Line Number: 3 

Type: Revolved 

Initial Point: 3 

Angle of Rotation: –180 

Axis of Revolution 

Defined by: Axis 

Axis: X 

Coord. System: 1 
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After entering the data, press the “Save” button and then leave the window with  

the “OK” button. The window view with the entered data is shown in the figure: 

 

 

STEP 12. Displaying line ID numbers 

To display the line identification numbers, locate and press the button  on  

the toolbar. If the model does not fit entirely in the main program window, press  

the button . Currently the model should look like this: 
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STEP 13. Model view adjustment 

To change the view (where the model is observed), left-click on the arrow next to 

the button  and then select “Iso View 1” from the available options. 

STEP 14. Definition of surface(s) 

In this step, all three defined lines will be extruded by 1.00 m in the direction  

of the X axis. To go to the surface definition, select “Geometry → Surfaces →  

Define...” from the menu or press the button . In the newly opened window, 

press the “Add...” button and enter the following data: 

 

Surface Number: 1 

Type: Extruded 

Initial Line: 1 

Extrusion Direction 

Defined by: Vector 

Coordinate System: 0 
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Vector 

X: 1 

Y: 0 

Z: 0 

Number of Mesh Subdivisions: 20 

Coincidence Checking 

Check Coincidence checked 

Tolerance 1e-005 

Additional Initial Lines 

 Line {p} 

1 2 

2 3 

 

After entering the data, press the “Save” button and then exit it with the “OK” button. 

The window view with the entered data is shown in the figure below: 
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STEP 15. Displaying surface(s) ID numbers 

To display surface identification numbers, locate and press the button  on the 

toolbar. Currently the model should look like this: 

 

 

STEP 16. Mesh subdivision 

In this step, subdivision parameters for lines that have not yet been subdivided for 

finite elements are defined. First, vertical lines will be divided, then arcs. To define 

the mesh subdivion under finite elements, go to “Meshing → Mesh Density → 

Line...” or press the arrow next to the button  and select “Subdivide Lines”. 

In the newly opened window, enter the following data: 
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Mesh Density 

Base Line: 0 

Method: Use Number of Divisions 

Progression of Element  

Edge Lengths: 
Geometric 

Number of Subdivisions: 20 

Length Ratio of Element  

Edges (Last/First): 
1 

Use Central Biasing instead  

of End Biasing 
Unchecked 

Assign to Following Lines 

 Line {p} 

1 1 

2 2 

3 6 

4 9 

 
The window view with the entered data is shown in the figure below: 

 

 
 
After entering the data, press the “Save” button, then define the mesh subdivision 

for the lines forming the arcs. To do this, enter the following values in the “Define 

Line Mesh Density” window: 
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Mesh Density 

Base Line: 0 

Method: Use Number of Divisions 

Progression of Element  

Edge Lengths: 
Geometric 

Number of Subdivisions: 36 

Length Ratio of Element  

Edges (Last/First): 
1 

Use Central Biasing instead  

of End Biasing 
Unchecked 

Assign to Following Lines 

 Line {p} 

1 3 

2 10 

 
After entering the data, press the “Save” button and then leave the window with the 

“OK” button. The window view with the entered data is shown in the figure below: 

 

 

 
Currently, the model should look similar to that: 
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STEP 17. Specifying the type of analyzed construction 

In this example, there is only one material model, so user can define a single group 

of elements describing the shell. To create a group of elements, go to “Meshing → 

Element Groups...” or press the button . In the newly opened window, press 

the “Add...” button and then enter the following data: 

 

Group Number: 1 

Type: Shell 

 “Basic” tab 

Description: Steel elements 

Default Material: 1 

Default Element Thickness: 1 

Number of Layers: 1 

 

The remaining data is left unchanged. Save the entered data by pressing the “Save” 

button and then exit the window by pressing the “OK” button. The window view 

with the entered data is shown in the figure below: 
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STEP 18. Displaying surfaces ID numbers 

In order to display the surface identification numbers, press the button on the 

toolbar. 

STEP 19. Defintion of surface(s) thickness 

To define the thickness for each surface separately, go to “Geometry → Surfaces → 

Thickness...”. In the newly opened window, enter the following data: 

 

 Surface # Thickness Deviation 1 Deviation 2 Deviation 3 Deviation 4 

1 1 0.04 0.0 0.0 0.0 0.0 

2 2 0.04 0.0 0.0 0.0 0.0 

3 3 0.02 0.0 0.0 0.0 0.0 

 
After entering the above data, press the “Apply” button and then leave the window 

with the “OK” button. The window view with the entered data is shown in the figure 

below: 
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Note: Although in the window regarding the definition of a group of elements, the 

default thickness of elements was set as “1”, defining the thickness via “Geometry 

→ Surfaces → Thickness...” is the master option. This means that after changing  

the default values in the “Define Surface Thickness” window, the entered values will 

be overwritten onto the “Deafult Shell Element Thickness” entered in the “Define 

Element Group” window.  

STEP 20. Definition of boundary conditions (fixity characteristics) 

To define the line supports (clamped line – blocking 6 degrees of freedom), go to 

“Model → Boundary Conditions → Apply Fixity...” or press the button . In the 

newly opened window, in the “Apply to:” option, select “Lines” from the drop-down 

list. Since the example includes clamped support, and the program has a declared 

fixity with all degrees of freedom fixed by default (fixity name: “All”), there is  

no need to declare the fixity once again.. In the “Apply Fixity” window open, enter 

the following data: 

 

Fixity: ALL 

Apply to: Edge/Line 

 Edge/Line {p} 

1 4 

2 7 
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After entering the data, press the “Save” button and then leave the window with  

the “OK” button. The window view with the entries is shown in the figure below: 

 

 

STEP 21. Displaying boundary conditions 

In order to display the defined boundary conditions in the main model window,  

click  button. 

STEP 22. Definition of finite elements 

To define finite elements, go to “Meshing → Create Mesh → Surface...” or press  

the button . When a new window opens, enter the following data: 
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 “Basic” tab 

Type: Shell 

Element Group: 1 

Meshing Type 

Rule-Based Checked 

Nodal Specification 

Nodes per Element: 8 

Element Pattern Automatic 

Preferred Cell Shape Quadrilateral 

Triangular Surfaces  

Treated as Degenerate 
Unchecked 

Surfaces to be Meshed 

 Surface {p} 

1 1 

2 2 

3 3 

 
The remaining cards, i.e. ”Advanced” and “Fracture Options”, are left unchanged. 

The window view with the entered data is shown in the figure below: 
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After entering the data, press the “Apply” button and then leave the window with  

the “OK” button. Currently the model should look like this: 

 

 

STEP 23. Definition of load variability 

In this step, a spatial function will be created to describe the variability of the load 

value distributed on the plane. To define the load function, go to “Geometry →  

Spatial Functions → Surface...”, then press the “Add...” button in the newly opened 

window. The purpose of this introduction is to obtain a load that will have the  

maximum value in the center of the arch's symmetry, while at the edges of the arch 

the load value is to be 0. This relationship is shown in the figure below: 
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To obtain such a load curve, enter the following data in the “Define Surface Function” 

window: 
 

Function Number: 1 

Type: Quadratic 

 

The table in the window should be completed with the following data: 
 

Values at Specific Points 

 ? = 0 ? = 0.5 ? = 1 

@ = 0 0 1 0 

@ = 0.5 0 1 0 

@ = 1 0 1 0 

 
After entering the data, press the “Save” button, then you can close the window with 

the “OK” button. The window view with the entered data is shown in the figure below: 

 

 
 
If the user is not sure which direction is referred to as “u” and which is referred to  

as “v”, the figure below should clear up any doubts: 

 

 
 

u 

wv
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STEP 24. Definition of load cases 

In this example, there will only be two load cases. To go to the case definitions, 

select “Model → Loading → Load Case...” from the menu. Then, in the newly 

opened window, press the “Add...” button twice. The window view is shown in the 

figure below: 

 

 

 
After entering the data, press the “Save” button and close the window with the  

“OK” button. 

STEP 25. Definition of load(s) combinations 

To create a load combination, go to “Model → Loading → Load Combination...”. 

Then, in the newly opened window, two load combinations will be created – one 

relating to the Serviceability Limit State (SLS), the other to the Ultimate Limit State 

(ULS). At this stage, we assume that the first case refers to the self-weight of the 

structure, while the second case concerns the snow loading on the upper surface – 

the arch. (referring to previously defined load cases). To add load combination  

No. 1, press the “Add...” button and enter the following data: 

 

Load Combination  

Number: 
1 

 
Data in the table: 

 

 Load Case # Weight 

1 1 1 

2 2 1 

 
The window view with the entered data is presented in the figure below: 
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After entering the data, press the “Save” button and then “Add...” again. Currently, 

the ULS case will be added, so please enter the following data: 

 

Load Combination  

Number: 
2 

 
Data in the table: 

 

 Load Case # Weight 

1 1 1.35 

2 2 1.50 

 
After entering the data, press the “Save” button and then leave the window with the 

“OK” button. The window view with the entered data is presented in the figure below: 

 

 

Note: Weights corresponds to the Eurocode(s) partial safety factors. 
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STEP 26. Definition of loads 

Two types of loads will be defined in this model. The load of the structure’s own 

weight and the distributed load of the arch shell, e.g. snow. To proceed to defining 

loads, go to “Model → Loading → Apply...” or press the button . After opening 

a new window, the self-weight load of the structure will be declared first, so for the 

“Load Type:” option, select “Mass Proportional” from the drop-down list, then for 

the “Load Number:” option, press the “Define...” button. Another new window will 

open, in which you should press “Add...” to add a new load, then enter the data as 

shown in the table: 
 

Mass Proportional Load Number: 1 

Magnitude: 1 

Body #: 1 

Direction Vector 

X: 0 

Y: 0 

Z: –1 

Interpret Loading as (for potential-based fluid element only) 

Body Force Checked 

Description: None 

Note: If user enter a number greater than 1 in the “Direction Vector”, this value is 

still interpreted as 1 with the sign specified by the user. It can also be entered “–0.01” 

in the “Z:” field, which will also be treated as “–1”, i.e. a load acting opposite to the 

“Z” axis. 

Note: The load interpretation “Interpret Loading as (for potential based fluid element 

only)” as the English name suggests only works with potential based fluid elements. 

Note: The “Magnitude” load value is a coefficient by which the volumetric weight 

of a given element is multiplied. The volumetric weight of the material was entered 

together with the definition of the material model. There is no need to enter a special 

coefficient here, because the coefficient will be used from the load combination,  

so “1” characterizes that the volumetric weight is to be assumed without any changes. 

After entering the data in the window, press the “Save” button and then “OK”, thus 

returning to the “Apply Load” window. The window with the entered data is shown 

in the figure below: 
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After returning to the “Apply Load” window, enter the following values: 
 

Load Type: Mass Proportional 

Load Number: 1 

Apply to: Model 
 

In the table, the data should look like this: 
 

 Load Case… Apply-Load Label # 

1 1 1 
 

The window view with the entered data is shown in the figure below: 
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After entering the data, press the “Apply” button, and then, without leaving the  

window, select “Pressure” from the drop-down list next to “Load Type:”, then press 

the “Define...” button next to the drop-down list for the “Load Number:” field. In the 

newly opened window, press the “Add...” button and enter the following data: 

 

Pressure Number: 1 

Magnitude (Force/Area): –800 

Description: None 

Magnitude From Point Cloud  

Load Mapping # 
0 

Coordinate System for Pressure  

in X, Y or Z Direction: 
0 

For Tangential Pressure Only 

Tangential Angle: 0 

Reference Line: 0 

 
After entering the data, the window should look like this: 
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After declaring the load value, press the “Save” button and then “OK.” closing the 

“Define Pressure” window and returning to the “Apply Load” window. In the “Apply 

Load” window, enter the following data: 

 

Load Type: Pressure 

Load Number: 1 

Apply to: Surface 

Values in a horizontal table 

Surface {p} 3 

Deform. Dependent? omit 

Load Direction Z-Direction 

Load Case 2 

Arrival Time omit 

Spatial Function 1 

Label # 2 

 
After entering the data, press the “Apply” button and then “OK”. The window view 

with the entered data is shown in the drawings below: 
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Note: After pressing the “Apply” button, any items that were omitted will be filled 

in with default values. 

STEP 27. Displaying active model loads 

In order to display defined loads in the main model window, click  button on 

the toolbar. The model window should look similar to that: 
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Since the above drawing does not accurately represent the load distribution, the user 

should switch view to the YZ plane. To do this, select the arrow next to the button 

 and select the “+YZ View” option. The model view should look like this: 

 

 
 

As shown in the figure above, the load was declared correctly. 

STEP 28. Displaying shell elements thinckess 

To display the thickness of shell elements, go to “Display → Geometry / Mesh Plot 

→ Modify...” or press the button . In the newly opened window, locate and 

press the “Element Depiction” button in the “Mesh Attributes” option group. After 

pressing the button, a new window will open in which the following data should be 

changed in the “Basic” tab: 

 

 “Basic” tab 

… 

Appearance of Shell Element 

Top/Bottom Checked 
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After entering the data, press the “Save” button and then exit both open windows 

with the “OK” button. Both windows are presented in the figures below: 

 

 
 

 
 

To precisely see the difference in thickness between the arch and the wall, select  

the button  and then use the left mouse button to select the area where the arch 

and the wall connect. The model should look something like this: 
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As you can see in the drawing above, the wall is twice as thick as the arch element, 

so the element thicknesses have been entered correctly. To return to the view of the 

entire model, press the button several times and activate the button . 

STEP 29. Save existing model to a file 

Each model should have been saved to a file between few steps taken in order to  

not lose the data. According to that select “File → Save as...” from the menu. When 

a new window opens, indicate the location of the saved file and its name. 

Note: Do not uses spaces in the file names, because it leads to an error! The space 

can be replaced with the underline character __. 

STEP 30. Starting calculations 

In order to start calculations, choose “Solution → Data File/Run” from the upper 

menu tabs, or choose  from the toolbars. Subsequently, input the path for saving 

the resultant file. However, before the user clicks the “Save” button, they should 

make sure that the “Run Solution” and “Automatic” function near the “Maximum 

Memory for Solution” options are selected in the window in the “Adina Structures 

Solution” group of options. After starting the calculations and recalculating the 

model, close all three dialogue windows which appeared during the calculations. 

Note: Depending on the complexity of the model and the number and type of finite 

elements used, model calculations may take from a few seconds to even several 

hours. 
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STEP 31. Post-processing module (results) 

In order to go to the results module, change “ADINA Structures” to “Post-Process- 

ing” in the drop-down list of the “Module” toolbar. 
 

 
 

When the user is prompted that the changes in the drawing have not been saved, it is 

recommended to save the model by going to “File → Save” or using the button . 

STEP 32. Opening the resultant file 

In order to open the resultant file, choose  from the toolbar, or choose “File → 

Open” from the upper menu tabs. 

Note: Depending on the specifications of the computer, the loading of a file in which 

a spatial analysis has been performed may take between about a dozen seconds up 

to even several minutes. The number of the applied finite elements and the number 

of nodes used have the greatest impact on the loading time of the file. 

STEP 33. Effective stress results 

In this step, it is shown how to present stresses so that the distinction between the 

two external surfaces of the finite element and the stresses averaged inside the ele-

ment are visible. The results will be displayed for the ULS combination, but it is 

worth classifying what a given time constant – “TIME” in the upper left corner of 

the window means. The load cases and combinations adopted for calculations are 

assigned unique identification numbers. According to how the loads were defined, 

the following classification is adopted at default: 

 “TIME 0.000” – no loads 

 “TIME 1.000” – self-weight (load case) 

 “TIME 2.000” – snow load (load case) 

 “TIME 3.000” – Serviceability limit state (own weight + snow load, both cases with 

safety factor 1.00) 

 “TIME 4.000” – Ultimate limit state (self-weight with a factor of 1.35 and snow 

load with a safety factor of 1.50) 

Before the stresses, which are averaged to the center of the finite element are  

displayed, make sure that the results will be presented for the ULS state – “TIME 

4.000”. To do this, look at the upper left corner of the result window and check 

whether the “TIME 4.000” value is there, and if it is not, one should use the button 

. 
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For now one can view the stresses. First, stress maps will be displayed for the planes 

passing through the center of the finite elements. To do this, go to “Display → Band 

Plot → Create...” or press the button . After opening a new window, for  

the “Band Plot Variable” option, select “Stress” in the first drop-down list, and  

 “EFFECTIVE_STRESS” in the second drop-down list next to it. After entering  

the data, press the “OK” button. The window view with the entered data is shown  

in the figure below: 
 

 
 
In order to better visualize what is happening to the model, user can turn on scaled 

displacements to see how the given structure deforms under the influence of applied 

loads. To display the scaled deformations, press the button . Currently the 

model should look like this: 
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Maintaining the current display, the finite element thickness will be displayed,  

with the stresses for each finite element displayed for each face separately. 

To enable the display of stresses on opposite faces of each finite element, go to  

 “Display → Geometry Mesh / Plot → Modify...” or press the button . “Modify 

Mesh Plot” window is presented below: 

 

 

 
In the newly opened window press the “Element Depiction” button. When the next 

window opens, change the following data: 

 

 “Basic” tab 

… 

Appearance of Shell Element 

Top/Bottom Checked 

 
Remaining options are left unchanged. After entering the data, press the “Save” button 

and then exit both open windows with the “OK” button. The view of the “Define 

Element Depiction” window is shown in the following figure:  
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Additionally, the model after lowering the window should look like: 

 

 
 

To show the essence of the applied function, user needs to zoom in on the model  

at the connection of the wall and the arch. To zoom in, activate the button   
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and then select the desired area to be enlarged. In the author’s version, the model 

looks something like this: 
 

 

Note: When the display of stresses for opposite faces of a finite element is turned 

on, it is not possible to turn on stress smoothing using the button . Also the plot 

may disappear after the use of mentioned button. 

Currently, the model should be moved to the starting position by pressing the button 

several times. Then activate the button  and rotate the model so that the 

outer part of the previously approximated place where the wall and the arch connect 

is visible. The model should look something like this: 
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Note: It is possible to rotate the model in a second way. After activating the button 

, select the model with the left mouse button and hold it down, and also press 

and hold the SHIFT key on the keyboard. With this combination of buttons pressed, 

you move the mouse and rotate the model to the desired location. 

Select the button  again and select the area at the wall-arch connection for  

the same part of the model as before. The author’s model view looks something  

like this: 
 

 
 
Comparing both obtained drawings: 

 

  

 
It is clearly visible that the stress values on the inner and outer surfaces of the shell 

are different. Stress concentration occurs on the outer shell of the arc near its begin-

ning (marked with a dashed line circle), whereas in the inner arch shell side the stress 

values are more or less the same – there are no concentrations. 
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Moreover, stresses can be considered “at the thickness” of the shell. To see how  

the stresses are distributed along the thickness of the shell near the connection of the 

arch with the wall, first the observation plane of the model must be changed. First, 

move the model back to its starting position by pressing the button  several 

times. To change the model viewing plane, press the arrow next to the button 

 and select the “+YZ View” option. Activate the button  again and mark 

the area near the connection of the arch with the wall as shown in the figure below: 

 

 
 
According to the above shown figure, both compressive and tensile stresses are 

shown across the thickness of the arch. 

Note: In the ADINA program, compressive and tensile stresses are displayed in the 

same colors in the case of the “Effective Stress” option, the stress values presented 

in the legend and in the drawing are the absolute value of the obtained stresses. 

STEP 34. Degrees of freedom in finite element nodes 

To graphically present which nodes have freedom of movement and rotation,  

and which nodes have no rotation ability, go to “Display → Geometry Mesh/Plot → 

Define Style...”. After that the new window appears: 
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locate the “Node Depiction” option in the “Mesh Attributes” option group, and then 

select “ROTATIONAL_DOF” from the drop-down list.  

After making changes, press the “Save” button and then leave the window with the 

“OK” button. After returning to the main results window, press the and  

button. Then activate the zoom button  and zoom in on the model at the support, 

as shown in the figure below: 
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The presented nodes should differ in colors for the user. In the case of nodes located 

at the support, they will differ in color from the other nodes in the structure. Addi-

tionally, the support nodes have 0 degrees of freedom, while the remaining nodes  

of the structure have rotational degrees of freedom free, respectively. 

STEP 35. Displaying local coordinate systems on finite elements 

To display the local coordinate system of each finite element, first the model have to 

be cleaned from previous entries. To do this, select the arrow next to the button 

 and select the “Reset Mesh Plot Style” option. Then press the following 

buttons and . After displaying a “clean” model consisting of finite ele- 

ments, go to “Display → Geometry Mesh/Plot → Modify...” or press the button 

. Once a new window opens, locate the “Element Depiction” button in the “Mesh  

Attributes” button group. After another new window opens, enter the following data: 
 

“Basic” tab 

… 

Display Local System Triad Checked 

 

Select the “Element Coordinate System” option from the drop-down list. After  

entering the data, press the “Save” button and then you can exit both windows with 

the “OK” button. The view of the “Define Element Depiction” window with the  

entered data is shown in the figure below: 
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After returning to the main results window, activate the zoom button  and then 

indicate the area to be zoomed in, e.g. the connection of the arc with the wall for  

the rightmost area in this window: 

 

 

 
When zoomed in, the drawing should look something like this: 

 

 

 

 
According to the figure above, the local coordinate systems differ in both the wall 

and the arc. In the arch, the “u” and “w” axes are in completely opposite directions 

in comparison to the same axes of the local coordinate systems assigned to the wall. 

 

x, r, u 

z, t, w y, s, v 
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● Dynamics 
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EXAMPLE 6  

VIBRATION FREQUENCY AND VIBRATION MODES OF  

A T-SHAPE CANTILEVER BEAM 

In this example activities related to modeling of a one end clamped steel bar with 

one-degree of freedom concentrated mass attached to the free end. Modelling is  

limited to the planar Cartesian system (2D). The diagram of the analyzed model  

is shown in Figure 24. 

 

 

Fig. 24. Schematic of a concentrated mass beam with one degree of freedom 

The following data is used in the analysis: 

– cross-section dimensions: 

ℎK = 0.484 m 

1K = 0.010 m 

LM = 0.300 m 

1M = 0.008 m 

– load: 

concentrated force * = 2000 N 

– material constants: 

steel S235JR: 

� = 210 GPa = 2.1e��Pa 

� = 0.30 

� = 7859 kg/m� 

– boundary conditions:  

one beam’s end fixed (blocked all degrees of freedom) 
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STEP 1. Definition of the type of analysis 

Upon opening the ADINA software, choose “ADINA Structures” from the “Module 

Bar” in the “Program Module” section, and choose “Mode Superposition” from  

the drop-down list next to “Analysis Type”. 

 

 

STEP 2. Entering the heading of the model 

In order to specify a heading, go to “Control → Heading…”. Subsequently, enter  

the project heading in the text box, e.g., “Beam – free and forced vibrations”.  

Upon entering a heading, click the “OK” button. 

STEP 3. Define number of frequencies to be calculated 

Press the  button located on the toolbar and after a new window opens press  

the “Settings...” button, another window should open. Both windows are presented 

below: 
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Description of individual functions in the window: 

“Calculate Frequencies and Mode Shapes” – force the program to calculate frequen-

cies and mode shapes of a given model. 

“Read from File (<problem file>.mds)” – frequencies and mode shapes are read from 

the file. 

“Number of Modes to Use” – the number of modes which should be taken into  

consideration by the software. 

“Interval of Calculating Error Measures on Loads” – specifies the ‘time’ interval  

in which the error measures are calculated. 

“Perform Static-Correction Calculations” – enables/disables calculations of static- 

-correction under dynamic calculations. 

“Start Time / End Time” – specifies in which “TIME” range the static-correction  

is used. 

“Time interval” – specifies the interval between defined “Start/End Time” range. 

“Analysis Switch Option – Number of Steps” – options regarding analysis switch, 

specifies the number of steps used in switch analysis. 

“Analysis Switch Option – Time Step Size” – time step size used in switch analysis. 

In the “Frequencies (Modes)” window: 

“Solution Method” – allow the user to choose the solution method of frequencies/ 

mode shapes. 

“Number of Frequencies/Mode Shapes” – specifies the number of frequencies/mode 

shapes to be calculated in the model. 
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“Number of Mode Shapes to be Printed:” – number of mode shapes and their  

frequencies to be printed in the *.out file. 

“Solution Settings” – solution options 

“Include Effect of Contact Compliance” – allow to include the effect of contact  

between different parts of model (activated by default). 

“Allow Rigid Body Mode” – an option that allows user to activate elements that  

are perfectly rigid. Specifies whether or not rigid-body modes are allowed. Should 

be used when the lowest frequency may be zero, or any part of the model would be 

insufficiently supported if all contact, mesh glueing and generalized constraints are 

removed. 

 “Rigid Body Mode Shift” – mode shifting option. 

 “Cutoff Circular Frequency:” – a field specifying the interruption of the program 

action when the specified or higher circular frequency is reached 

“Max. Number of Iterations per Eigenpair:” – maximum number of iterations per 

eigenpair (frequency/mode shape). 

 “Output Settings” – options regarding the output file 

 “Calculate Modal Stresses” – option indicating whether or not to calculate modal 

stresses for post-processing. 

“Print Intermediate Solution Information” – an option that allows user to print inter-

mediate solution results in the *.out file. 

“Component Mode Synthesis” – the component mode synthesis (CMS) method is 

used to calculate the lowest frequencies/modes of the original finite  

“# of Fixed Interface Modes” – specifies the number of the fixed interface dynamic 

vibration modes to be calculated in the first phase of CMS. 

“Output Reduced Matrices” – specifies whether the reduced or full matrices are  

written in the output file. 

“Method for 2nd Phase of CMS” – specifies the number of frequencies/modes of  

the original finite element system to be calculated in  

the second phase of CMS. Can only be used when “… subspace iteration” method  

is choosen. 

Since for the purposes of this example it will be necessary to display both 10 fre-

quencies results and vibration modes, the following data should be entered in the 

“Frequencies (Modes)” window: 
 

Frequencies/Mode Shapes 

Number of Frequencies/Mode Shapes: 10 

Number of Mode Shapes to be Printed: 10 

Leave the remaining options unchanged 
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The window view with the entered data is shown in the figure below: 

 

 
 
After entering the data, press the “OK” button to save changes and to exit the window. 

After returning to the “Mode Superposition” window, enter “10” for the “Number  

of Modes to Use:” option. The figure below shows the window with the changes 

introduced. 
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After making changes, press the “OK” button to leave the window. 

STEP 4. Definition of the number of time steps 

To define time steps, go to “Control → Time Step...”. Then, in the newly opened 

window, enter following data: 

 

 # of Steps Magnitude 

1 1000 0.001 

 
After entering the values, press the “Save” button and then “OK.” The window with 

the entered data is presented below: 

 

 

STEP 5. Definition of points 

In order to define points, go to “Geometry → Points → Define…” in the main model 

window, or click . Upon opening a new window, input points in accordance 

with the table below: 
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Point # X1 X2 X3 System 

1 0 0 0 0 

2 0 2 0 0 

3 0 2 0.1 0 

Note: There is no need to enter zero values in the table. After pressing the “Apply” 

button, the table will be automatically completed with these values. Then, in the  

window for defining points, press “Apply” and “OK”. The window with entered data 

is presented below: 

 

 

STEP 6. Displaying point ID numbers 

To display point identifiers, press the button  on the toolbar. 

STEP 7. Definition of lines 

In this example, user needs to create only one straight line, according to that go to 

“Geometry → Lines → Define...” or press the button . After opening a new 

window, press the “Add...” button and then, in place of the “Type:” line type, select 
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the option from the drop-down list “Straight”. After performing the operation, enter 

the data according to the table below: 

 

Line Number: Type: Point 1: Point 2: 

1 Straight 1 2 

 
Points can also be entered using the “P” button located next to the text field belong-

ing to the “Point 1:” option. After selecting the button, left-click the mouse in the  

modeling window to indicate 2 points of interest, and then the program will return 

to the point definition window. The window view with the entered data is shown  

in the figure below: 

 

 
 
After entering the data, press the “Save” button and then “OK”. The main model 

window should look like this: 
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STEP 8. Definition of boundary conditions (fixity characteristics) 

To define clamped support in the considered system, go to “Model → Boundary 

Conditions → Apply Fixity...” or press the button . Since the example only 

includes a clamped support, and the program by default has a declared such a support 

with all degrees of freedom blocked (support name “All”), there is no need to declare 

the support again. In the “Apply Fixity” enter following data: 

 

Fixity: ALL 

Apply to: Edge/Line 

 Point {p} 

1 1 

Note: In older ADINA software versions if the “Fixity” column remains empty for 

the declared nodes/lines/areas, after pressing the “Save” button it will be completed 

based on the option selected from the drop-down list for “Default Fixity”. 

After performing the above operations, press the “Save” button and then “OK”.  

The window view with the entered data is shown in the figure below: 
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STEP 9. Displaying boundary conditions 

In order to display the defined boundary conditions in the main model window,  

click  button located on the toolbar. 

STEP 10. Definition of loads 

In order to define a load, choose “Model → Loading → Apply…” from the upper 

menu, or click . In the newly opened window, in the load type – “Type:”, select 

“Force” from the drop-down list – the same as in the case of defining concentrated 

force. In place of “Apply to:” the “Point” option should be selected. After entering 

this data, press the “Define” button next to the text field for the “Load Number:” 

option. A new window will open, in which press the “Add...” button and the further 

data should be entered in accordance with the table below: 

 

Concentrated Force Number: 1 

Magnitude: 2000 

Force Direction 

X: 0 

Y: 0 

Z: –1 

Description: None 

 
After entering the data, the window should look like this: 
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Then press the “Save” and “OK” buttons. After returning to the “Apply load” window 

enter following data: 

 

Load Type: Force 

Load Number: 1 

Apply to: Point 

 
In the table, the data should look like this: 

 

 Point {p} … Focus Point … 
Apply-Load  

Label # 

1 2 Empty 3 Empty 1 

 
After entering the above data, the window should look like this: 
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As soon as the data is entered press the “Apply” button and then leave the window 

with the “OK” button. 

STEP 11. Displaying active model loads 

In order to display defined loads in the main model window, click  button  

on the toolbar. The model window should look similar to that: 
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STEP 12. Definition of material constants 

In order to define materials constants, go to “Model → Materials → Manage Mate-

rials...” or press the button , then in the newly opened window (if the material 

has been previously added to the program database), press the “Get MDB” button.  

A new window with a table should open, then select the material called “Steel”  

in the table and press the “Retrieve” button. After loading the material from the  

program database, press the “Close” button. In the “Manage Materials” window,  

in its lower part, in place of the table, there should be a material – “Steel” with  

the id number “1”. The retrieving material window is presented below: 

 

 
 

If the database does not contain the material required in the example, in the “Manage 

Materials” window, find the group relating to elastic materials – “Elastic”, and then 

press the “Isotropic” button – isotropic material. In the newly opened window, press 

the “Add...” button and enter the data in accordance with the table below: 

 

Material Number: 1 

Description: Steel 

Young’s Modulus  

(> 0) 
2.1e11 

Poisson’s Ratio 

(–1.0 < NU < 0.5) 
0.30 

Density 7859 

Coef. of Thermal Expansion 

(>= 0) 
0 
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After entering the values, press the “Save” button. If the user wants to add material 

to the program's database, press the “Put MDB” button. After completing the opera-

tion, you can exit the window by pressing the “OK” button. Again, as in the previous 

case, after leaving the window, in the lower part of the “Manage Material Defini-

tions” window, the table should contain the “Steel” material model with an assigned 

identification number of “1”.  

The window view with the entered material in the elastic material definition window 

is shown in the figure below: 
 

 
 

The view of the material manager window should look similarly as: 
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After performing all operations, exit the “Manage Material Definitions” window  

by pressing the “Close” button. 

STEP 13. Definition of the cross-section of the beam 

In order to define a cross-section, go to “Model → Cross-Sections…” in the upper 

tabs of the program, or click  in the program toolbars. In the newly opened 

window, click the “Add…” button. Enter following data: 

 

Section Number: 1 

Type: I-Beam 

Standard Beam Unchecked 

Dimensions 

Width W1: 0.300 

Height H: 0.500 

Width W2: 0.300 

Thickness T1: 0.008 

Thickness T2: 0.010 

Thickness T3: 0.008 

Torsional Rigidity * 

Factor: 1 

Shear Area Factors * 

s: 0 

t: 0 

Increase moments of inertia by parallel axis theorem 

s: 0 

t: 0 

Numerical Integration for warping beam with nonlinear material 

Along W1: 0 

Through T1: 0 

Along Web: 0 

Through T2: 0 

Along W2: 0 

Through T3: 0 
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After entering the above data, the window should look like this: 

 

 

 
After entering all the data, press the “Save” button and then “OK.” 

STEP 14. Specifying the type of analyzed construction 

In this example, there is only one group of elements. This group is determined by 

the type of material and the cross-section of the model. To create a group of elements, 

go to “Meshing → Element Groups...” or press the button . After pressing 

the button, a new window will open, press the “Add...” button and then enter the 

following data: 

 

 
 



I. Major, M. Major, K. Kuliński 

254 

Group Number: 1 

Type: Beam 

“Basic” tab 

Description: Beam 

Element Sub-Type 3-D 

Include Warping DOF Checked 

Displacement: Default 

Stiffness Definition 

Use Material and Cross Section Checked 

Default Material: 1 

Default Cross Section: 1 

 
Remaining options should be left unchanged. The window view with the entered 

data is shown in the figure below: 

 

 
 
After entering the above data, press the “Save” button and then leave the window 

with the “OK” button. 
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STEP 15. Mesh subdivision 

In this example, line subdivision will be used. To define the division, go to “Meshing 

→ Mesh Density → Line...” or press the arrow next to the button  and then 

select “Subdivide Lines” from the available options. When a new window opens, 

enter the options according to the table below: 
 

Mesh Density 

Base Line: 0 

Method: Use Length 

Element Edge Length 0.01 

Progression of Element  

Edge Lengths: 
Geometric 

Number of Subdivisions: 20 

Length Ratio of Element  

Edges (Last/First): 
1 

Use Central Biasing instead  

of End Biasing 
Unchecked 

Assign to Following Lines 

 Line {p} 

1 1 

 

The remaining options are left unchanged. Then press the “Save” and “OK” buttons 

to leave the window. The window view with the entered data is shown in the figure 

below: 
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STEP 16. Definition of finite elements 

To define finite elements in the model, go to “Meshing → Create Mesh → Line...” 

or press the button . In the newly opened window, make sure that the type of 

elements used “Type:” refers to the “Beam”. The remaining data should be entered 

in accordance with the table below: 
 

Type: Beam 

Element Group: 1 

Nodes per Element: 2 

Orientation (Point overrides Vector) 

X: 0 

Y: 0 

Z: 0 

Auxiliary Point: 3 

Vector System: Skew 

Table “Lines to be Meshed” 

 Line {p} 

1 1 

 

The remaining options are left unchanged. After performing these operations, press 

the “Apply” button and then “OK”. The window view with the entered data is shown 

in the figure below: 
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After introducing finite elements, the model should look like this: 

 

 

Note: To check whether the cross-section has been entered correctly, perform the 

operations described below. To do this, go to “Display → Geometry / Mesh Plot → 

Modify...” or press the button . After the window appears: 

 

 

 
press the “Element Depiction” button. Another window will open, in which user 

must check the box for the “Display Beam Cross Section” option: 
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After performing the above operations, press the “Save” button and then “OK” thus 

leaving the “Define Element Depiction” window and then pressing “Apply” and then 

“OK” in the “Modify Mesh Plot” window. Currently, the main modeling window 

should look like this: 
 

 
 

One can notice in the drawing above, that the height of the I-beam is consistent  

with the X axis, which was intended, thus one can proceed to the next step. 
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Note: In older ADINA software versions if the same cross-section is defined so that 

the height of the I-beam coincides with the Z axis, leaving the load axis unchanged, 

errors may occur during calculations. The calculations may be interrupted or the 

model may be recalculated – but without taking into account the external load. It is 

recommended to pay attention to the messages from the “Log Window” each time. 

STEP 17. Save existing model to a file 

Each model should have been saved to a file between few steps taken in order to  

not lose the data. According to that select “File → Save as...” from the menu. When 

a new window opens, indicate the location of the saved file and its name. 

Note: Do not uses spaces in the file names, because it leads to an error! The space 

can be replaced with the underline character __. 

STEP 18. Starting calculations 

In order to start calculations, choose “Solution → Data File/Run” from the upper 

menu tabs, or choose  from the toolbars. Subsequently, input the path for saving 

the resultant file. However, before the user clicks the “Save” button, they should 

make sure that the “Run Solution” and “Automatic” function near the “Maximum 

Memory for Solution” options are selected in the window in the “Adina Structures 

Solution” group of options. After starting the calculations and recalculating the 

model, close all three dialogue windows which appeared during the calculations. 

Note: Depending on the complexity of the model and the number and type of finite 

elements used, model calculations may take from a few seconds to even several 

hours. 

STEP 19. Post-processing module (results) 

In order to go to the results module, change “ADINA Structures” to “Post-Process- 

ing” in the drop-down list of the “Module” toolbar. 

 

 

 
When the user is prompted that the changes in the drawing have not been saved, it is 

recommended to save the model by going to “File → Save” or using the button . 
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STEP 20. Opening the resultant file 

In order to open the resultant file, choose  from the toolbar, or choose “File → 

Open” from the upper menu tabs. 

Note: Depending on the specifications of the computer, the loading of a file in which 

a spatial analysis has been performed may take between about a dozen seconds up 

to even several minutes. The number of the applied finite elements and the number 

of nodes used have the greatest impact on the loading time of the file. 

STEP 21. Displaying the vibration modes 

In order to display the vibration modes, first go to “Definitions → Response...”, then 

in the newly opened window, in the “Type:” place, select the vibration modes – 

“Mode Shape” from the drop-down list. The figure below shows the window with 

the introduced change: 
 

 
 

After changing the result display type, press the “Save” button and then “OK” to exit 

the window. 

Note: The program will not automatically create a view of vibration mode. The main 

results window will contain the same model that was loaded earlier, but if the user 

try to change the results using the time manipulation arrows , the 

program will assume that the user wants to view the results concerning deflections, 

stresses, etc. It should be noted that pressing the manipulation arrows leads to revert 

changed options in the “Define Response” window back to the “Load Step”. According 

to that, one should once again change the “Type” option in the “Define Response” 

window to “Mode Shape”. 

In order to display the vibration mode results in the main window, first delete the 

current model using the button  and then . The main results window should 

look like this: 
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Currently, subsequent vibration modes can be displayed using manipulators 

, e.g. vibration mode 7 looks as follows: 

 

 

 
Note: “Reference Time” in the “Define Response” cannot be changed to other than 

“latest”. Thus, there are no vibration modes and frequency for consecutive time steps 

taken into analysis. 

Note: The example uses a concentrated force on purpose to make users aware that 

concentrated force and any other type of force have no effect on the vibration modes 

and vibration frequencies obtained in the program. 

STEP 22. Displaying the vibration frequency in list form 

To display vibration frequencies for a beam in the form of a list, go to “List → Value 

List → Zone...”. In the newly opened window make following changes: 
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Zone Name: WHOLE_MODEL 

Result Grid: DEFAULT 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Response Option 

Range of Responses Checked 

Response: DEFAULT 

Response Range: DEFAULT_MODE-SHAPE 

 

Variables to list 

1 Frequency/Mode FREQUENCY 

2 Frequency/Mode NATURAL_FREQUENCY 

 
After entering all the data, press the “Apply” button. The window view with the  

entered data is shown in the figure below: 
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The results can also be exported to a text file using the “Export...” button indicating 

the file name and its location. Such files are saved with the *.txt extension. 

STEP 23. Displaying the reaction and support moment 

Note: Since this example uses a concentrated force, the user can display maps of 

displacements, stresses, internal forces, etc. 

First, it is needed to switch back from vibration mode results to static calculations. 

To do this, go to “Definitions → Response...”. Then, in the newly opened window, 

select the “Load Step” option in the type of results to be displayed – “Type:” from 

the drop-down list. The remaining data in the window is left unchanged. Then press 

the “Save” button and then close the window with the “OK” button. The window 

view with the entered data is shown in the figure below: 

 

 
 

After performing the above operation, delete the current model  and reload  

the finite element mesh . Then, go to displaying the reaction (moment in the 

support) in the model – from the menu, select “Display → Reaction Plot → Create...” 

or press the  button located on the toolbar and when a new window opens,  

enter the following data: 
 

Reaction Quantity: MOMENT_REACTION 

Reaction Plot Style: DEFAULT 

Mesh Plot Name: MESHPLOT00001 

Result Control: DEFAULT 

 
After entering the data, press the “Apply” button, then enter the following data in  

the “Create Reaction Plot” window (reactions to normal/cutting forces): 
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Reaction Quantity: REACTION 

Reaction Plot Style: DEFAULT 

Mesh Plot Name: MESHPLOT00001 

Result Control: DEFAULT 

 
The views of the windows and the entered data are shown in the drawings below: 

 

 

 

 

 
After entering above mentioned data, press the “OK” button, thus leaving the  

window. 

In the main results window you can also display the acting force by pressing the 

button . 

To have a good view of the support reaction – moment, you need to change the plane 

from which the model is visible. To do this, select the arrow next to the button 

 and then select the “Iso View 1” option.  
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Next, activate the button , select the model with the left mouse button and  

use mouse movements to zoom out so that it fits in the result window. Then activate 

the button  again and arrange the model and legends in the window so that  

nothing overlaps. The resulting window is shown in the figure below: 

 

 

 

Note: When using time step manipulators  – it turns out that the 

arrows representing the moment in the support and the support reactions change. 

Displaying the legend again for the support moment and reaction at a different time 

step, it turns out that different values are obtained, even though the concentrated 

force was assumed to be constant over the entire length of the analysis. For example, 

for the time step “TIME 0.99200”, the results shown in the figure below are obtained. 

The impact value has been refreshed here by pressing the button  twice and,  

as you can see, it is constant – 2000 N. The legend at the beginning shows the  

reaction and support moment values in the “TIME 1.0000” step and even though  

the “TIME 0.99200” step is displayed there, this is an error in program display.  

Please also remember that the existing reaction and support moment legend cannot 

be refreshed, i.e. the results are displayed in the time step in which these legends 

were defined. 
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Note: The variability of the support reactions is related to the vibrations of the rod. 

The greater the amplitude in the deflection of the free end of the bar, the greater  

the reactions obtained in the place of clamped support. This should also be taken  

into account when displaying graphical and text maps of displacements, stresses, etc. 

To better illustrate the essence of the problem, enable the display of scaled bar dis-

placements by pressing the button , and then create an animation by pressing 

the button . After the animation is completed, go to “Display → Animate...” 

and then set the following data in the newly opened window: 
 

Movie Number: 1 

Number of Cycles: 1 

Minimum Delay: 10 

 

The window view with the entered data is shown in the figure below: 
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After entering the data, press the “OK” button. The animation will restart, but based 

on the entered data. To restart the animation defined in this way, press the button 

. The “Apply” button also starts the animation, however leaves the “Animate” 

window open, thus pressing the “OK” button will start the animation once again  

with predefined data. 

Note: In order to obtain the influence of an external force on the vibration frequency, 

use the “Restart Run” option. The use of this option is thoroughly discussed for  

problems 8 and 26 in the ADINA program manual, which can be found by going to 

“Help → ADINA Primer (pdf)...” in the program window. 
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EXAMPLE 7  

A CLAMPED-CLAMPED BEAM WITH A STEPPED CROSS- 

-SECTION. DEFINITION OF OBJECTS WITH A SPECIFIC 

LIFE CYCLE IN THE COMPUTATIONAL MODEL  

In this example activities related to modeling of stepped, a both ends’ clamped  

beam subjected to different dynamic loads. It is recommended for the reader to get  

acquainted with the previous examples, since some of the functions were discussed 

earlier. A diagram of the analyzed model is presented in Figure 25. 

 

 

Fig. 25. Scheme of an analyzed beam 

The following data is used in the analysis: 

– loads: 

*1 = 2 kN = 2000 N 

*2 = 4 kN = 4000 N  


 = 1 kN/m = 1000 N/m  

– material constants: 

segment A and B – steel S235JR 

� = 210 GPa = 2.1e�� Pa  
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� = 0.30  

� = 7860 kg/m� 

segment C – aluminum alloy 

� = 70 GPa = 7e�N Pa 

� = 0.33 

� = 2700 kg/m� 

The following dimensions have been assumed for the cross-sections: 

the A-A cross-section: 

+1 = 0.10 m 

1 = 0.008 m 

the B-B cross-section: 

+2 = 0.06 m 

the C-C cross-section: 

L = 0.10 m 

1 = 0.02 m 

Note: For training purposes, the present example assumes that segment B is a segment 

with a specified life cycle. For technological reasons, segment B becomes demolished 

at a time step of 1 = 0.5 s, thus leaving behind two independent beams (segments A 

and C). In the SI unit system used across this example, it is recommended to assume 

time in seconds (not in time steps). 

STEP 1. Definition of the type of analysis 

Upon opening the ADINA software, choose “ADINA Structures” from the “Module 

Bar” in the “Program Module” section, and choose “Dynamics-Implicit” from the 

drop-down list next to “Analysis Type”. 

 

 

Note: Since there are two types of possible to choose dynamic analyzes: “Dynamic-

-Implicit” and “Dynamic-Explicit”, it is recommended to consider time steps with  

a values higher than 1·10–4 as “Dynamic-Implicit”, and lower as “Dynamic-Explicit”. 

STEP 2. Entering the heading of the model 

In order to specify a heading, go to “Control → Heading…”. Subsequently, enter  

the project heading in the text box, e.g., “Stepped beam dynamics”. Upon entering  

a heading, click the “OK” button. 
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STEP 3. Definition of global boundary conditions 

Since the considered model is a planar model considered in the program default YZ 

plane, boundary conditions that do not participate in the analysis process should be 

excluded. To check which boundary conditions are active, go to “Control → Degrees 

of Freedom...”. In the newly opened window, all boundary conditions in the “Master 

Degrees of Freedom (Selected = Active)” option group should have their boxes 

checked. Make the following changes in the window: 

 

X-Translation Unchecked 

Y-Translation Checked 

Z-Translation Checked 

X-Rotation Checked 

Y-Rotation Unchecked 

Z-Rotation Unchecked 

 
The figure below shows the window with selected boundary conditions: 

 

 
 
The remaining data is left unchanged. After selecting the appropriate boundary  

conditions involved in the analysis, exit the window by pressing the “OK” button. 

STEP 4. Definition of points 

In order to define points in the model, go to “Geometry → Points → Define… “ from 

the menu or press the button . In the newly opened window, add points accord-

ing to the table below:  
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Point # X1 X2 X3 System 

1 0 0 0 0 

2 0 0.25 0 0 

3 0 1.00 0 0 

4 0 1.25 0 0 

5 0 1.50 0 0 

6 0 1.75 0 0 

7 0 2.00 0 0 

8 0 3.00 0 0 

9 0 0 0.1 0 

 
Subsequently, click “Apply” and “OK” in the main window for defining points.  

The window view with the entered data is shown in the figure below: 

 

 

STEP 5. Displaying point ID numbers 

To display point identifiers in the YZ plane, press the  button on the toolbar, 

and then press the  button, respectively. 
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STEP 6. Definition of lines 

All lines in the present example are straight lines, so the only one type of will be 

used – “Straight”. In order to define a line, choose “Geometry → Lines → Define…” 

from the upper menu, or click . Then click the “Add…” button in the newly 

opened window in order to add the first line. 

Note: After entering data from each table row, press the “Save” button and then 

“Add...” to add a new line from the next row until data from the last row is entered. 

Enter the data according to the table below: 

 

Line Number Point 1 Point 2 Type 

1 1 2 Straight 

2 2 3 Straight 

3 3 4 Straight 

4 4 5 Straight 

5 5 6 Straight 

6 6 7 Straight 

7 7 8 Straight 

 
When all the lines have been defined, click the “OK” button in order to confirm  

the input values. The window with data entered for the line with ID “7” is shown  

in the figure below: 
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Note: When adding lines one by one, there is no need to click the “Save” button. 

Just click the “Add…” button after inputting the identification numbers of points. 

The line will be created, and the user will go to the generation of a new line at once. 

However, clicking the “Save” button enables avoiding a situation in which, after 

closing the window with the X or the “Cancel” button, the last created line is not 

created. 

STEP 7. Displaying line ID numbers 

In order to display the numbers of lines for their easier identification, click . 

The model should look like in the figure below: 

 

 

STEP 8. Definition of boundary conditions (fixity characteristics) 

In order to define a fixity in the system, go to “Model → Boundary Conditions → 

Apply Fixity…”, or click . Since there are two clamped supports in the model, 

there is no need to define a new fixity, since a fixity named “ALL” has all the possible 

directions of translation and rotation blocked. When a new window opens, enter  

the following data: 

 

Fixity: ALL 

Apply to: Points 

 Point {p} 

1 1 

2 8 

 
After entering the data, press the “Apply” button and then leave the window with  

the “OK” button. Window presenting entered data is shown below: 
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Note: In the previous ADINA versions if no value is declared for a given point  

in the “Fixity” column (the box remains blank), upon clicking the “Save” button  

the program will automatically fill out the blank boxes with the boundary condition 

specified in the “Default Fixity” drop-down list. 

STEP 9. Displaying boundary conditions 

In order to display the defined boundary conditions in the main model window,  

click . 

STEP 10. Definition of load variability 

Since in the present example a “trapezoidal” load is used, it is necessary to create  

an additional function specifying the increment of the force multiplier in selected 

points. In order to define such a function, go to “Geometry → Spatial Functions → 

Line…”, then in the newly opened window click the “Add…” button. As shown in 

the analyzed scheme figure one can notice, that from the left side the “trapezoidal” 

load has 0.5q, and on the right side 1.0q. To obtain such an increment in line load 

enter the following data in the “Define Line Function”: 
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Function Number: 1 

Type: Linear 

Values at Specific Points 

u = 0: 0.5 

u = 0.5:  

u = 1.0: 1.0 

 
A view of properly declared values in the window is presented in the figure below: 

 

 
 
After entering the data, press the “Save” button, then you can close the window  

with the “OK” button. 

STEP 11. Definition of load variability (additional informations) 

It is possible to apply a load to a construction in three various ways: a variable load 

(2 points), a variable load described by a parabolic function, or a load declared by 

means of a table (linear variability). 

Three various types of loads will be examined for the present example, which exists 

in a single plane (2D). For the below presented examples it is assumed that the bar 

length is equal 1.00 m, and a linear distributed force is equal 1000 N.  

Load patterns along with the input data being possible to be declared in the software 

are presented below. 
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A linearly variable load 

The value of load is determined by the values used in the “u = 0” and “u = 1” points. 

Since a value of “0.8” is assumed for “u = 0” and “0” for the “u = 1.0” as shown  

in the table below: 
 

Function Number: … 

Type: Linear 

Values at Specific Points 

u = 0: 0.8 

u = 0.5:  

u = 1.0: 0.1 

 

the value of force will reach value of 1000·0.80 = 800 N in the left node and 100 N 

in the right node. The load scheme would look similar to that: 
 

 
 

The window with entered data would be: 
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Determining a load by means of a parabolic function 

It should be noted that in case of declaring a load, it is also possible to use negative 

values, which means that the load will have an opposite direction. In this case  

following data are used to obtain parabolic function of load pattern: 

 

Function Number: … 

Type: Quadratic 

Values at Specific Points 

u = 0: –10 

u = 0.5: 1 

u = 1.0: 5 

 
The window with introduced data would be: 

 

 
 
thus the load pattern would be: 
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Definition of any function for a continuous load  

It is possible to declare nearly any function for a continuous load. For example,  

when following data are introduced: 
 

Function Number: … 

Type: Tabular 

Number of points: … (i) 

 

In the table, are introduced “i” numbers characterizing virtual nodes created on  

a beam span in which the load will be applied. It means that if a user inputs 5 different 

rows, the beam will be divided into “i – 1” spans, and between these spans the data 

from “f(i)” column will be used. Moreover, it should be noted that between the con-

secutive “f(i)” a linear interpolation is used. Only in external virtual nodes (first/last) 

the value of force is the same as in the introduced in the table. For example, by  

introducing following values in the table: 
 

 i F(i) 

1 1 0 

2 2 0.6 

3 3 3 

4 4 –5 

5 5 1 

 

the window of “Define Line Function” would look like: 
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and the continuous line load would reach following variability: 

 

 
 
One can notice, that in the point “i” = 4, the value for the function used was “–5” 

thus one could expect the value of 5000 N, however, the value there is 4333 N. That 

software behaviour is connected with the use of linear interpolation between points. 

Note: When declaring the abovementioned function, with division into, e.g., three 

segments, where the first and last values are 0, while the middle one the value is 

equal 0.5, a proper result will not be achieved (see the figure below). 

 

 
 
It is clearly visible on the abovementioned scheme, the segment along which the load 

is distributed was not divided precisely into three sections, with the highest value  

of load occurring in the middle. On the other hand, a flattening was observed in  

the upper part of the graph, along with a value not corresponding to the adopted 

assumptions. 

STEP 12. Definition of loads 

Three different types of loads will be defined in present model – own structure’s 

weight, linear load and concentrated force. In order to define loads, go to “Model → 

Loading → Apply...” or press the  button. After opening a new window, the 

self-weight load of the structure will be declared first, so for the “Load Type:” option, 

select “Mass Proportional” from the drop-down list, then for the “Load Number:” 



I. Major, M. Major, K. Kuliński 

280 

option, press the “Define...” button. A new window will open, in which one should 

press “Add...” button to add a new load, then enter the data as shown in the table: 

 

Mass Proportional Load Number: 1 

Magnitude: 1 

Body #: 1 

Direction Vector 

X: 0 

Y: 0 

Z: –1 

Interpret Loading as (for potential-based fluid element only) 

Body Force Checked 

Description: None 

 
After entering the data in the window, press the “Save” button and then “OK”, thus 

returning to the “Apply Load” window. The window with the entered data is shown 

in the figure below: 
 

 
 
The “Apply Load” window should therefore be completed as follows: 

 

Load Type: Mass Proportional 

Load Number: 1 

Apply to: Model 
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In the table, the data should look like this: 

 

 Time Function… Label # 

1 1 1 

 
The window view with the entered data is shown in the figure below: 

 

 

 
After entering the data, press the “Apply” button, and then, without leaving the  

“Apply Load” window, select “Distributed Line Load” from the drop-down list next 

to “Load Type:”, and then press the “Define...” button next to the drop-down list of 

the “Load Number:” field. In the newly opened window, press the “Add...” button 

and enter the following data: 

 

Distributed Line Load Number: 1 

Magnitude (Force/Length): 1000 

Description: None 
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After entering the data, the window should look like this: 

 

 

 
After declaring the load value, press the “Save” button and then “OK” closing the 

“Define Distributed Line Load” window and return to the “Apply Load” window.  

In the “Apply Load” window following data should be entered: 

 

Load Type: Distributed Line Load 

Load Number: 1 

Apply to: Line 

 
In the table, the data should look like this: 

 

 Line {p} Aux. Point … Load Direction … Time Function 

1 2 9 Empty Z-Comp. Only Empty 1 

 

 Line {p} Aux. Point … Spatial Function… Apply-Load Label # 

1 2 9 Empty 1 2 

 
After entering the data, press the “Apply” button – this will cause the program to fill 

in the empty spaces with default values. 

The view of the windows along with the entered data is shown in the figures  

below: 
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Lastly, without closing the “Apply Load” window, change the load type “Load 

Type:” by selecting the “Force” option from the drop-down list – concentrated  

force. Declare the force again by pressing the “Define...” button located next to the 
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drop-down list for the “Load Number:” option. When a new window opens, enter 

the following data: 
 

Concentrated Force Number: 1 

Magnitude: 2000 

Force Direction 

X: 0 

Y: 0 

Z: –1 

Description: None 

 

Press “Add…” button once again and enter following data: 
 

Concentrated Force Number: 2 

Magnitude: 4000 

Force Direction 

X: 0 

Y: 0 

Z: –1 

Description: None 

 

After entering the data, for both forces, the definition windows should look similar 

to that presented below: 
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After entering the data, press the “Save” button and then close the window with the 

“OK” button. Returning to the “Apply Load” window, complete it as follows: 
 

Load Type: Force 

Load Number: 1 

Apply to: Point 

 

In the table, the data should look like this: 
 

 Point {p} Time Function… … Label # 

1 5 1 Empty 3 

 

The view of the “Apply Load” window with the entered data is shown in the figure 

below: 
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After entering the data, press the “Apply” button – the program will automatically 

fill the empty table columns with default values. Now in the same window make 

following changes: 

 

Load Type: Force 

Load Number: 2 

Apply to: Point 

 
In the table, the data should look like this: 

 

 Point {p} Time Function… … Label # 

1 7 1 Empty 4 

 
The view of the “Apply Load” window with the entered data is shown in the figure 

below: 
 

 

 
After entering all the data, press the “Apply” button – the program will automatically 

fill the empty table columns with default values. After performing all the above  

operations, you exit the window by pressing the “OK” button. 

STEP 13. Displaying active model loads 

In order to display the defined loads in the main model window, click .  

The model window should look like this: 
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STEP 14. Definition of cross-section(s) 

In order to define cross-section shapes, select “Model → Cross-Sections...” from the 

menu or press the button . After opening of a new window, press the “Add...” 

button and enter the following data: 
 

Section Number: 1 

Type: Pipe 

Dimensions 

Diameter D: 0.10 

Thickness T: 0.008 

 

Remaining options left unchanged. Press the “Save” button, and once again click 

“Add…”. The second cross-section is a circular solid bar. Thus, for the second  

cross-section input following data: 
 

Section Number: 2 

Type: Pipe 

Dimensions 

Diameter D: 0.06 

Solid Section Checked 

 

Once again, the remaining options in the window remain unchanged; save the 

changes with the “Save” button, and add another cross-section with the “Add…” 

button. The third cross-sections corresponds to the box-like profile. According to 

that enter the following data in the “Define Cross Section” window: 
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Section Number: 3 

Type: Box 

Dimensions 

Width W: 0.10 

Height H: 0.10 

Thickness T1: 0.02 

Thickness T2: 0.02 

 
The remaining options are left unchanged. Finally, save the input values with the 

“Save” and “OK” buttons. Windows with introduced data are presented below: 
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I. Major, M. Major, K. Kuliński 

290 

STEP 15. Definition of material constants 

In the present example there are two different materials which need to be defined.  

In order to define materials constants, go to “Model → Materials → Manage Mate-

rials...” or press the button , then in the newly opened window (if the material 

has been previously added to the program database), press the “Get MDB” button.  

A new window with a table should open, then select the material called “Steel”  

in the table and press the “Retrieve” button. After loading the material from the  

program database, press the “Close” button. In the “Manage Materials” window,  

in its lower part, in place of the table, there should be a material – “Steel” with  

the id number “1”. The retrieving material window is presented below: 
 

 
 

If the database does not contain the material required in the example, in the “Manage 

Materials” window, find the group relating to elastic materials – “Elastic”, and then 

press the “Isotropic” button – isotropic material. In the newly opened window, press 

the “Add...” button and enter the data in accordance with the table below: 
 

Material Number: 1 

Description: Steel 

Young’s Modulus  

(> 0) 
2.1e11 

Poisson’s Ratio 

(–1.0 < NU < 0.5) 
0.30 

Density 7859 

Coef. of Thermal Expansion  

(>= 0) 
0 
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After entering the values, press the “Save” button. If the user wants to add material 

to the program's database, press the “Put MDB” button. Close the window the “OK” 

button. 

For now, the second material will be added. From the “Elastic” group of materials 

press the “Isotropic” button. In the newly opened window hit “Add...” and enter  

following data: 

 

Material Number: 2 

Description: Aluminum 

Young’s Modulus  

(> 0) 
7e10 

Poisson’s Ratio 

(–1.0 < NU < 0.5) 
0.33 

Density 2700 

Coef. of Thermal Expansion  

(>= 0) 
0 

 
After completing the operation, exit the window by pressing the “OK” button. Again, 

as in the previous case, after leaving the window, in the lower part of the “Manage 

Material Definitions” window, the table should contain the “Aluminum” material 

model with an assigned identification number of “2”.  

The window views with the entered materials in the elastic material definition  

window are shown in the figures below: 
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The view of the material manager window should look similarly as: 

 

 

 
After performing all operations, exit the “Manage Material Definitions” window  

by pressing the “Close” button. 
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STEP 16. Definition of the number of time steps 

100 time steps will be used for the purpose of the present example, each with a value 

of 0.01 s. Therefore, the total duration of the analysis will fill the range of 0 up to  

1 s. In order to declare the number of time steps, go to “Control → Time Step…”. 

Then, in the newly opened window, enter the value of “100” in the first row of “# of 

Steps” column and in the same row under the “Magnitude” field, make sure to set 

the value to “0.01”. The window view is shown in the figure below: 
 

 

STEP 17. Definition of load variability in subsequent time steps 

In the present example, a sine function is used to declare a nonlinear increase in load 

over time. In order to declare the variability of load over time, go to “Control → 

Time Function…”, and then enter the following data: 
 

Time Function Number: 1 

Function Multiplier: Sinusoidal 

Angular Frequency (deg/time): 90 

Phase Angle (degrees): 0 

 

The remaining options are left unchanged. The value of 90 in “Angular Frequency 

(deg/time):” means that the load will reach its maximum value over a time of 1 s). 

As soon as changes are completed save the data via “Save” button and close the 

window with the “OK” button. A view of the values input in the window is presented 

in the figure below.  
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A graph of the variability of load over time is in turn presented in the figure below: 
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STEP 18. Specifying the type of analyzed construction 

The present example requires the creation of 3 various element groups. It is con-

nected with three bar segments, each with various cross-sectional area. The first and 

third segment of the bar (cross-sections A-A and C-C) are single-clamped (blocked 

6 degrees of freedom). For the purpose of learning, segment B has a specified  

life cycle of 0.50 s. According to the above, segment B of the analyzed model will 

take part in the redistribution of forces in the entire beam from the beginning of the 

analysis, up to its 50th step (a time of 0.50 s); subsequently, the middle segment will 

become demolished. In the following time steps, segment B becomes isolated from 

the model, meaning that the calculations are performed only with respect to segments 

A and C. 

In order to create an element group, go to “Meshing → Element Groups…”, or click 

. Clicking the button will open a new window, in which the “Add…” button 

should be clicked to add a new element group. The first created element group will 

be related to segment A, therefore input following data: 

 

Group Number: 1 

Type: Beam 

 “Basic” tab 

Description: Beam A 

Element Sub-Type 3-D 

Include Warping DOF Unchecked 

Displacements: Default 

Stiffness Definition 

Use Material and Cross Section Checked 

Default Material: 1 

Default Cross Section: 1 

 
Since the numerical values symbolizing the cross-section and the type of material  

(if the user has not remembered/written down the id numbers for proper materials 

and cross-sections) are quite confusing in the form of numbers, in both of these cases 

use the “… “ button to check the id numbers of the requested cross-section and type  
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of material. In the present example, choose the “… “ button next to the “Default 

Material” option, then upon confirmation that steel is a material with the number 

id = 1, the material manager window can be closed with the “Close” button. Make 

sure that a value of “1” is displayed as “Default Material” in the “Define Element 

Groups” window. Similar actions are taken in order to specify a cross-section –  

“Default Cross-Section”. In here, it is also worth it to use the “… “ button, and  

then in the new window find the cross-section requested by the user by selecting  

the individual id numbers from the drop-down list in the “Section Number” box.  

The present element group needs a cross-section in the form of a pipe; therefore,  

its assigned value of “1” in the “Define Cross-Section” window. Subsequently,  

close the “Define Cross-Section” window by means of the “OK” or “Cancel” button, 

making sure that a value of “1” is displayed in the “Define Element Groups” window 

next to the “Default Cross-Section” option. The remaining data in the window remain 

unchanged. Window view with introduced changes is presented below: 

 

 
 
As soon as changes are introduced in the “Define Element Group” window, press 

“Save” and once again “Add…” button. The second group will be segment B, which 

is made of steel, and has a cross-section in the form of a circular solid bar, also it is 

assumed that this segment has specified life cycle. According to that enter following 

data for the segment B in the “Define Element Group” window: 
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Group Number: 2 

Type: Beam 

 “Basic” tab 

Description: Beam B 

Element Sub-Type 3-D 

Include Warping DOF Unchecked 

Displacements: Default 

Stiffness Definition 

Use Material and Cross Section Checked 

Default Material: 1 

Default Cross Section: 2 

Advanced tab 

Element Birth/Death Time 

Birth: 0 

Death: 0.5 

 

The remaining options in the window remain unchanged. Finally, save the element 

group with an id = 2 with the “Save” button. The window with introduced data is 

presented below: 
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At last add the final element group by means of the “Add…” button. The third group 

covers a bar with a box-like cross-section, made of aluminum. Return to the “Basic” 

tab in the “Define Element Group” window. Similarly to the previous two groups 

enter following data: 
 

Group Number: 3 

Type: Beam 

 “Basic” tab 

Description: Beam C 

Element Sub-Type 3-D 

Include Warping DOF Checked 

Displacements: Default 

Stiffness Definition 

Use Material and Cross Section Checked 

Default Material: 2 

Default Cross Section: 3 

 

Once the operation is completed, the times of the appearance/disappearance of the 

element in the “Advanced” tab will be automatically set as 0 – an element will take 

part in the analysis over its entire duration. When all the operations are completed, 
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click the “Save” button in order to save the edited values, and the “OK” button. 

Window with entered data is presented below: 
 

 

STEP 19. Mesh subdivision 

In the present example, the same length of a finite element segment equal to 1.00 cm 

will be used for each beam. In order to specify the length value of a finite element, 

go to “Meshing → Mesh Density → Line…”. In the newly opened window, choose: 
 

Mesh Density 

Base Line: 0 

Method: Use Length 

Element Edge Length: 0.01 

Assign to Following Lines 

 Line {p} 

1 1 

2 2 

3 3 

4 4 

5 5 

6 6 

7 7 



I. Major, M. Major, K. Kuliński 

300 

For filling the table it is possible to use the “Auto…” button. As soon as this button 

is clicked, a new window appears in which following data should be introduced: 
 

 Line {p} 

From 1 

Step 1 

To 7 

 

then confirm the data with the “OK” button. Properly input data are presented below: 
 

 
 

 
 

When the abovementioned operations are completed, save the data with the “Save” 

button, and then leave the window with the “OK” button. 

It should be noted that faster method to create a mesh subdivision with identical  

size for each element is to go to “Meshing → Mesh Density → Complete Model…”. 

That method was used across previous examples. 
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STEP 20. Definition of finite elements 

In order to define finite elements in the model, go to “Meshing → Create Mesh → 

Line…”, or click  button, then enter the following options in the window: 
 

Type: Beam 

Element Group: 1 

Nodes per Element: 2 

Orientation (Point overrides Vector) 

X: 0 

Y: 0 

Z: 0 

Auxiliary Point: 9 

Vector System: Skew 

Table “Lines to be Meshed” 

 Line {p} 

1 1 

2 2 

3 3 

 

Remaining options are left unchanged. Press the “Apply” button, do not leave the 

window yet, and input following data once again: 
 

Type: Beam 

Element Group: 2 

Nodes per Element: 2 

Orientation (Point overrides Vector) 

X: 0 

Y: 0 

Z: 0 

Auxiliary Point: 9 

Vector System: Skew 

Table “Lines to be Meshed” 

 Line {p} 

1 4 

2 5 
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Remaining options are left unchanged. Once again press the “Apply” button, do not 

leave the window, and enter following data: 
 

Type: Beam 

Element Group: 3 

Nodes per Element: 2 

Orientation (Point overrides Vector) 

X: 0 

Y: 0 

Z: 0 

Auxiliary Point: 9 

Vector System: Skew 

Table “Lines to be Meshed” 

 Line {p} 

1 6 

2 7 

 

Remaining options are left unchanged. Hit the “Apply” button and leave the window 

by pressing “OK”. A properly filled out windows are presented in the figures below: 
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Note: Since the cross-sections used in the model are bisymmetric, the declared point 9 

specifying the orientation of the cross-section can have any position on the YZ, XY 

or XZ plane. In the remaining cases, in which the cross-section is not bisymmetric, 

that point specifies the line in which the width of the declared profile extends. 

Note: The window for defining finite elements can be entered before modeling  

the element groups, since the element groups can be created directly by means of the 

“Mesh Lines” or “Mesh Surfaces” window, etc. New element groups can be defined 

by means of the “ + “ button placed to the left of the text box belonging to the  

“Element Group” option. 

Note: It is possible to check which element group has its assigned proper cross-section 

and material by clicking the “…” button in the “Mesh Lines” or “Mesh Surfaces” 

window, etc., placed to the right of the text box belonging to the “Element Group” 

option. Faster and easier identification is performed when a given group of elements 

has an entry specified by the user in the “Description” box (typically, this box can be 

left blank with a default entry of “NONE”; however, such an entry does not make 

work easier when there is a large number of elements in the model). 

STEP 21. Definition of an automatic time stepping analysis 

In case the convergence is not met, the automatic time stepping analysis greatly help 

to achieve that convergence. In order to define an automatic time step in the absence 

of convergence, click the button related to analysis options: , and select the 

“Use Automatic Time-Stepping” box in the newly opened window. The window is 

presented in the figure below: 
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The remaining values remain unchanged.  

An automatic time stepping in the absence of convergence allows for obtaining  

a solution between user defined time steps via time division, e.g., for a step size of 

0.01 s and the existing absence of convergence in a time of 0.33 s, the program  

will start dividing the time interval between 0.33 s and 0.34 s in half; if this produces 

no results, the interval between 0.33 s and 0.335 s will be divided, etc. In order to 

better understand how this function works, it is recommended to click the “…”  

button, and then the “Help” button in the newly opened window.  

Once the automatic time step has been activated, the window can be closed with  

the “OK” button. 

STEP 22. Checking the correctness of the adopted model 

The first things to be checked are the loads, in particular by checking whether the 

mass-proportional load has been declared, since it is missing from the printout of 

loads in older ADINA software versions. In order to check the loads quantitatively, 

unfold “Loading” in the “Model Tree” window with the “ + “ button. 

 

 
 
As can be seen in the figure above, all the loads have been introduced. 

The next step is to check the declaration of element groups in the model. In order to 

do this, click . Unfortunately, the existing example is obstructed by segments 

showing the division of the element, like in the figure below: 
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In order to deactivate presentation of the division of the segment, go to “Display → 

Geometry / Mesh Plot → Modify…” or click  button, make sure that the “Mesh 

Plot Name:” option refers to “MESHPLOT00001”, and then click the “Line Depiction” 

button in the newly opened window. 

Once a new window has opened in the “Subdivision Attributes” group of options, 

unselect the “Display Line Subdivision” box, and then click the “Save” button and 

“OK”. The window with unchecked option is presented below: 

 

 
 
Upon returning to the “Modify Mesh Plot” window, also click the “Apply” button  

in it, and then “OK”. The model should look as follows: 
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In the model made by the author, segment A is indicated with the green color,  

segment B with orange, and segment C with pink, respectively.  

Note: The colors of beam segments listed above may differ between the author’s 

model and the user’s model.  

If it is still insufficient, return to the “Modify Mesh Plot” window, and by going  

to “Display → Geometry / Mesh Plot → Modify…”, click the “Element Depiction” 

button. In the newly opened window, select the box belonging to the “Display Beam 

Cross Section” options. Then save the changes with the “Save” button, and leave the 

“Define Element Depiction” window with the “OK” button. A view of the window 

is presented below. 

 

 

 
Upon returning to the “Modify Mesh Plot” window, click the “Apply” button and 

“OK”. Once the window has been closed, in order to increase legibility of the figure, 

it is also recommended to unselect the view of line and point numbers by clicking 

 and , in this order. At this time, the model should look like this: 
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All that remains is to check the length of the declared beam segments with specific 

cross-sections. In order to check segment length for cross-section A-A, click , 

and then click the first node, in which the bar begins, and then the second node,  

in which the bar ends. Once the operation is completed, a window with information 

about the distance between the two nodes along proper coordinate axes will appear.  

 

 
 
Of course, it is also possible to check other information about the model; however, 

for the needs of the present example, this is enough. 

STEP 23. Starting calculations 

In order to start calculations, choose “Solution → Data File / Run” from the upper 

menu tabs, or choose  from the toolbars. Subsequently, input a path for saving 

the resultant file. However, before the user clicks the “Save” button, they should 

make sure that the “Run Solution” and “Automatic Memory Allocation” options  

are selected in the window in the “Adina Structures Solution” group of options. 
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After starting the calculations and recalculating the model, close all three dialogue 

windows which appeared during the calculations. 

STEP 24. Saving existing model to a file 

Each model should have been saved to a file between few steps taken in order to  

not lose the data. According to that select “File → Save as...” from the menu. When 

a new window opens, indicate the location of the saved file and its name. 

Note: Do not uses spaces in the file names, because it leads to an error! The space 

can be replaced with the underline character __. 

STEP 25. Starting calculations 

In order to start calculations, choose “Solution → Data File/Run” from the upper 

menu tabs, or choose  from the toolbars. Subsequently, input the path for saving 

the resultant file. However, before the user clicks the “Save” button, they should 

make sure that the “Run Solution” and “Automatic” function near the “Maximum 

Memory for Solution” options are selected in the window in the “Adina Structures 

Solution” group of options. After starting the calculations and recalculating the 

model, close all three dialogue windows which appeared during the calculations. 

Note: Depending on the complexity of the model and the number and type of finite 

elements used, model calculations may take from a few seconds to even several hours. 

STEP 26. Post-processing module (results) 

In order to go to the results module, change “ADINA Structures” to “Post-Process- 

ing” in the drop-down list of the “Module” toolbar. 

 

 

 
When the user is prompted that the changes in the drawing have not been saved,  

it is recommended to save the model by going to “File → Save” or using the  

button . 
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STEP 27. Opening the resultant file 

In order to open the resultant file, choose  from the toolbar, or choose “File → 

Open” from the upper menu tabs. 

Note: Depending on the specifications of the computer, the loading of a file in which 

a spatial analysis has been performed may take between about a dozen seconds up 

to even several minutes. The number of the applied finite elements and the number 

of nodes used have the greatest impact on the loading time of the file. 

STEP 28. Creating a graph 

A graph showing the displacement of the end of segment A bar (in the place where 

segment A is connected to segment B) and at the end of segment C bar (at the con-

nection of segments B and C, respectively) will be created for the purpose of the 

present example. As can be seen after opening the file, the model has a gap between 

segments A and C. This is due to the fact that the analysis assumed a specific life 

cycle of segment B, and the model is displayed for the last time step adopted in the 

analysis. Therefore, when the life cycle has been exceeded, i.e., after the demolition 

of segment B, two independent systems will be created in the form of supports.  

By means of the arrow buttons  and the scalable displacement 

function activated with , it can be observed that segment B becomes demol-

ished at a time point of 0.50 s, while segments A and C begin vibrating along with 

the time passing by. Since in such a case the maps created for the bars are quite con- 

fusing when presenting the results of displacements, it is possible to create a graph 

of the displacement of two different points. 

In order to create a graph, start with declaring the points for which the displacements 

will be examined. In order to do that, go to “Definitions → Model Point → Node…”. 

Click the “Add…” button in the new window The user will be asked to enter a name; 

the free end of segment A is the first one to be entered; therefore, the name has been 

defined as “SEG_A_FREE_END”; subsequently, click the “OK” button, upon which 

the program will go the node selection window. Having the “Define Model Point 

(Node Point)” window opened, scalable displacements should be deactivated by 

means of . Subsequently, activate the view of nodes with ; it is also  

possible to activate the view of node numbers by means of . The next step is  
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the best possible magnification of the area of the free end of segment A. To this end, 

click , and then, while holding the left mouse button, select an area comprising 

the free end of segment A by means of a frame. The model should look like in the 

figure below. 

 

 
 
Since the zoom-in button is still active, it should be turned into a selection cursor  

by activating . Now it is possible to return to the “Define Model Point (Model 

Point)” window. Following data should be entered: 

 

Model Point Name: SEG_A_FREE_END 

Node #: 127 

Substructure: 0 

Reuse: 1 

 
Subsequently, save changes in the window using the “Save” button, and add another 

node by clicking the “Add…” button. Once again, the user will be asked to enter  

a name; in this case, the name is “SEG_C_FREE_END”; afterwards, click the “OK” 

button. Once again, without closing the “Define Model Point (Node Point)” window, 

start with shrinking the resulting model to the default value by clicking . Sub-

sequently, the model should be magnified; however, this time in the area of the free 

end of segment C. Click the zoom in button  again, and select a small area 

comprising the free end of segment C. The model should look like in the figure below. 

 

 
 
Now the node definition window can be activated again. Afterwards, enter following 

data: 
 

Model Point Name: SEG_C_FREE_END 

Node #: 177 

Substructure: 0 

Reuse: 1 
 



I. Major, M. Major, K. Kuliński 

312 

or choose the desired node from the model by means of the “P” button.  

The remaining options in the window remain unchanged. Finally, click the “Save” 

button in order to save changes, and then “OK” to close the window. 

The node definition windows are presented below: 

 

 

 

 

 
Note: It may happen that the node numbers in the user’s model are different from 

those in the presented example; therefore, it is recommended select proper nodes  

for the purpose of the present example. 

With both nodes defined, it is possible to clear the resulting model window with 

. The selection cursor should also be chosen by clicking . After the above-

mentioned operations, it is possible to start creating a graph. To this end, go to 

“Graph → Response Curve (Model Point)…”. Open a new window, which looks  

as follows. 
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Functions available in the left part of the window refer to the X and Y axes of the 

graph coordinate system.  

– “Variable” – in this drop-down list it is possible to choose the time, displacement, 

stress, etc.; the second drop-down list helps to choose proper functions, i.e.,  

if displacement is selected, the second drop-down list will allow for specifying 

the axis along which the displacement should be examined.  

– “Model Point” refers to the node which has been declared by the user.  

– “Result Control” enables changing the view of values on the graph, i.e., specify-

ing the type of interpolation between points on the graph, etc.  

– “Smoothing Technique” enables specifying the manner of smoothing the maps – 

the function is useful for “2-D Solid” – and “3-D Solid”-type models. 

In the right part of the window there are options related to the graph itself – the line 

type of the X and Y axes, the curve type of the presented function, etc. 

– “Plot Name” – enables specifying whether a new graph would be created, or 

whether additional curves would be added to an already existing graph. 

– “Graph Style” – enables defining a single style including the options presented 

below, so that each option does not have to be defined separately. This function 

includes the following options: “X-Axis”, “Y-Axis”, “Curve Depiction”, “Graph 

Depiction” and “Subframe”. 
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– “X-Axis” and “Y-Axis” – options related to displaying the X and Y axes on  

the graph. 

– “Curve Depiction” – options related to displaying a curve for specific variables 

on the graph. 

– “Graph Depiction” – options for displaying the graph window. 

– “Subframe” – options related to the graph frame. 

– “Response Range” – options related to the time step adopted on the graph. 

The analyzed example will use all the options related to the view of the graph.  

Start with declaring options related to displaying the graph and the curve directly; 

therefore, starting from the beginning, click the “…” button next to “X-Axis”. A new 

window will appear, which is presented below: 

 

 
 

 
In the present window, click the “Add…” button, enter a new name, e.g., “X_axis”, 

and click “OK”. Then enter following data: 
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… 

Label Attributes 

Type: Custom 

Color: BLACK 

Font Size: 0.40 

Unit: CM 

Scale Factor: 1 

Table: 

 Label: 

1 Analysis time 

Appearance 

Color: BLACK 

Line Width: 0 

Unit: CM 

Font Size: 0.30 

Unit: CM 

Draw Line at Value = 0 Checked 

Tick Direction 

Out Checked 

Number of Minor Ticks: 10 

Draw Line at Each Major Tick Unchecked 
 

Remaining options are left unchanged. The window with changed data is presented 

below: 
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As soon as the settings for the X axis have been specified, click the “Save” button. 

Note: Since the settings for the Y axis are exactly the same as for the X axis, their 

input can begin directly from the window in which the values of X were defined,  

or it is possible to close the window with the “OK” button, and then click the “…” 

button in the “Display Response Curve (Model Point)” window next to the “Y-Axis” 

option in the right part of the window.  

The present example uses a faster method, which means inputting the settings for  

the Y axis directly from the window in which values for the X axis were defined. 

According to that, click the “Add…” button, enter a name, e.g., “Y_Axis”, and click 

the “OK” button. Similarly, as before, enter following data: 

 

… 

Axis Type and Value Range 

Linear Checked 

Min. Value: –15e-4 

Max. Value: 0 

Automatically Rescale Unchecked 

Label Attributes 

Type: Custom 

Color: BLUE 

Font Size: 0.40 

Unit: CM 

Scale Factor: 1 

Table: 

 Label: 

1 Z-Displacement 
 

Appearance 

Color: BLUE 

Line Width: 2 

Unit: PIXELS 

Draw Line at Value = 0 Checked 

Tick Direction 

Out Checked 

Number of Minor Ticks: 5 

Draw Line at Each Major Tick Checked 
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Finally, save the input data with the “Save” button, and leave the window with  

the “OK” button. The window with introduced data should look similar to that: 

 

 

 
In the “Display Response Curve (Model Point)” window, choose the “…” button 

from its right part, belonging to the “Curve Depiction” option. A new window will 

open. For the purpose of the present example, two line types will be created, one 

specifying the free end of segment A, the other referring to the free end of segment 

C. Click the “Add…” button in the “Define Graph Curve Depiction” window, and 

then enter the name “A-A” and click “OK”. Enter following data: 
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 “Curve” tab 

Symbol Attributes 

Display Curve Symbol Checked 

Symbol: CURVE 

Interval: 0 

Color: BLACK 

Size: 3 

Unit: Pixels 

Line Attributes 

Solid Checked 

Color: GREEN 

Width: 2 

Unit: Pixels 

X-Axis-To-Curve Line Attributes 

Draw Lines from X-Axis to Curve Points Checked 

Color: GRAY 

Width: 1 

Unit: Pixels 

 “Legend” tab 

Legend Attributes 

Type: Custom 

Color: GREEN 

Font Size: 0.25 

Unit: CM 

Scale Factor: 1 

Placement 

Automatic Checked 

Display Curve Symbol in Legend Checked 

Custom Legend: 

 Legend: 

1 SEG_A_FREE_END 

 
The “Save” button can be clicked upon inputting all the data. A view of the window 

with the input values is presented below: 



Example 7. A clamped-clamped beam with a stepped cross-section. Definition of objects with a specific … 

319 

 

 

 

 
All that remains is to create parameters of the curve specifying the displacement 

along the Z axis of the free end of segment C; therefore, click the “Add…” button  

in the same window (“Define Graph Curve Depiction”), enter the name “C-C”,  

and click the “OK” button. Then, choose following options and data: 
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 “Curve” tab 

Symbol Attributes 

Display Curve Symbol Checked 

Symbol: CURVE 

Interval: 0 

Color: BLACK 

Size: 3 

Unit: Pixels 

Line Attributes 

Solid Checked 

Color: RED 

Width: 2 

Unit: Pixels 

X-Axis-To-Curve Line Attributes 

Draw Lines from X-Axis to Curve Points Unchecked 

Color: GRAY 

Width: 1 

Unit: CM 

 “Legend” tab 

Legend Attributes 

Type: Custom 

Color: RED 

Font Size: 0.25 

Unit: CM 

Scale Factor: 1 

Placement 

Automatic Checked 

Display Curve Symbol in Legend Checked 

Custom Legend: 

 Legend: 

1 SEG_C_FREE_END 

 
The remaining options remain unchanged, and the input changes should be con-

firmed by the “Save” button and “OK”, thus closing the “Define Graph Curve  

Depiction” window. Properly filled out windows are presented below: 
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Upon returning to the “Display Response Curve (Model Point)” window, choose  

the “…” button in the right part of the window for the “Graph Depiction” option, 

then click the “Add…” button in the new window, enter a name, e.g., “Graph_1”, 

and click “OK”. Make following changes in the window: 
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Box Attributes 

Display Graph Box Checked 

Color: Black 

Line Width: 2 

Unit: Pixels 

Scale Factor: 1 

Title Attributes 

Type: Custom 

Color: VIOLET 

Font Size: 0.60 

Unit: CM 

Scale Factor: 1 

Placement 

Automatic Checked 

Graph Title: 

 Title 

1 Displacement vs Time 

 

Upon inputting all the changes, click the “Save” and “OK” buttons. A window with 

the input data is presented below: 
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Upon returning to the “Display Response Curve (Model Point)” window, all that 

remains is the “Subframe” option related to the size of the graph; click the “…” button 

belonging to this option, and the “Add…” button in the new window, enter the name 

“New_frame”, and confirm it with the “OK” button. In the window enter following data: 
 

Depiction Name: NEW_FRAME 

Type: CUSTOM_SIZE 

Custom Subframe Size 

X: 0 

Unit: Percent 

Y: 0 

Unit: Percent 

Width: 100 

Unit: Percent 

Height: 50 

Unit: Percent 

 

Leave the remaining options unchanged. Confirm the input changes with the  

“Save” button, and leave the window with the “OK” button. A view of the window 

is presented below: 
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In the main “Display Response Curve” window, the “Response Range” option will 

not be changed, since the graph will present the displacement of points from the 

beginning to the very end of the analysis (100 time steps, 0.01 s each). 

Note: In the present example, there is no need to create a “Graph Style”, since the 

graph will ultimately have 2 curves, which causes certain complications when using 

“Graph Style”. This option should be mainly used when it is certain that the graph 

consists of only one curve. 

Note: The graph defined in this example is adjusted to being displayed against  

a white background. Against a black background, many of the applied functions  

may not be visible; therefore, if the user uses a black background, it is recommended 

to change them to white by means of “Edit → Background Color…”, then choose 

the color “WHITE” from the drop-down list and confirm it with the “OK” button. 

Once the abovementioned data have been input, a graph can already be created.  

In the “Display Response Curve (Model Point)” window make following changes: 

 

X Coordinate 

Variable: Time 

 TIME 

Model Point: SEG_A_FREE_END 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Y Coordinate 

Variable: Displacement 

 Z_DISPLACEMENT 

Model Point: SEG_A_FREE_END 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Graph Attributes 

Plot Name: Empty 

Graph Style: Empty 

X-Axis: X-AXIS 

Y-Axis: Y_AXIS 

Curve Depiction: A-A 

Graph Depiction: GRAPH_1 

Subframe: FRAME 

Response Range: DEFAULT 
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The values defined in the whole window in the form of a drawing are presented 

below: 

 

 

 
Subsequently, click the “Apply” and “OK” buttons. The model window should look 

like in the figure below. 

 

 

 
In the figure above, some of the texts overlap the graph. They can be moved by 

means of , by holding a given text with the left mouse button and moving it in 

the model window. 

A line referring to the free end of segment C should still be added to the graph. Again, 

go to the graph definition window “Graph → Response Curve (Model Point)”. In the 

left part of the window related to the view of variables on the graph, act similarly 

like when defining a graph for a point from segment A. Make following changes: 
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X Coordinate 

Variable: Time 

 TIME 

Model Point: SEG_C_FREE_END 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Y Coordinate 

Variable: Displacement 

 Z_DISPLACEMENT 

Model Point: SEG_C_FREE_END 

Result Control: DEFAULT 

Smoothing Technique: DEFAULT 

Graph Attributes 

Plot Name: GRAPHPLOT00001 

Graph Style: Empty 

X-Axis: X-AXIS 

Y-Axis: Y-AXIS 

Curve Depiction: C-C 

Graph Depiction: GRAPH_1 

Subframe: FRAME 

Response Range: DEFAULT 

 
It is critical to change the blank box to “GRAPHPLOT00001” in the drop-down list 

of the “Plot Name:” box. If this option is not set, a separate graph will be created; 

the curve referring to the free end of the bar located in the left part of segment C will 

not be added to the previously created graph referring to the free end of the bar in 

the right part of segment A. A properly filled out window is presented below. 
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Upon inputting all the data, click the “OK” button. 

The model should look as follows: 

 

 
 

Note: The text overlapping the graph was moved by means of . 

The figure above presents a graph created in a frame in the lower part of the window, 

with dimensions of 100% of its width and 50% of its height. These settings have 

been input in the “Define Subframe Depiction” window, upon selecting the “…” 

button belonging to the “Subframe” option from the “Display Response Curve 

(Model Point)” window. Such a manner of displaying the graph is a desirable proce-

dure when, apart from the graph, the resultant maps are to be displayed for the model. 

Note: It is also possible to zoom in and out of the graph by using , or by moving 

the mouse while holding the CTRL key. 
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A sample window with a graph and a map of displacements is shown in the figure 

below: 
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SUMMARY 

Dear reader, if you have completed all the examples described in this book, then you 

already have sufficient knowledge on the ADINA software, enabling you to examine 

the technical subjects related to building structures by yourself. The ability to com-

plete a given numerical model also makes it easier to operate on other programs 

based on the finite element method, like ABAQUS, ANSYS, CATIA, etc. In order 

to broaden theoretical knowledge about the finite element method, go to [1-10] from 

the list of references. Information regarding the ADINA software as well as its avail-

able functions and their application are described in [11-14]. Some design aspects 

are also discussed on the website of the software, in the Support/Tech Briefs tab [15]. 

Moreover, operation by means of commands entered in the command line of the 

main menu of the ADINA software is presented in publications [16-19]. Various 

types of publications constitute a valuable source of information regarding the shap-

ing of numerical models as well as their calculation and application. Selected publi-

cations related to numerical calculations by means of the ADINA software can be 

found in scientific journals available in printed and electronic version i.e. [20-22].  

A broader review of publications from various authors indirectly related to the 

ADINA software and its application are presented on the website of the software,  

in the Support/Publications tab [23]. It should be mentioned that the ADINA soft-

ware has an additional guidebook [24] presenting the modeling process step by step. 

Apart from the present book, it is also worth it to get acquainted with the examples 

presented. This guidebook can be found directly in the ADINA program, by going 

to the “Help/ADINA Primer (pdf)…” tab. 

It should be pointed out that the tools based on the finite element method and the 

acquired knowledge from a given field of science can be used to perform numerical 

calculations of a model, for which calculations using the traditional method would 

be too time-consuming, and thus uneconomical, as well there is a risk of making  

an error due to applied simplifications. Therefore, the programs provide the ability 

to produce correct results in a short time, assuming that all the input data have been 

introduced properly. According to the above, it can be noticed that programs based 

on the FEM are the future of the pursued projects and research, allowing for better 

understanding of the behavior of a given model or phenomenon, with no need to 

perform expensive laboratory tests. 
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